Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 6 Antworten, has 2 Teilnehmer.

Last updated by Andreas W. vor 1 Woche, 5 Tage.

Assigned support staff: Andreas W..

Author Artikel
September 3, 2019 um 4:18 pm #4506199

hubertusH

Hallo liebes WPML Support Team,

wir haben bei der Optimierung mit YOAST ein Problem in der Einstellung von Index und No-Index von durch WPML gesteuerten Unterseiten. Stellen wir eine auf no index werden alle damit verknüpften Seiten ebenfalls auf no index gestellt. Gewollt ist, dass manche Seiten auf index, andere Seiten aber auf no index gestellt werden. Wir haben diesen Thread befolgt: https://wpml.org/de/forums/topic/keine-unterschiedliche-meta-robot-einstellung-fuer-yoast-seo-moeglich-noindex/ das funktioniert aber nicht. Können Sie uns hierzu etwas weiterhelfen? Das wäre großartig!

Herzlichen Dank und beste Grüße!
Hubertus Huber

September 3, 2019 um 5:27 pm #4506699

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank, dass Sie das WPML Support Forum kontaktiert haben.

Anscheinden wird das Custom Field "no-index" oder "index" beim Übersetzen kopiert. Gehen Sie bitte auf eine demenstprechende Seite und scrollen Sie zum Multilingual Content Setup (einstellung des mehrsprachigen Inhaltes). Sie sollten diese oben erwähnten Custom Fields (benutzerdefinierte Felder) im Bereich "Systemfelder anzeigen" finden.

Setzten Sie diese hier auf "Nicht übersetzen" oder "not translate". Bestätigen Sie dann die Eingabe und aktualisieren Sie die Seite. Übersetzen Sie die Seite nun erneut, wobei Sie im Grunde nur die bestehende Übersetzung im WPML Übersetzungseditor bestätigen müssen.

Sollten Sie Hilfe benötigen oder das Problem auf diese Weise nicht gelöst werden können, so kontaktieren Sie mich bitte.

Wir können dann versuchen eine Lösung wie im folgenden Ticket anzuwenden, allerdings mit dem Unterschied, dass wir die Custom Fields zu Übersetzung ignorieren wollen.

https://wpml.org/forums/topic/wpml-and-yoast-seo-do-not-sync-meta-robots-noindexindex-field/

Mit freundlichen Grüßen
Andreas

September 4, 2019 um 8:31 am #4509277

hubertusH

Lieber Andreas,

vielen Dank für deine ausführliche Beschreibung. Wenn ich die Einstellung auf "Nicht übersetzen" setze und speichere, dann wird diese Einstellung nicht übernommen. Sollen wir nach der Anleitung vorgehen, die Sie oben beschrieben haben?

September 4, 2019 um 4:17 pm #4512841

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich möchte einen temporären Zugriff (wp-admin und FTP) auf Ihre Site anfordern, um das Problem genauer zu untersuchen. Besser wäre eine Testseite, an der das Problem repliziert werden kann.

Die dafür erforderlichen Felder finden Sie unterhalb des Kommentarbereichs, wenn Sie sich anmelden, um Ihre nächste Antwort zu hinterlassen. Die Informationen, die Sie eingeben werden, sind privat, was bedeutet, dass nur Sie und ich sie sehen und darauf zugreifen können.

Vielleicht muss ich Ihre Site lokal replizieren. Dazu muss ich vorübergehend ein Plugin namens „Duplicator“ auf Ihrer Site installieren. Dadurch kann ich eine Kopie Ihrer Website und Ihrer Inhalte erstellen. Sobald das Problem behoben ist, lösche ich die lokale Site. Lassen Sie mich wissen, ob dies bei Ihnen in Ordnung ist.

 WICHTIG

Machen Sie eine Sicherungskopie der Site-Dateien und der Datenbank, bevor Sie uns den Zugriff gewähren.
Wenn Sie die Felder "wp-admin / FTP" nicht sehen, werden Ihre Anmeldedaten für Post und Website als "PUBLIC" (Öffentlich) festgelegt. Veröffentlichen Sie NICHT die Details Ihrer Website, es sei denn, Sie sehen die erforderlichen wp-admin / FTP-Felder. Wenn Sie dies nicht tun, bitten Sie mich, die private Box zu aktivieren. Die private Box sieht so aus:
hidden link

Mit freundlichen Grüßen
Andreas

September 4, 2019 um 5:01 pm #4513071

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Um ein Änderung an den Custom Field vorzunehmen müsste ich unser Plugin Translation Management installieren und wollte fragen, ob das für Sie in Ordnung wäre?

https://wpml.org/documentation/translating-your-contents/

Mit freundlichen Grüßen
Andreas

September 6, 2019 um 5:02 pm #4526865

hubertusH

Lieber Andreas, gern!

Liebe Grüße!
Hubertus

September 6, 2019 um 6:15 pm #4527121

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Durch die Installation des Translation Managements haben Sie nun die Möglichkeit unsere WPML Übersetzungseditoren zu verwenden. Ich habe als standard den klassischen Übersetzungseditor gewählt.

Mehr Informationen dazu hier:

https://wpml.org/de/documentation-3/ubersetzen-ihrer-inhalte/verwendung-des-translation-management-moduls-von-wpml/

Ich habe nun unter WPML -> Settings -> Custom Fields Translation das Custom Field namens _yoast_wpseo_meta-robots-noindex auf "Not translate" stellen können. Um das Feld in den Optionen sichtbar zu machen müssen Sie auf "Show System Fields klicken".

Sie können das Feld auch auf "translate" stellen und es dann mit dem WPML Translation Editor übersetzen, wenn diese für bestimmte Inhalte aktiviert wurde.

Bitte testen Sie, ob die Yoast Übersetzungen nun wie erwartet funktionieren.

Mit freundlichen Grüßen
Andreas