Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 0.27 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: Nach eineme Update ist die englische Version mit einer Maitenance-Notiz blockiert. Theme is Enfold.

Solution: Da in Enfold die Theme-Optionen separat für jede Sprache einstellbar sind, war in den englischen Theme-Optionen die Checkbox dafür versehentlich aktiviert.

Da keine Seite definiert worden war, erschien nur ein kleiner Default-Text vom WP-Maintenance auf der Seite.

Sobald die Checkbox deaktiviert war, waren die englischen Seiten wieder sichtbar.

Relevant Documentation:

Schlagwörter: 

This topic contains 2 Antworten, has 2 Teilnehmer.

Last updated by kamilK-11 vor 11 Monate, 2 Wochen.

Assigned support staff: Cristina.

Author Artikel
Oktober 30, 2018 um 1:44 pm #2862051

kamilK-11

Seit dem letzten Update funktioniert unsere Englische Seite nicht mehr korrekt. Irgendwie ist diese im maintenance modus hängengeblieben. Wo kann ich diesen für eine spezifische Sprache ein/aus/umstellen?
die andreen beiden sprachswitches (ch&at) funktionieren wie gehabt.
im eingeloggten zustand funktioniert alles reibungslos.

die URL ist hrworks.de/en und es wird nur "Sorry, we are currently updating our site - please try again later." angezeigt.

eine .maitenance file habe ich nicht gefunden, als auch den cache von wpml gelöscht. auch das caching plugin gecheckt, wie auch den AJAX Cookie gesetzt.

Oktober 30, 2018 um 5:33 pm #2863098

Cristina

Hallo Kamil,

vielen Dank für die Anfrage und die beigefügten Debug-Informationen.

Enfold hat in den Theme-Optionen einen eigenen Maintenance Mode. Er befindet sich in Enfold > Theme-Options ganz unten als "Maintenance Mode" mit einer Checkbox.

Da in Enfold die Theme-Optionen separat für jede Sprache einstellbar sind, checken Sie bitte, ob in den englischen Theme-Optionen diese Checkbox versehentlich aktiviert wurde.

Falls ja, deaktivieren Sie die Checkbox. Wenn hier keine weitere Seite definiert wurde, ist eventuell die Default-WordPress Meldung erschienen.

Wenn der Maintenance-Mode nicht von dem Theme Enfold gesetzt wird, sondern während des Updates von WordPress selbst erstellt worden ist, probieren Sie doch, ob es hilft, für einen Moment die WPML Plugins in der Liste der aktiven Plugins im WordPress Admin zu deaktivieren.

Denn es könnte sein, dass diese Meldung von WordPress selbst erzeugt worden ist, das ja während eines Updates einen eigenen Maintenance-Mode schaltet. Wenn hier etwas nicht korrekt aktualisiert werden konnte, ist das wohl für die Englischen URLs hängengeblieben.

Dann den Cache leeren und in Plugins > Neu installieren > kommerziell auf den WPML Update Button zu klicken, falls hier eine Komponenten nicht richtig heruntergeladen wurde. Eventuell hilft es dann auch, wenn Sie eine frische Kopie des WPML Plugins per FTP in den Plugin-Ordner laden, falls eine Datei nicht korrekt beim Update heruntergeladen und gespeichert wurde.

Wenn Sie dann WPML in der Liste der Plugins wieder aktivieren, sollte das alles funktionieren.

MFG,
Cristina

Oktober 31, 2018 um 7:17 am #2864560

kamilK-11

Vielen lieben Dank für diese präzise und umfangreiche Antwort! Es war tatsächlich der Enfold Wartungsmodus.

Somit ist das Problem erledigt.