Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

This topic contains 5 Antworten, has 2 Teilnehmer.

Last updated by Bruno vor 5 Jahre, 10 Monate.

Assigned support staff: Bruno.

Author Artikel
November 18, 2013 um 5:31 pm #294217

David

Hallo,

wir haben Probleme mit Permalinks nach der WPML-Installation.

Das Theme ist Enfold, installierte Plugins sind WooCommerce, Antispam Bee, Jetpack. Alles aktuell.

Sobald ich WPML aktiviere, die Grundeinstellungen abspeichere und danach die WordPress-Permalinks aktualisiere (/%postname%/, sonst Standard), erscheinen beim Aufrufen von Seiten und Beiträgen nur noch 404er - WooCommerce-Seiten werden aber tadellos angezeigt.

Wenn ich auf Standard-Permalinks (?p=123) umstelle, geht alles, bei "schönen" Permalinks tritt das Problem jedoch sofort wieder auf.

Nach einer kompletten Deinstallation von WPML (über die Support-Seite) gehen "schöne" Permalinks überall wieder problemlos, auch nach erneutem Speichern von Permalinks.

Was kann da los sein?

Viele Grüße
David

November 18, 2013 um 6:27 pm #294244

Bruno
Supporter

Languages: Englisch (English ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Dear David,

Our support is not available in German at the moment. I can help you in English. This is good for you?

Thank you.

November 20, 2013 um 10:39 am #295274

David

Hi Bruno,

we have problems with permalinks after the installation of WPML.

Theme is Enfold, used plugins are WooCommerce, Antispam Bee, Jetpack. All up to date.

After the installation of WPML and then saving the permalinks (/%postname%/, other settings standard), we see only 404s on pages and posts - except of WooCommerce, it works.

No problems after switching to standard permalinks (?p=123), but with pretty links the problems appear again.

After a complete deinstallation of WPML (support page) there are no problems with pretty permalinks anymore!

Best regards
David

November 20, 2013 um 8:15 pm #295602

Bruno
Supporter

Languages: Englisch (English ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Dear David,

Please, you can disable all non-WPML plugins to test? Also, if possible, please switch to the default theme. That way we can see if there's some incompatibility between plugins and WPML.

Thank you.

November 20, 2013 um 8:39 pm #295615

David

Hi Bruno,

disabling all plugins except of WPML does not help. The problem exists only with the Enfold theme (contact with the support already), but: a complete deinstallation of WPML resolves all permalink problems.

Best regards
David

November 21, 2013 um 9:36 pm #296236

Bruno
Supporter

Languages: Englisch (English ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Dear David,

The Enfold is compatible with WPML: http://wpml.org/2013/04/now-compatible-enfold-azione-handmade-gigawatt-and-background-manager/

I'll ask for some information so I can verify the problem. The fields for you to insert the credentials will be below its comment field.

Thank you.

Das Thema ‘[Geschlossen] Permalink-Probleme nach WPML-Installation’ ist für neue Antworten geschlossen.