Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 6.40 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem:
Ich möchte im Plugin "Reading Time WP" kann ich die zu erwartende Lesedauer übersetzen.

Solution:

Fügen Sie folgende XML-Konfiguration zu WPML -> Einstellungen -> Benutzerdefinierte XML-Konfiguration hinzu:

<wpml-config>
    <admin-texts>
        <key name="rt_reading_time_options">
            <key name="label" />
            <key name="postfix" />
            <key name="postfix_singular"/>
        </key>
    </admin-texts>
</wpml-config>

Relevant Documentation:
https://wpml.org/documentation/support/language-configuration-files/#using-wpml-language-configuration-file-with-child-themes

Schlagwörter: 

This topic contains 19 Antworten, has 2 Teilnehmer.

Last updated by marioM-49 vor 2 Monate.

Assigned support staff: Marcel.

Author Artikel
August 11, 2019 um 9:19 pm #4377549

marioM-49

Hallo,

im Plugin "Reading Time WP" kann ich die zu erwartende Lesedauer einstellen.

Wie bekomme ich es hin, dass in der jeweiligen Sprachversion eine Übersetzung angezeigt wird?

Danke und Gruß
Mario

August 12, 2019 um 8:11 am #4379071

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Mario,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Dieses Plugin wurde bisher von uns nicht getestet. So viel ich herausgefunden habe, arbeitet das Plugin mit einem Shortcode, welcher im Template hinterlegt werden kann. Wird dieser nicht in die übersetzte Version übernommen?

Lt. dem Plugin Code werden getText() Variablen verwendet. Es sollte sich dann der Text (Der Text vor der Minutenanzeige) im Template über unsere String Translation Tabelle übersetzbar sein.

hidden link

Bitte geben Sie mir Bescheid, wenn dies nicht funktioniert. Dann können wir einen Test aufsetzen, womit unserer Compatibilty Team den Plugin Autor kontaktieren kann.

Freundliche Grüße
Marcel

August 12, 2019 um 11:26 am #4380345

marioM-49

Hallo Marcel,

richtig, das Plugin arbeitet mit Shortcodes, die werden automatisch ins Template eingepflegt.

In der String Tranlslation jedoch befindet sich der entsprechende String jedoch nicht (ich habe einen Screenshot hinzugefügt).

Danke und Gruß
Mario

August 12, 2019 um 1:52 pm #4381469

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Mario,

können Sie bitte versuchen das Problem auf folgende isolierten Sandbox nachzustellen? hidden link

Sie müssen dazu bitte das betroffene Plugin hochladen und konfigurieren. WPML ist bereits in Ihren 3 Sprachen vorkonfiguriert.

Hier kann ich dann versuchen die Strings aus der wp_options Tabelle übersetzbar zu machen oder ggf. können wir es dann an unserer Compatibility Team weiterleiten.

Vielen Dank

Freundliche Grüße
Marcel

August 12, 2019 um 2:39 pm #4381695

marioM-49

Hallo Marcel,

erledigt. Hier hidden link wird jetzt oben auf deutsch "Durchschnittliche Lesedauer" angezeigt.

Viele Grüße
Mario

August 12, 2019 um 3:02 pm #4381769

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Vielen Dank, nun funktioniert es: hidden link

#1 Bitte öffnen Sie WPML -> String Translation und scrollen Sie ganz nach unten zu "Text auf Admin-Bildschirmen übersetzen »"
#2 Suchen Sie nach "+ rt_reading_time_options" und klicken Sie auf den Text
#3 Markieren Sie die checkbox von label, postfix, postfix_singular
#3 Scrollen Sie ganz nach unten und klicken Sie auf "Anwenden"
#4 Nun können die Texte in der String Translation Tabelle übersetzt werden.

Doku: https://wpml.org/de/documentation-3/ratgeber-zum-loslegen/string-ubersetzung/#admin_texts

Freundliche Grüße
Marcel

August 12, 2019 um 6:56 pm #4383331

marioM-49

Hallo Marcel,
ich habe die Schritte durchgeführt und bei Klick auf "Anwenden" speichert er auch, jedoch ist bei der String Translation Tabelle der Eintrag für die Übersetzung nicht zu finden.
Woran mag das liegen?
Danke und Gruß
Mario

August 13, 2019 um 7:28 am #4385563

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Mario,

theoretisch kann es an der PHP Variable max_input_vars liegen. Diese ist aktuell auf Value 5000 gesetzt. Wenn Sie auf die php.ini Zugriff haben können Sie versuchen diese auf 10000 zu erhöhen.

Ansonsten schaue ich mir am besten direkt an, wenn ich für das zweite Ticket Seitenzugriff habe.

Doku: hidden link

Freundliche Grüße
Marcel

August 13, 2019 um 7:31 am #4385593

marioM-49

Hallo Marcel,

ich habe den Wert auf 10000 gesetzt. Sollte es dennoch nicht funktionieren, melde ich mich kurz.

Danke und Gruß
Mario

August 13, 2019 um 7:42 am #4385647

marioM-49

Hallo Marcel,

ich habe den Wert nochmals erhöht (25000), aber keine Verbesserung.

Viele Grüße
Mario

August 13, 2019 um 2:14 pm #4388773

marioM-49

Hallo,

das Hochsetzen des WP Memory Limits auf 1024 MB brachte leider keinen Erfolg.

Viele Grüße
Mario

August 13, 2019 um 2:22 pm #4388807

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Kurzes Update: Ich migriere seit Mittag die Seite auf unseren Cloudways Server. Hier kann ich testen, ob das Problem sich auf unserer Serverumgebung nachstellen lässt. Die Migration ist in etwa 40min fertig, dann gebe ich Ihnen Bescheid.

August 13, 2019 um 2:24 pm #4388813

marioM-49

Danke!

August 14, 2019 um 1:55 pm #4395641

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Mario,

nun funktioniert es. Sie hatten für dieses Plugin bereits eine XML Konfiguration aktiv. Jedoch war dies als <shortcode> eingetragen und nicht als <admin-texts>. Somit hatte jeglicher Exportversion keine Wirkung.

Bitte entfernen Sie dies unter WPML -> Einstellungen -> Benutzerdefinierte XML-Config und fügen Sie nun folgendes ein:

<wpml-config>
    <admin-texts>
        <key name="rt_reading_time_options">
            <key name="label" />
            <key name="postfix" />
            <key name="postfix_singular"/>
</key>
    </admin-texts>
</wpml-config>

Ich habe es bereits auf der Cloudways Kopie aktiv.

Freundliche Grüße
Marcel

August 14, 2019 um 2:27 pm #4395969

marioM-49

Hallo Marcel,

wo in den Einstellungen bei den WPML-Einstellungen finde ich "Benutzerdefinierte XML-Config"? (siehe Screenshot, ich finde dort nichts)

Danke und Gruß
Mario