Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Bilder im Revolution Slider werden in der Zweitsprache nicht angezeigt. Die Slider werden über ein ACF-Feld aufgerufen.

Solution: Man muss diese Feldgruppe in ACF übersetzen damit die Galerien in den übersetzten Feldern erscheinen.

1: Bilder in Media Translation duplizieren 2: In dem Slider in den Einstellungen die Übersetzung mit WPML aktivieren (settings > misc)

4: Feldgruppen übersetzbar machen

In WPML > Einstellungen > Beitragstypen muss man den Beitragstyp "Feldgruppen" erst auf "Übersetzbar - nur übersetzte Elemente anzeigen" ändern, damit wird die Feldgruppe Fotos übersetzbar:

- Nun muss man die Feldgruppe der Fotos öffnen und duplizieren.

5: Felder der Feldgruppe mit den Fotos auf "kopieren" setzen

Am einfachsten ist es so: - In das Angebot gehen und unten in der Metagbox "Einrichtung des mehsprachigen Inhalts " zuerst den Link "Systemfelder" öffnen.

- Die Felder mit _slider und _gallery auf "Kopieren" setzen und die Einstellung speichern:

Die Namen der Felder sind die Name wie sie in der Feldgruppe definiert wurden.

6: Posts updaten

- Original und Übersetzung nacheinander updaten. - Damit erscheinen die Fotos und Galerien des Originals in der übersetzten Seite

Relevant Documentation:

0% of people find this useful.

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Schlagwörter: 

This topic contains 14 Antworten, has 2 Teilnehmer.

Last updated by davidH-95 vor 2 years.

Assigned support staff: Cristina.

Author Artikel
August 19, 2018 um 9:06 pm

davidH-95

Ich versuche: Beiträge zu übersetzten.

URL der/meiner Website, auf der das Problem auftritt:
- Deutsch hidden link
- Englisch hidden link

Erwartet hatte ich zu sehen: Übersetzten Beitrag inklusive Revolution Slider und Gallery.

Stattdessen bekam ich: nur den Text zu sehen ohne den Slider und die Gallerie.

August 20, 2018 um 10:17 am #2658927

Cristina

Hallo David,

vielen Dank für Ihre Anfrage und die beigefügten Informationen.

Ich habe mich kurz in die Seite eingeloggt und den Slider angesehen.

Die WPML-Option ist korrekt aktiviert, aber in WPML Medienübersetzung erscheinen die Bilder alle als nicht übersetzt, was dazu führt, dass sie nicht im Slider der übersetzten Seite erscheinen.

Wenn in Revolution Slider bei den Einstellungen > Misc die WPML Option aktiviert wird, werden die Übersetzungen automatisch erstellt, d.h. die Slides werden dupliziert und können bei Auswahl einer Sprache bearbeitet werden.

Damit die Bilder aber erscheinen, müssten sie zuvor ebenfalls über WPML > Medienübersetzung dupliziert werden. Erst dann werden die Bilder auch in den übersetzten Slides erscheinen und sichtbar sein.

Sie können die Medien in WPML >Medienübersetzung duplizieren, indem Sie auf das "+" Icon klicken. Damit werden die Bildinformationen dupliziert. Vorhandenen Bildtexte können Sie bei Bedarf dort ebenfalls übersetzen.

Da in WPML > Medienübersetzung zur Zeit die Bilder als nicht übersetzt erscheinen, fehlt das wohl noch für bereits existierenden Sliders.

MfG,
Cristina

August 21, 2018 um 8:06 pm #2664642

davidH-95

Hallo Cristina

Vielen Dank für deine Antwort und deine Ausführungen. Ist es denn wirklich so, dass wir alle Fotos duplizieren müssen? Gibt es keine andere Möglichkeit ein Foto in allen Sprachen verfügbar zu machen? Wenn wir alle unsere Fotos duplizieren verdoppelt sich somit ja der Speicherplatzverbrauch?

Besten Dank und Grüsse
David

August 22, 2018 um 7:58 am #2665996

Cristina

Hallo David,

wenn Sie die Duplizierungsfunktion nutzen, werden nur die Bildinformationen in der Datenbank dupliziert. Auch wenn die Mediathek dann das gleiche Bild in zwei Sprachen zeigt, ist es die gleiche Bild-URL, weil die Mediendatei an sich nicht dupliziert wird.

Nur die Einträge in der Datenbank in _posts und _postmeta sowie die Verknüpfungen zu Beiträgen oder Kategorien werden dupliziert. Das sind also nur Einträge in der Datenabank.

Damit wird kein zusätzlicher Speicherplatz auf dem Server beansprucht, aber die Bilder sind trotzdem in beiden Sprachen verfügbar.

MfG,
Cristina

August 24, 2018 um 9:25 am #2672601

davidH-95

Hallo Cristina
Ich habe das nun für alle Bilder in diesem Beitrag gemacht. Sowohl der Slider oben, als auch die Gallerie unten wird aber im übersetzten Beitrag immer noch nicht angezeigt.
Vielen Dank für deine Unterstützung.

Freundliche Grüsse
David

August 24, 2018 um 11:07 am #2672851

Cristina

Hallo David,

ich habe den Originalbeitrag aktualisiert und damit das Featured Image in die Übersetzung bekommen, aber keine weiteren Bilder.

Daraufhin habe ich für einen Moment die Medien auch auf "übersetzbar" in WPML > Settings geändert und noch einmal abgespeichert, aber das hat nichts gebracht. Den WPML Cache habe ich geleert, aber das hat auch nicht geholfen.

Der Slider selbst erscheint in der Vorschau korrekt in beiden Sprachen, es ist daher etwas an der Seiteneinstellung selbst, das hier den Slider verhindert.

Der Slider wird ja über die Metabox eingebunden. Ich habe gesehen, dass ACF Multilingual installiert, aber nicht aktiv ist.

Handelt es sich dabei um ein benutzerdefiniertes Feld von ACF, das den Slider aufruft?

Eventuell wäre es hilfreich, wenn ich einen Snapshot ohne Bilder und Cache der Seite erstellen dürfte, um gefahrlos die Einstellungen der benutzerdefinierten Felder zu checken. Haben Sie einen Backup der Seite?

Alternativ stelle ich jetzt eine entsprechende Sandbox auf, wo ich vergleichbare Settings mit CPT UI, ACF und WPML rekonstruieren und das Verhalten im Slider checken kann kann.

MfG,
Cristina

August 24, 2018 um 12:43 pm #2673131

davidH-95

Hallo Cristina

Vielen Dank für die Antwort.

Ja, das ist richtig. Sowohl der Slider als auch die Gallerie werden über ein ACF Feld (Dropdown) pro Beitrag ausgewählt. Die Felder habe ich unter WPML auf "Copy" eingestellt und gehe mal davon aus, dass der Wert übernommen wird? Gerne kann ich auch den Code des Templates zur Verfügung stellen, damit du siehst wie der Slider und die Gallerie eingebunden wird auf der Seite?

Einen Snapshot darfst du gerne erstellen von der Seite.

Freundliche Grüsse
David

August 24, 2018 um 2:59 pm #2673561

Cristina

Hallo David,

jetzt verstehe ich das besser.

Bei ACF muss man ACF Multilingual aktivieren und die Feldgruppen duplizieren, wenn es Felder gibt, die dann auch übersetzt oder mit unterschiedlichen Inhalten in beiden Sprachen erscheinen sollten.

Ich werde daher einen Snapshot erstellen und die unterschiedlichen Optionen checken. Wir haben einen neuen Release für ACF Multilingual und WPM 4.0.6 kommt auch in wenigen Tagen, so dass ich das dann gleich lokal mit checken kann.

Danke und mfG,
Cristina

August 24, 2018 um 3:29 pm #2673670

davidH-95

Hallo Cristina

Am schönsten wäre es, wenn im übersetzten Beitrag einfach der Original-Slider und die Original-Gallerie angezeigt wird. Darum habe ich diese Felder jeweils auch auf "copy" gesetzt. Es ist nicht notwendig bei den übersetzten Beiträgen einen anderen Slider oder eine andere Gallerie auszuwählen. Wie du beim Original-Beitrag siehst, gibt es sowohl beim Slider als auch bei der Gallerie gar nichts zu übersetzen.

Lass mich wissen, sobald du mehr weisst.

Freundliche Grüsse
David

August 27, 2018 um 8:33 am #2677320

Cristina

Hallo David,

es ist leider so, dass man diese Feldgruppe übersetzen muss, damit die Galerien erscheinen.

Im Snapshot hat es so funktioniert:

1: Feldgruppen übersetzbar machen

In WPML > Einstellungen > Beitragstypen muss man den Beitragstyp "Feldgruppen" erst auf "Übersetzbar - nur übersetzte Elemente anzeigen" ändern, damit wird die Feldgruppe Fotos übersetzbar:

- Nun muss man die Feldgruppe Fotos öffnen und duplizieren.

2: Felder der Felgruppe Fotos auf "kopieren" setzen

Am einfachsten ist es so:
- In das Angebot gehen und unten in der Metagbox "Einrichtung des mehsprachigen Inhalts " zuerst den Link "Systemfelder" öffnen.

- Diese Felder auf "Kopieren" setzen und die Einstellung speichern:

  • - angebot_slider
  • _angebot_slider
  • angebot_gallery
  • _angebot_gallery

Die Namen der Felder sind die Name wie sie in der Feldgruppe definiert wurden.

3: Angebot updaten

- Original und Übersetzung nacheinander updaten.
- Damit erscheinen die Fotos und Galerien des Originals in der übersetzten Seite

4: Feldgruppen wieder auf "übersetzbar" umstellen und einzelne Feldgruppe ebenfalls ändern

Wenn man dann die Beitragsgruppen wieder auf "übersetzbar" einstellt, erscheinen die meisten restlichen Felder wieder, ohne dass man alles übersetzen muss. Allerdings kann es sein, dass einige Felder nicht korrekt in der Übersetzung erscheinen

Sollten jetzt noch Feldgruppe nicht korrekt erscheinen, muss man das bei diesen Feldern genauso tun: erst die Feldgruppe duplizieren und dann die Felder auf "kopieren" einstellen.

Danach die Feldgruppen wieder auf "Übersetzbar - Übersetzung nutzen, sofern verfügbar, oder auf Standardsprache zurückgreifen" umstellen.

Das ist leider nicht anders zu machen.

MfG,
Cristina

September 6, 2018 um 2:40 pm #2711165

davidH-95

Hallo Cristina
Super, vielen Dank! Das scheint so zu funktionieren 🙂
hidden link

Jetzt ist noch ein weiteres Problem da. Im Translations Editor werden gewisse mehrzeilige Felder korrekt angezeigt, andere kommen komischerweise nur als einzeilige Textfelder daher. Woran liegt das? Für die Anzeige des Inhalts auf der Website ist es erforderlich, dass dies mehrzeilige Textfelder sind, damit wir Zeilenumbrüche machen können. Der Screenshot im Anhang beschreibt das Problem besser.

Herzlichen Dank und Grüsse
David

September 6, 2018 um 6:08 pm #2711901

Cristina

Hallo David,

diese Felder expandieren automatisch, wenn im Original die einzelnen Listenpunkte mit einem Zeilensprung getrennt werden.

Wenn ich die neuen Zeilen mit der "Return"-Taste im Original voneinander trenne, expandiert das auch im Editor. Wenn ich Kommas setzen oder keine neue Zeile nutzen, wird es als Fließtext erfasst.

Es wird aber auch hier expandieren, wenn das Feld erweitert. In dem Screenshot sind die beiden Punkte ohne Trennung im Original sichtbar. Das müsste im Ausgangsfeld mehrzeilig eingerichtet werden. Im HTML wird ein Zeilensprung dann übernommen.

Ich füge ein paar Screenshots dazu bei.

MFG
Cristina

September 7, 2018 um 7:18 am #2713345
davidH-95

Hallo Cristina

Das ist aber leider in der Tat anscheinend nicht so. Schau dir mal die beiden Screenshots an. Im Original sind da Zeilenumbrüche drin.

Vielen Dank und Grüsse
David

Neue Threads, die von Cristina erstellt wurden und mit diesem verbunden sind, sind unten aufgeführt:

https://wpml.org/de/forums/topic/zeilenumbrueche-in-benutzerdefinierten-feldern-werden-nicht-angezeigt/

September 7, 2018 um 10:27 am #2714127

Cristina

Hallo David,

Sie haben recht, das scheint mit dem Update auf Version 4.0.6 in WPML passiert zu sein.

Ich habe den Thread abgespalten, um das Problem separat zu handeln und Ihnen schon dazu geantwortet.

Diesen Thread könnten wir schließen, denn das Problem mit dem Slider ist jetzt abgeschlossen.

MfG,
Cristina

September 7, 2018 um 11:01 am #2714231

davidH-95

Danke Cristina.