Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 0.08 hours from now. Thank you for your understanding.

Schlagwörter: 

This topic contains 3 Antworten, has 2 Teilnehmer.

Last updated by Marcel vor 3 Wochen, 1 Tag.

Assigned support staff: Marcel.

Autor Beiträge
November 19, 2019 um 9:47 am #4970347

Adrian

German (Englisch is below):

Guten Tag,

wir haben derzeit das Problem, dass einige Strings nicht übersetzt werden.
Obwohl in der "String Translation" entsprechende Übersetzungen eingetragen sind, werden diese nicht übernommen.

Was wir versucht haben:
- Erhöhung des Memory Limits auf 256MB
- Löschung des Caches von WPML & WordPress
- Löschung der Strings und neu Übersetzung
- Neu einlesen aller Strings sowohl im Template als auch in Plugins
und mehr

Bei dem Theme handelt es sich um ein selbst erstelltes, an den entsprechenden Stellen wird die WordPress Funktion __("String", "Domain") verwendet.

Bis jetzt hat nur die Option "Look for strings while pages are rendered" unter WPML->String Translation dazu geführt, dass die übersetzten Strings angezeigt werden.
Die Option hat allerdings einen 2 stündigen Countdown und soll nach der Beschreibung her mehr Ressourcen verbrauchen.

Unsere Hauptsprache ist Deutsch, die zu übersetzende Sprache ist Englisch.

Da der künde sich sorgen um seine Daten macht, können wir Ihnen leider keinen Zugang anbieten.

--------------
Hello,

we currently have the problem that some strings are not translated.
Although the "String Translation" contains corresponding translations, they will not be translated.

What we have tried to do:
- Memory increment to 256MB
- Deletion of WPML & WordPress cache
- Deleting the strings and translate them again
- New import of all strings in the template as well as in plugins
and more

The theme is a self-created one, at the appropriate places the WordPress function __("String", "Domain") is also used.

So far only the option "Look for strings while pages are rendered" under WPML->String Translation has caused the translated strings to be displayed.
However, the option has a 2 hour countdown and should not be used according to the description.

Our main language is German, the language to be translated in is English.

Since the customer is worried about his data, we cannot offer you access.

November 19, 2019 um 12:34 pm #4972073

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Adrian,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Bitte versuchen Sie folgendes:

#1 Aktualisieren Sie WPML auf die Version 4.3.4 -> Das Update kann unter WPML -> Plugins im Tab "Komerziel" abgerufen werden. Da es erst veröffentlicht wurde, ist es aktuell nur für ca. 10% der Kunden sichtbar. Mit einem Klick auf dem Updatebutton können Sie es jedoch jederzeit abrufen.

#2 Wenn das Update keine Lösung bringt, versuchen Sie bitte Ihre PHP Variable max_input_vars zu erhöhen. Sie verwenden aktuell einen Wert von 1000, ich empfehle Ihnen 10000 zu setzen. Sie können dies über die php.ini oder über die htaccess Datei durchführen (falls es der Hoster erlaubt).

=> php.ini file
Öffnen Sie die php.ini und fügen Sie diese Zeile ein/bearbeiten Sie sie:

max_input_vars = 10000

hidden link

=> .htaccess file

php_value max_input_vars 10000 

Bitte um Info, ob es damit funktioniert.

Freundliche Grüße
Marcel

November 19, 2019 um 2:19 pm #4973095

Adrian

Vielen Dank für die Antwort,

1. Die Plugins wurden von uns aktualisiert, es kam aber leider zu keiner Änderung.
2. Werden wir so dem Kunden übermitteln und ausprobieren.

Was eventuell hilfreich sein könnte, wir haben eine 1:1 Spiegelung des Systems, auf dieser haben wir ursprünglich entwickelt und auch sämtliche Inhalte und Texte (sowie Übersetzungen) eingepflegt (Auf diesem System gab es nur an einer Stelle die Problematik mit fehlenden Übersetzungen, konnten wir allerdings durch das hinzufügen einer fehlenden Domain fixen). Könnte es eventuell daran liegen, dass beim Spiegeln auf den Server des Kunden, es in irgend einer Art dazu geführt hat, dass Übersetzungsdateien beschädigt wurden?
lese und schreib zugriff sollte vorhanden sein, wird allerdings noch geprüft.

Freundliche Grüße

November 19, 2019 um 2:30 pm #4973297

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Adrian,

ich vermute den Fehler eher in den max_input_vars. Wert 1000 ist eine häufige Ursache für Ihr beschriebenes Problem. Versuchen Sie es einfach und geben Sie mir Bescheid.

Freundliche Grüße
Marcel