Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 8.44 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: One of two SuperAdmins is not able to login after WPML Update

Solution: Changing the passwords for the SuperAdmins on the DB solved the issue

Relevant Documentation: https://wpml.org/documentation/support/multisite-support/

This topic contains 20 Antworten, has 2 Teilnehmer.

Last updated by carstenZ-2 vor 7 Monate, 2 Wochen.

Assigned support staff: Andreas W..

Autor Beiträge
Februar 28, 2019 um 3:09 am #3253442

carstenZ-2

Vielen Dank für das Debuggen. Ich habe den Fehler im Theme ausfindig machen können. Es wurde die aktuelle Währung abgefragt und je nach Währung wurden Payment Gateways ausgeblendet:

if (!class_exists('WCML_Multi_Currency')) {
		return;
	}
  
	$get_current_currency_wcml = new WCML_Multi_Currency();
	$get_current_currency = get_woocommerce_currency();

Das funktioniert aber so nicht. Zu nutzen ist die Funktion get_woocommerce_currency().

Dadurch hat sich aber noch nicht folgendes Problem gelöst, wie schon beschrieben. Bitte auch noch dringend checken!:

Durch das Update der WP Installation + aller Plugins kommt nun der Network Admin Superuser nicht mehr in das WP Backend, es erscheint ein Error 500 (im Log steht memory 3GB exhausted. Auch 10GB helfen nicht weiter..). Grund dafür ist das Plugin "WPML Multilingual CMS". Nachdem das Plugin deaktiviert wurde, funktioniert der Zugriff wieder. Es hängt allerdings nur an dem einen User (User: syntaxmedia).

Im "installer" kann man außerdem sehen, dass wohl das Update irgendwie hängengeblieben ist: installing... updating... installed updated activating activated" steht bei allen WPML Plugins. Alle Plugins habe ich manuell geupdatet, da es über den installer nicht ging (irgendeine Fehlermeldung wegen des License Keys).

März 1, 2019 um 11:34 pm #3263329

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Entschuldigen Sie bitte die Verzögerung.

Vielen Dank, dass Sie den WPML Kundendienst kontaktiert haben.

Bitte laden Sie die aktuellen Versionen von WPML Multilingual CMS 4.2.4.1 unter https://wpml.org/downloads herunter.

Deaktivieren und löschen Sie nun bitte alle WPML plugins. Keine Sorge, dieser Vorgang hat keinen Einfluss auf Ihre in der Datenbank gespeicherten Übersetzungen und Einstellungen.

Fügen Sie nun WPML Mulitlingual CMS 4.2.4.1 erneut hinzu.

Gehen Sie dann auf Plugins -> Installieren -> kommerziell und laden Sie die Add-ons herunter. Wählen Sie außerdem die Schaltfläche "nach dem Download aktivieren" am unteren Ende der Plugin-Auswahl.

Lassen Sie mich bitte wissen, ob das Problem behoben wurde.

Mit freundlichen Grüßen
Andreas

März 4, 2019 um 10:08 am #3267953

carstenZ-2

Nein hat leider nicht funktioniert. Die Plugins habe ich manuell geupdatet, wie beschrieben. Unter "Plugins>Installieren" finde ich allerdings kein "Kommerziell", weder direkt im Blog noch im Network. Auch der WPML Installer hängt nach wie vor bei allen Plugins im Status "installing... updating... installed updated activating activated" fest und der Superadmin kann sich nicht auf dem betroffenen Blog einloggen.

März 4, 2019 um 3:28 pm #3269578

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich sehe, mit meinem Zugriff auf Ihre Website, dass dem Menüpunkt "Plugins die Untermenüs fehlen". Ist dies auf für Sie als Admin der Fall?

Ich vermute, das ein weiteres installiertes Plugin dieses Problem veursacht. Sie sagten, das Problem löst sich, wenn WPML deaktiviert ist, aber wie verhält es sich wenn nur WPML and WooCommerce laufen? Ich vermute, dass ein anderes Plugin hier die Ursache des Problems ist.

Ich würde Sie bitte die Website in einem minimalen Setup zu überprüfen. Wechseln Sie dazu Ihre Theme zu einem Standard-Theme wie TwentySeventeen. Hat sich das Problem gelöst?
Falls, nein deaktivieren Sie bitte Plugins bis auf WPML kurzrisitg. Besteht das Problem weiterhin? Falls nein, reaktivieren Sie bitte Ihre Plugins in kleinen Blocks, um so herauszufinden welches Plugin den Fehler verursacht.

es war mir bislang nicht möglich, Ihre Website zu übeprüfen, da der UMfang der Website zu groß ist. Außerdem konnte ich keine Plugins installieren und der FTP-Zugriff funktionierte leider ebenfalls nicht.
Auf Grund des großen Umfangs Ihrer Wesbite würde Sie bitten, falls notwendig, die Plugins, das Theme und eine Kopie Ihrer Datenbank zu übermitteln. Die Ordner für Uploads und Backups sind für weitere test nicht nötig.

Auf diese Weise werde ich versuchen Ihre Website lokal zu überprüfen.

Mit freundlichen Grüßen
Andreas

März 6, 2019 um 7:04 am #3277149

carstenZ-2

Kurz noch einmal eine Rückmeldung bevor ich weitere Schritte unternehme: Wie mitgeteilt, funktioniert es erst seit dem Update der WPML Plugins nicht mehr. Ich kann daher andere Plugins oder das Theme nahezu ausschließen. Außerdem handelt es sich hier um eine Multisite-Installation, da ist die Plugin-Installation im Network-Admin und nicht im Blog. Daher sehen Sie auch keine Untermenüs bei Plugins. Allerdings gibt es auch im Network-Admin kein "Kommerziell".

Können Sie mir genauer mitteilen, inwiefern der FTP Zugang nicht funktioniert?

März 6, 2019 um 4:39 pm #3280460

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich habe ein wenig in unserem Forum gesucht.

Bei der Verwendung von Multisites ist ein Update von WPML nur über die Hauptseite möglich.

Informationen zu verwendeten WPML Produktschlüsseln können Sie in Ihrem Nutzerkonto auf https://wpml.org/de/account/websites/ erhalten. Vergwissern Sie sich bitte, dass WPML auf der Hauptseite Ihres Multisite-Netzwerkes installliert wurde und führen Sie von dort aus das Update für alle Seiten durch.

Bitte lassen Sie mich wissen, ob es funktioniert hat.

Mit freundlichen Grüßen
Andreas

März 7, 2019 um 7:20 am #3282552

carstenZ-2

Ich denke mit Hauptseite meinen Sie den Network-Admin, oder? Prinzipiell gibt es auch nur dort die Möglichkeit Plugins zu installieren und zu updaten. Dies wirkt sich dann auf das ganze Netzwerk aus. Aber hier gibt es nun mal leider keinen "Commercial-Tab". Letztendlich sind ja aber alle Plugins up-to-date durch das manuelle Update.

Ich habe irgendwie die Vermutung, dass es ein Verbindungsproblem zu WPML gibt. Dafür spricht auch, dass im "Installer" der Status bei Updating hängenbleibt und der Superadmin sich nicht einloggen kann. Evtl. gibt es hier einen Timeout (im Log kann ich aber nichts sehen). Wovon die Anzeige des Commercial-Tabs abhängt weiß ich nicht, aber ggf. wird hier ja auch im Hintergrund mit WPML kommuniziert?

März 7, 2019 um 8:52 pm #3286942

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich sehe es gibt zwei Super Admin User auf Ihrer Mutiliste.

- admin_eks
- syntaxmedia

Das Problem, besteht also nur bei einem der Konten?

Ich würde generell dazu raten in einem minmalen Setup zu prüfen. Soll bedeuten Sie deaktivieren alle Plugins.
Sollten Sie keine Zugriff auf jegliche Plugins haben können Sie diese über FTP deaktiveren.
Benennen Sie dazu den Ordern "wp-content/plugins" in "wp-content/plugins deactivated". um.

Sobald Sie wieder angemeldet sind machen Sie die Änderung wieder rückgängig und sollten nun Plugins aktivieren können.

Sollte es weiterhin Probleme geben sollten Sie Ihre Datenbank überprüfen. Wenn Sie mir Zugriff auf Ihr PHPmyAdmin geben könnten schaue ich gerne mal rein.

Bitte werfen Sie einen Blick in Ihre Datenbanktabelle wp_usermeta.

Öffnen Sie die Tabelle "wp_usermeta" und suchen Sie den Eintrag "wp_capabilities" für den Admin-Benutzer (anhand der User-ID können Sie dies überprüfen). Bearbeiten Sie nun den Wert für die richtige Zeile "wp_capabilities" und aktualisieren Sie ihn mit folgendem Wert:

a: 1: {s: 13: "administrator"; s: 1: "1";}

Kennwörter können in der Datentabelle wp_users geändert werden.
https://codex.wordpress.org/Resetting_Your_Password

Mehr Informationen zu den WordPress Datentabellen finde Sie hier:
https://codex.wordpress.org/Database_Description

Bitte versuchen Sie die Änderungen vorzunehemen und vergewissern Sie sich, ob das Problem weiterhin besteht, wenn WPML, bzw, der Plugin Ordner deaktiviert wurde.

Von dort versuchen Sie bitte ein Duplicator Paket ohne Uploads und Backups zu erstelllen. Sollten das Paket kleiner als 500M sein, so ist dies kostenlos mit Duplicator möglich. Ich werde dann versuchen Ihre Multisite nachzubilden, um das Problem zu prüfen.

Mit freundlichen Grüßen
Andreas

März 12, 2019 um 7:20 am #3318833

carstenZ-2

Leider wieder ohne Erfolg. Alle Plugins deaktiviert, login funktioniert. Wieder aktiviert - login funktioniert wieder nicht. WPML deaktiviert - login funktioniert. Es muss also am Plugin WPML liegen! Ich würde es ja auch einmal mit einem Downgrade versuchen. Wo bekomme ich denn ältere Versionen von WPML?

Mit Duplicator hatte ich es schon einmal versucht. Ich kann nur eine Seite vom Network kopieren und außerdem ist die Datenbank schon viel zu groß. Also Duplicator scheidet aus.

Die permissions für den user syntaxmedia (um den es geht) habe ich auch geprüft, sogar die permissions vom user admin_eks übernommen. Ohne Erfolg.

Da ich hier einige unnötige Informationen angeben muss um eine private Nachricht zu senden, kann ich leider nicht den phpMyAdmin Zugang mitsenden!

März 12, 2019 um 4:16 pm #3326035

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für Ihre Nachricht.

Ihre nächste Antwort ist auf privat gestellt. Sie wird nicht für andere Nutzer des Forums sichtbar sein.

Bitte übermitteln Sie uns die Zugangsdaten zum PHPmyAdmin-Bereich. Ich werde die Angelgenheit dann zur 2. Stufe eskalieren.

Bitte fügen Sie auch nochmals die aktuellen WPML Debug Informationen hinzu.
https://wpml.org/de/faq/so-liefern-sie-fehlerbehebungsinformationen-fuer-schnelleren-support/

Mit freundlichen Grüßen
Andreas

März 12, 2019 um 9:46 pm #3328607

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ihre Datenbanktabellen eks_user und eks_usermeta weisen keinen Eintrag für den Nutzer admin_eks auf.

Weder eine Suche nach der E-Mail, noch nach dem User admin_eks war erfolgreich.

Auf der Datentabelle eks_sitemeta, welche die Angaben zu allen Admins enthält, sieht alles richtig aus.

Ich würde Ihnen dazu raten den Nutzer admin-eks neu anzulegen. Sie benötigen dazu nur wenige SQL Queries. Mehr Informationen dazu hier:

hidden link

Weshalb es zum Fehlen der Einträge kam ist schwer zu sagen. Sind Sie sich sicher, dass dies nach dem letzten WPML Multilingual CMS Update auf Version 4.2.4.1 geschehen ist?

Mit freundlichen Grüßen
Andreas

März 13, 2019 um 6:38 am #3330103

carstenZ-2

Hallo,

es geht nicht um den User "admin_eks" sondern um den User "syntaxmedia"! "admin_eks" kann sich problemlos einloggen.

Außerdem ist der User "admin_eks" in der Tabelle "eks_users" durchaus vorhanden. Der User "syntaxmedia" ist auch darin vorhanden. Bitte nochmal genauer schauen, danke!

März 13, 2019 um 6:23 pm #3337311

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Tut mir leid, mir ist anscheinend bei der Suche auf der Tabelle ein Fehler unterlaufen.

Ich habe die Angelgenheit an unserzur 2. Stufe eskaliert und werde mich bei Ihnen melden, sobald ich eine Rückmeldung habe.

Älter Versionen von WPML finden Sie hier:
https://wpml.org/download/wpml-multilingual-cms/?section=changelog

Mit freundlichen Grüßen
Andreas

März 18, 2019 um 7:23 am #3366367

carstenZ-2

Wann kann ich hier mit einer Rückmeldung rechnen?

März 18, 2019 um 3:28 pm #3370865

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich habe die Angelegenheit an unser Entwicklerteam weitergeleitet und werde mich bei Ihnen melden, sobald ich eine Rückmeldung habe.

Ich bitte Sie um etwas Geduld, während unser Team an einer Lösung für dieses Problem arbeitet.

Mit freundlichen Grüßen
Andreas