Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This thread is resolved. Here is a description of the problem and solution.

Problem: Wenn der Status einer Bestellung geändert wird, z.B. von Bearbeitung auf Fertiggestellt, dann ändert WPML automatisch das ganze System von Deutsch auf Englisch.

Solution: Das Problem tritt nur bei Seiten auf, bei denen die Default-Sprache nicht Englisch ist, wenn die Status-Änderung der Order manuell im Backend editiert wird und dabei auch im Benutzerprofil die Option aktiv ist, die Editiersprache auch als Admin-Sprache zu nutzen.

Wenn man den Haken in Benutzer > Dein Profil > WPML-Spracheinstellungen > Bearbeitungssprache > Admin-Sprache als Bearbeitungssprache einstellen entfernt, passiert das nicht mehr.

Relevant Documentation: https://wpml.org/de/documentation-3/ratgeber-zum-loslegen/einstellung-der-sprachen/#admin-sprache

Schlagwörter: 

This topic contains 2 Antworten, has 2 Teilnehmer.

Last updated by dirkS-23 vor 1 Jahr.

Assigned support staff: Cristina.

Autor Beiträge
Oktober 15, 2018 um 7:56 am #2816452

dirkS-23

Guten Tag, wir setzen als Designagentur das WPML Modul bei unserem Kunden ein und haben ein Problem im Backend bei Woocommerce. Wenn der Status einer Bestellung geändert wird, z.B. von Bearbeitung auf Fertiggestellt, dann ändert WPML automatisch das ganze System von Deutsch auf Englisch. Bitte erklären Sie mir kurz, wie wir das fixen können.

Oktober 15, 2018 um 5:10 pm #2818390

Cristina

Hallo Dirk,

vielen Dank für die Anfrage und die beigefügten Informationen.

Da dies kein vorgesehenes Verhalten ist, kann es das verschiedene Ursachen haben, die nicht pauschal beantwortet werden können.

Aktuell haben wir nur ein Problem in dieser Richtung identifiziert, bei manuellen Statusänderungen mit einer bestimmten Konfiguration in den Benutzersprachen.

Das Problem tritt nur bei Seiten auf, bei denen die Default-Sprache nicht Englisch ist,

- Wenn die Status-Änderung nicht im Standardmodus über den Checkout im Shop (Zahlen, Zahlungseingang bestätigen und automatisch fertigstellen) erfolgt, sondern die Order manuell im Backend editiert wird.

Es passiert auch nur wenn eine Bestellung storniert oder auf "in Bearbeitung" manuell geändert wird. Bei "pending payment" Status passiert das nicht.

- Wenn dabei auch im Benutzerprofil die Option aktiv ist, die Editiersprache auch als Admin-Sprache zu nutzen.
Benutzer > Dein Profil > WPML-Spracheinstellungen > Bearbeitungssprache > Admin-Sprache als Bearbeitungssprache einstellen: Hier wechselt bei einer manuellen Statusänderung die Sprache auf Englisch.

Sollte Ihr Problem in dieses Muster passen, könnten Sie provisorisch die WPML-Spracheinstellungen im Benutzerprofil ändern, damit die Bearbeitungssprache nicht zu Adminsprache wird.

Diese spezielle Situation wird in WooCommerce Multilingual Version 4.3.7 gelöst.

Selbst wenn Ihr Problem ein wenig anders ist, probieren Sie, ob eine Änderung in den WPML-Spracheinstellungen im Benutzerprofil hilft, da sich die Backend-Sprache individuell für jedes Userprofil anpasst.

Sollte das Problem dann ein anderes sein, konnte es von der Erfahrung her im Zusammenhang mit WP-Rocket und WooCommer Germanized entstehen. Hier müsste man aber im Detail nachsehen, was genau betroffen ist.

Könnten Sie genau schildern, wie Ihre WPML und WooCommerce Einstellungen sind, und welche Statusänderung genau diesen Sprachwechsel bewirkt?

Passiert das bei bestimmten Bestellungen / Produkten oder bei allen?

Betrifft das das gesamte Backend oder auch die online sichtbaren Seiten, Emails oder andere Komponenten die nicht zur Backend-Sprache gehören und vom Nutzer gelesen werden?

Passiert das auch ohne WP-Rocket?

Wenn es nicht eindeutig mit einer bestimmten Aktion in Zusammenhang gebracht werden kann, müssten wir uns das anschauen.

MfG,
Cristina

Oktober 16, 2018 um 12:00 am #2818971

dirkS-23

Hi,

danke für den Support. Die Lösung war:

- Wenn dabei auch im Benutzerprofil die Option aktiv ist, die Editiersprache auch als Admin-Sprache zu nutzen.
Benutzer > Dein Profil > WPML-Spracheinstellungen > Bearbeitungssprache > Admin-Sprache als Bearbeitungssprache einstellen: Hier wechselt bei einer manuellen Statusänderung die Sprache auf Englisch.

Habe einfach den Haken entfernt.