Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

Schlagwörter: 

This topic contains 23 Antworten, has 2 Teilnehmer.

Last updated by Marcel vor 4 Monate, 3 Wochen.

Assigned support staff: Marcel.

Autor Beiträge
April 8, 2019 um 9:15 am

florianR-11

Ich versuche: Ich habe einen CPT mit Toolset Types erstellt welcher eine Reihe von Kontrollkästchen beinhaltet. Diese habe ich mittel String Translation auch übersetzt. Im Backend funktioniert die Übersetztung im Frontend allerdings nicht.

URL der/meiner Website, auf der das Problem auftritt: hidden link

Erwartet hatte ich zu sehen: Eine Übersetzung

Stattdessen bekam ich: Nur die englische Version

April 8, 2019 um 10:29 am #3556635

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Florian,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Unsere Toolset Types benötigen das WPML Translation Management Add-On. Dieses ist momentan auf Ihrer Seite installiert, aber deaktiviert. Bitte aktivieren Sie dieses und geben mir Bescheid, ob es funktioniert hat 🙂

Anbei ein Link wo dieser Prozess beschrieben wird: https://toolset.com/documentation/translating-sites-built-with-toolset/prepare-site-run-multilingual/#installing-the-necessary-plugins

Freundliche Grüße
Marcel

April 8, 2019 um 12:12 pm #3557511

florianR-11

Hallo!

Danke für die schnelle Antwort! Sobald ich das Translation Management AddOn aktiviere sind ALLE Übersetzungen weg. Weiters habe ich auch keine Ahnung wie ichh dieses Tool benutzen soll? Es scheint nirgends wirklichh auf.

Auch verstehe ich nicht warum es bereits funktioniert hat (mittels String Translation) und nun nicht mehr?

April 8, 2019 um 4:35 pm #3560155

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Florian,

das Translation Management Plugin hat einen eigenen Eintrag unter WPML -> Übersetzungsmanagement. Die Aktivierung fügt jedoch auch andere Einstellungsmöglichkeiten und Funktionen zum Core Plugin hinzu (z.b. unseren neuen Advanced Translation Editor).

Es sollten keine Übersetzungen verschwinden. Könnten Sie ggf. eine Seitenkopie/Dev-Umgebung bereitstellen, wo wir dies gefahrlos testen können? Bei Bedarf kann ich Ihnen eine Cloudways Installation aufsetzen, womit sie in wenigen Minuten die Seite über ein Plugin auf unseren Server migrieren können. Hier können wir alles gefahrlos testen.

Wenn Sie Toolset Types übersetzen können Sie den CPT selbst bzw. die Taxonomie mit String Translation übersetzen. Der Translation Manager wird benötigt, sobald Custom Fields im Spiel sind, da die copy/translate Funktion dazu von unserem Add-On geladen wird. Dies sollte somit das Problem mit den Checkboxen beheben.

Freundliche Grüße
Marcel

April 8, 2019 um 6:15 pm #3560701

florianR-11

Hallo!

Sobald das Translation Management Tool aktiviert ist erscheint die gesamte WordPress Installation auf englisch! Ich miusste das daher wieder deaktivieren. Wie gesagt ich verstehe nicht warum die bereits übersetzten Strings nun nicht mehr funktionieren.

Gerne können Sie die Seite migrieren.

April 9, 2019 um 10:16 am
April 9, 2019 um 5:43 pm #3569755

florianR-11

Hallo!

Die Seite sollte nun auf dem Cloudserver migriert sein.

Danke für die Hilfe!

April 12, 2019 um 4:39 pm #3600633

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Florian,

vielen Dank. Ich bin bereits dabei dies zu testen. Leider hat es sich etwas verzögert, da bei der Migration div. Error 500 auf der Cloudways Installation aufgetreten sind, z.B. durch den Revslider. Dies habe ich nun soweit beheben können. Ich gebe Ihnen schnellstmöglich Bescheid.

Freundliche Grüße
Marcel

April 15, 2019 um 4:06 pm #3614955

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Florian,

in meinem Test hat sich gezeigt, dass Translation Management das WordPress Backend nicht auf Englisch anzeigt, wenn Sie zuvor den WPML Core sowie String Translation aktualisieren. Ebenso konnte ich nicht feststellen, dass Übersetzungen damit verloren gehen.

Somit zum eigentlichen Problem: Können Sie mir bitte noch mitteilen, welche Kontrollkästchen im CPT betroffen sind? Senden Sie mir bitte am besten direkt einen Link/Screenshot zum Backend & Frontend, dann kann ich die direkt vergleichen & überprüfen wie es übersetzt wurde.

Vielen Dank

Freundliche Grüße
Marcel

April 16, 2019 um 6:52 am #3618551

florianR-11

Hallo Marcel!

Vielen Dank für die Hilfe! Das Update der Core Komponenten hat soweit geholfen, dass das Backend ganz normal angezeigt wird. Die Übersetzung des Kotrollkästches funktioniert leider immer noch nicht.

Link zum Backend: hidden link

Link zum Frontend: hidden link

April 16, 2019 um 3:22 pm #3623477

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Florian,

vielen Dank. Von der Kontrollkästchen Einstellung sollen die Länder übersetzt sein, oder? Sprich deutsche Namen der Länder auf der deutschen Seite? Da Sie sagen es hat vorher funktioniert, war auf der Seite zuvor Englisch die default Sprache? (Die Strings sind momentan in Englisch registriert).

- Mir ist in Ihrem Backend noch eine PHP Meldung aufgefallen, diese wird nun nicht mehr eingeblendet. Können Sie das bitte überprüfen? https://wpml.org/forums/topic/wpml-translation-management-requires-php-setting-allow_url_fopen1/

- Ebenso fehlt von er WPML Systemvorraussetzung folgendes eine Erweiterung für String Translation: hidden link

- Bitte erhöhen Sie ebenso in Ihrer wp-config.php das WordPress Memory Limit [php] define( 'WP_MEMORY_LIMIT', '256M' ); </code

Bitte um Info
Grüße Marcel

April 16, 2019 um 7:22 pm #3625089

florianR-11

Hallo!

Ja die Länder sind übbersetzt. Mittels String Translation. Die default Sprache war und ist Deutsch. Die Strings sind auf Englisch registriet, da dies vorher nicht anders möglich war (hier gibt es einige Threads zu dem Thema). Wie gesagt, bis vor dem Update hat auch alles einwandfrei funktiomniert. Die Strings sind auch in Deutsch übersetzt.

Was die Einstellungen betrifft wird das wohl schwierig werden.

1. was soll ich mit dem MYSQL Unicode Charset machen?
2. Wie bei den meisten Webservern (hier A1) habe ich keinen direkten Zugang zur php.ini ...
3. es liegt doch bestimmt nicht an diesen Werten? Ist das Problem bei dem Webseitenklon auch aufgetreten?

April 18, 2019 um 3:59 pm #3640533

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Florian,

Vielen Dank, ich habe nochmal alles überprüft. Auch das Ändern der Default Sprache der Strings brachte keine Lösung, ebenso nicht das Abändern div. Werte. Damit ich das Problem nun intern zu unserem 2nd Tier sowie ggf. meinen Toolset Kollegen weitergeben kann benötige ich bitte noch folgende Infos:

- FTP Zugangsdaten
- Duplikator Seitenkopie
- Können Sie etwa abschätzen, ab wann/welches Update das Problem verursacht hat?
- Bei mir tritt das Problem auch im Backend auf. Die Ländern sind im Backend auch in Englisch. Sie haben geschrieben, dass dies nur im Frontend auftritt. Können Sie dies bestätigen?

Zu den Einstellungen:

#1 Ignorieren Sie bitte vorerst die utf8mb4 Meldung. Da Sie geschrieben haben, dass A1 verwendet wird, können Sie dies vorerst so belassen. Dies ist ein typisches Problem von älteren Webservern. Falls eine Änderung nötig ist, gebe ich Ihnen Bescheid.

#2 Sofern Sie bei A1 den Business Linux Webserver/Webspace verwenden, können sie die A1 Hotline anrufen und es wird die php.ini für Änderungen freigeben, oder es wird direkt für Sie konfiguriert. Es ist dazu für Sie nur das Kundenkennwort des Vertragsinhabers notwendig. Einstellungen wie "fopen" können auch über die .htaccess gesteuert werden. Fragen Sie am besten bei A1 nach. Ich würde auch empfehlen "set_time_limit", "max_input_vars" erhöhen zu lassen, damit Ihre Installation auch für zukünftige WP Releases stabil läuft. WP_MEMORY wird über die wp-config.php gesetzt.

#3 Das Problem tritt am Klon ebenso auf. Bitte haben Sie Verständnis dafür, dass ich die minimalen Systemvoraussetzungen durchprüfen muss, bevor ich unseren 2nd Tier Support zuziehen kann, da dies bereits einen Großteil der Probleme beseitigt, sowie das Tickethandling stark vereinfacht, wenn wir diese Punkte als Fehlerquelle ausschließen können.

Ebenso möchten wir sicherstellen, dass Ihre Installation stabil läuft und nicht andere Plugins, oder neuere WP Core Änderungen (Beispiel der neue Blockeditor), welche viel Speicher benötigen auch WPML an das Limit bringt.

Mit den angeforderten Informationen sollten wir nun schnell zu einer Lösung kommen.

Vielen Dank
Freundliche Grüße Marcel

April 19, 2019 um 8:59 am
April 30, 2019 um 8:33 am #3709477

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Florian,

vielen Dank für alle Infos. Ich wollte Ihnen Bescheid geben, dass ich noch auf eine Antwort unseres 2nd LVL warte. Das Ticket ist bereits eskaliert und ich gebe Ihnen Bescheid, sobald ich eine Rückmeldung erhalte.

Freundliche Grüße Marcel