Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 0.54 hours from now. Thank you for your understanding.

This topic contains 17 Antworten, has 2 Teilnehmer.

Last updated by clemensG vor 1 Jahr, 1 Monat.

Assigned support staff: Cristina.

Autor Beiträge
Oktober 15, 2018 um 10:16 am #2816953

clemensG

Hallo, gibt es schon Neuigkeiten? Lg

Oktober 15, 2018 um 11:45 am #2817200

Cristina

Hallo Clemens,

der Kollege hat sich das angeschaut und glaubt, das hier ein Workflow-Problem stattgefunden hat.

Die Konfiguration der Checkboxen im Screenshot ist so, dass die Option gewählt ist, den Wert der Felder von der Datenbank zu lesen. Das Problem dabei ist, dass diese Werte nicht übersetzbar sind. Die richtige Einstellung hier wäre die Option "Show one of these two values: " und dann den Wert setzen, der im Frontend erscheinen soll.

Dieser Wert muss dann in String Translation übersetzt werden. Dabei erscheint das Feld in der Text-Domain "plugin Types" als beispielsweise "field specials option wpcf-fields-checkboxes-option-d9e4cee3e941ff0ba26a58a9d252219f-1 display value selected", wobei dieses "display value selected" das Feld ist, dessen übersetzter Wert angezeigt wird.

Diese Felder können schon vorher auf der Seite nicht korrekt erschienen sein, das konnte so nicht funktionieren. Eventuell ist das aber nicht aufgefallen, wenn diese Optionen nicht in den übersetzten Appartments enthalten waren.

Ich habe im Duplikat diese Checkboxen in der Einstellung verändert und damit konnte die Werte korrekt gezeigt werden.

Das benötigt dann auch keine weitere oder zusätzliche XML Konfiguration, sondern funktioniert direkt nach der Übersetzung in String Translation.

MfG,
Cristina

Oktober 16, 2018 um 9:15 am #2820240

clemensG

Thank you Cristina, the tips helped me to resolve the problem. Best regards!