Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

This thread is resolved. Here is a description of the problem and solution.

Problem: The database table wp_icl_string_pages quickly grows too large amount of rows and size.

Solution: Go to WPML -> Support -> Troubleshooting and run the option "Recreate ST DB Cache table"

This will reset the table.

Further, the issue should be solved with the release of CMS Multilingual 4.3

Relevant Documentation: The Beta versions of your new plugins are already available on your wpml.org account. More information can be found here: https://wpml.org/version/wpml-4-3-0-b-8/

This topic contains 5 Antworten, has 2 Teilnehmer.

Last updated by peterD-37 vor 3 Wochen, 4 Tagen.

Assigned support staff: Andreas W..

Autor Beiträge
September 18, 2019 um 3:39 pm #4598289

peterD-37

The table wp_icl_string_pages quickly grows too large again and again. We know we can reset it by clicking in WPML>Support on [German version] "ST-DB-Cache-Tabellen wieder erstellen" (String Translation-Cache-Tabellen neu erstellen, wenn sie fehlen oder ungültig sind.) (look at attachment).

This resets the table to 0 byte. But then it heavily grows again. If we wait two weeks, this table is between 4 GB and 8 GB in size (look at other attachment) and keeps growing, which is not ok and a risk for the whole WordPress installation to run smoothly.

Please tell us how we can fix this one and for all so this table doesn't reach these gigantic dimensions.

September 19, 2019 um 1:39 am #4600429

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Please go to WPML ->String Translation and disable *Auto-Registering* option for all of the String Domains.

This should minimize the strings that are getting added to String Translation once a plugin is activated or updated.

Further, please take note the our next major update will bring performance imporvements about how String Translation handles strings. We will start working by defaut with .mo files, that are gathered from the the single themes or plugins, as long provided by the authors. This way we will be able to minimize the amount of strings needed in String Translation and enhance the performance for the website.

The Beta versions of your new plugins are already available on your wpml.org account. More information can be found here:
https://wpml.org/version/wpml-4-3-0-b-8/

Let me know if this solved the issue.

Kind regards
Andreas

September 23, 2019 um 1:20 pm #4624427

peterD-37

Hi Andreas,

we performed the steps you explain above last week. Today we have a look at the table and it has grown large again: Over 17 Mio. lines with 1.2 GB - and still growing...

As attachement I send you a screenshot of the setting you suggested and we have active from last week on and a second screenshot of the current table size.

Please help us so that this table finally stops exploding all the time.

Many greetings,
- doffine

September 24, 2019 um 1:30 am #4627003

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better for a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards,
Andreas

September 24, 2019 um 11:21 pm #4634403

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

I took a review of the test site and I did not spot any PHP errors or notifications. In fact the icl_string_pages table has almost 18 million entries.

Our second tier informed that our developers are aware of the issue and we are currently working on the final release for Multilingual CMS 4.3, which will be designed to treat string differently and avoid overloaded databases while enhancing the site performance.

I have installed our latest Beta versions of Multilingual CMS, Translation Management and String Translation on the provided test site, for you to have a review.

Take note that the option to Recreate ST DB Cache Tables is currently not available on this versions, but you could run the option with the current version of CMS Multilingual and then update to the Beta.

You can download and install the Beta on your live site by going to Plugins -> Add new -> Commercial and changing the channel from "stable" to "beta".

Otherwise, please have couple of weeks of patience until we will have a final release date for CMS Multilingual 4.3 available.

Let me know if you do have any further questions.

Kind regards
Andreas

September 25, 2019 um 11:51 am #4638403

peterD-37

Ok, thank you very much. Since we don't want to risk using the beta version in the live site we prefer to wait a couple of weeks for the release of the stable version. In the meantime we will reset this table manually on a regular basis.

If the problem persists in stable version 4.3 we will come back to you.

Thanks again for you help,
-doffine