Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Schlagwörter: 

This topic contains 6 Antworten, has 2 Teilnehmer.

Last updated by Marcel vor 4 Wochen.

Assigned support staff: Marcel.

Autor Beiträge
Februar 23, 2020 um 7:01 pm #5549671

carlosM-77

Ich möchte zwei Textfelder aus den Settings des Plugins WP SMS übersetzen lassen. Im String-Übersetzung/Text auf Admin-Bildschirmen übersetzen finde ich sie auch. Wenn ich dann jedoch auf den Button Anwenden klicke und in String-Übersetzung nach Strings suche, die nur in diesen Textfeldern vorkommen, findet WPML diese nicht. Wie kann ich diese Felder übersetzen?

Danke
Carlos

Februar 24, 2020 um 3:25 pm #5555623

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Carlos,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

#1 Fügen Sie bitte diesen Code Ihrer wp-config.php hinzu, um den Arbeitsspeicher von WP zu erhöhen. Damit wird der Speicher von aktuell 40MB auf 256 erhöht. WPML benötigt mind. 128MB.

define ('WP_MEMORY_LIMIT', '256M'); 

Fügen Sie es kurz vor:

 
/* That's all, stop editing! Happy blogging. */

#2 Bitte überprüfen Sie ebenso folgendes Ticket: https://wpml.org/forums/topic/cant-add-string-for-translation-from-admin-strings/

Dies kann durch einen geringen Wert der PHP-Variable "max_input_vars" ausgelöst werden. Sie haben aktuell einen Wert von "1000" definiert. Sie können dies über Ihre php.ini erweitern, sowie bei manchen Hosting Umgebungen direkt in der .htaccess Datei.

Dies sollte das Problem beheben, ansonsten geben Sie mir bitte Bescheid.

Freundliche Grüße
Marcel

Februar 24, 2020 um 9:03 pm #5557493

carlosM-77

Hallo Marcel,

vielen Dank für die schnelle Hilfe. Mit der Erhöhung von max_input_vars = 10000 konnte ich die Strings jetzt übersetzen. Leider werden die Übersetzungen nicht im Frontend angezeigt, oder muss ich irgendwo noch was synchronisieren? Es kann aber auch sein, dass WP SMS nicht voll mit WPML kompatibel ist. Hast du noch ne Idee?

Gruß
Carlos

Februar 25, 2020 um 9:07 am #5560375

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Carlos,

Ich würde mir das gerne direkt auf Ihrer Seite ansehen. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

Februar 27, 2020 um 5:10 pm #5580133

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Gerd,

also der String ist korrekt übersetzt und die Einstellungen ebenso. Bitte versuchen Sie Plugin auf folgender isolierten Sandboxumgebung zu installieren und den Fehler minimal nachzustellen.

Wenn wir den Fehler hier ebenso reproduzieren können, kann ich den Fall an unser Kompatibilitäts-Team weitergeben. Die werden dann versuchen einen Workaround dafür bereitzustellen oder kontaktieren den Autor, falls notwendig:

hidden link

Bitte um Info

Freundliche Grüße
Marcel

März 6, 2020 um 12:30 pm #5635001

carlosM-77

Hallo Marcel,
vielen Dank. Ich bin grad ziemlich eingespannt und hoffe, das am WE einrichten zu können.

Gruß
gerd

März 6, 2020 um 12:50 pm #5635141

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Gerd,

kein Problem. Geben Sie mir bitte einfach Bescheid, wenn Sie so weit sind.

Freundliche Grüße
Marcel

Das Thema „[Geschlossen] Textstrings aus settings können nicht übersetzt werden“ ist für neue Antworten geschlossen.