Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 6 Antworten, has 2 Teilnehmer.

Last updated by danielK-15 vor 3 Monate, 1 Woche.

Assigned support staff: Noman.

Author Artikel
Juli 9, 2019 um 7:41 am #4168207

danielK-15

I use Shoptimizer Theme and 5 Languages... i need to have a claim besides the logo... the Theme is not able to show the Claim beside the logo in text so i made 5 different logos for each langauge with the claim as png... but when i upload the logos in the different languages nothing happens... its on all sites in my default language (german)

Juli 9, 2019 um 8:00 am #4168309

Noman
Supporter

Languages: Englisch (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. If your site logo is added from Customizer/Theme options then you can translate it by following this doc:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

Juli 9, 2019 um 8:13 am #4168381

danielK-15

HI

I already tried that... problem is it seems that under theme_mods_shoptimizer there is no logo url...

Juli 9, 2019 um 8:19 am #4168485

danielK-15

FYI i used the regular way for the logo under Design--> Customizer--> General--> website information... my theme uses this method for the theme logo

Juli 9, 2019 um 2:21 pm #4171781

Noman
Supporter

Languages: Englisch (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

Juli 10, 2019 um 10:11 am #4178171

Noman
Supporter

Languages: Englisch (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have followed the below steps in order to translate logo:
- Enabled logo translation from WPML >> String Translations >> (at the bottom of page) “Translate texts in admin screens” >> theme_mods_shoptimizer-child-theme > custom_logo
- Copied logo I'D for each language from Media >> Library.
- Added logo ID as translation from WPML >> String Translations as you can see in the attached screenshot.

Now it showing correct logo in each language.

Thank you

Juli 10, 2019 um 10:25 am #4178615

danielK-15

My issue is resolved now. Thank you!