Navigation überspringen

Dieses Thema ist gelöst. Hier finden Sie eine Beschreibung des Problems und der Lösung.

Problem:
Wenn Sie feststellen, dass Inhalte, die Sie auf der Originalsprachseite gelöscht haben, immer noch auf der übersetzten Seite angezeigt werden, liegt das daran, dass Änderungen an einem Unterfeld im Standardfeld "gdlr-core-page-builder" nicht automatisch in der Übersetzung synchronisiert werden.
Lösung:
Um dieses Problem zu beheben, empfehlen wir Ihnen, anstelle eines leeren Feldes den HTML-Code

 

in das entsprechende Feld einzufügen. Speichern Sie die Änderungen und aktualisieren Sie die Übersetzung, damit dieser Code in die übersetzte Version übernommen wird und effektiv einen Raum anzeigt. Alternativ können Sie die gesamte Icon-Liste entfernen und neu erstellen, ohne die Beschriftungen, oder den entsprechenden Eintrag direkt aus der Datenbank löschen.

Bitte beachten Sie, dass diese Lösung möglicherweise nicht mehr relevant ist, da sie veraltet sein könnte oder nicht auf Ihr Problem zutrifft. Wir empfehlen Ihnen, die bekannten Probleme zu überprüfen, die Version der dauerhaften Lösung zu verifizieren und zu bestätigen, dass Sie die neuesten Versionen von Themes und Plugins installiert haben. Sollte das Problem weiterhin bestehen, zögern Sie nicht, ein neues Support-Ticket zu öffnen. Hier können Sie das WPML-Supportforum kontaktieren: WPML-Supportforum.

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

Schlagwörter: ,

Dieses Thema enthält 23 Antworten, hat 2 Stimmen.

Zuletzt aktualisiert von Prosenjit Barman Vor 1 Monat, 3 Wochen.

Assistiert von: Prosenjit Barman.

Verfasser Beiträge
Januar 8, 2024 unter 6:26 pm #15162340

remigiusK

Hallo WPML Support Team,
Dies ist die originale Seite auf Deutsch:
versteckter Link
Dies ist eine Beispielseite, wo das Problem auftritt:
versteckter Link
Die gelb markierten Werte habe ich längst gelöscht auf der Deutschen Seite aber die Englische Seite zeigt die Werte immer noch an. Habe ich etwas falsch gemacht?
Danke und Gruss, Remy

Screenshot 2024-01-08 191316.png
Screenshot 2024-01-08 191252.png
Januar 9, 2024 unter 11:06 am #15164021

Prosenjit Barman
Supporter

Sprachen: Englisch (English )

Zeitzone: Asia/Dhaka (GMT+06:00)

Hi There,
Thanks for contacting WPML Support.

To reduce the waiting time, I took this ticket and responded in English. Please let me know if you're okay with it or if you prefer to continue the conversation in German. Based on your preference, I will forward this ticket to one of our German-speaking colleagues to assist you further.

I understand the issue you're having. When you update the translation, the content on the translated page should reflect those changes made on the default page. Can you please check and confirm that if the English translation is updated? If it is, a "Pencil" icon will be visible next to the English language. If not, you will see an update icon, as illustrated in this screenshot: versteckter Link, next to the English lbefore

If the issue persists even after that, please try the following:

- Please clear the caches from the site and browser
- Go to "WPML > Support > Troubleshooting" and click on the buttons marked in this screenshot: versteckter Link [Make sure to take a backup prior to that and before pressing another button, please wait till the previous process is completed.]
- Once done open the default tour and make a small change there
- Save the changes and update the translation.

Please give it a try and let me know the update. I will be happy to help if you need further assistance in this matter.

Best regards,
Prosenjit

Januar 9, 2024 unter 9:21 pm #15166624

remigiusK

Hi, English is perfectly fine for me. The translation works, when I change something it is being recognized and changed afterwards. However, when I delete an attribute, e.g. date as shown in my attachment, the English translation still shows the content. So its only about deleted properties which are still shown. What do you thing I should do? Thanks and regards, Remy

Januar 10, 2024 unter 6:29 am #15167250

Prosenjit Barman
Supporter

Sprachen: Englisch (English )

Zeitzone: Asia/Dhaka (GMT+06:00)

Hi Remy,
Thank you for the update.

Please be informed that it's necessary to update the translation whenever you make any changes to the default content. Even if you delete elements from a post, updating the translation is essential to ensure that these changes are accurately reflected and propagated across all translated versions.

If you're having the issue even after updating the Translation please retry after making the following adjustments,

- Please go to WPML > Settings
- Scroll down to the "Posts and pages synchronization" section and check the option named "When deleting a taxonomy (category, tag or custom), delete translations as well"
- Save the changes and clear the caches
- Go to the Tour post type and open the tour where you;re having the issue.
- Make a small change or delete the Elements that you don't want and save the changes.
- Then proceed to update the translation.

Please let me know how it goes. I will be happy to help if you need further assistance in this matter.

Best regards,
Prosenjit

Januar 10, 2024 unter 6:39 pm #15171044

remigiusK

Hi, yes I always update the translation whenever I make a change to the German (original) site. However, the error still persits when I delete a certain value (see example attached). Thanks and regards, Remy

Screenshot 2024-01-10 193732.png
Januar 11, 2024 unter 6:47 am #15172291

Prosenjit Barman
Supporter

Sprachen: Englisch (English )

Zeitzone: Asia/Dhaka (GMT+06:00)

Hello Remy,
Thank you for understanding the matter and trying out the suggestions.

As the issue persists even after that, a closer inspection will be required to understand the root cause of the issue.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to have a testing site where the issue is replicated.

You will find the needed fields below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” or "All in One WP Migration" on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT
-Please backup site files and database before providing us access.
-If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
versteckter Link

Looking forward to your response.

Best Regards,
Prosenjit

Januar 11, 2024 unter 8:47 am #15172780

remigiusK

Hi, I have only deleted the cache so far. Shall I do the follwoing which you proposed before we continue?
- Go to "WPML > Support > Troubleshooting" and click on the buttons marked in this screenshot: versteckter Link [Make sure to take a backup prior to that and before pressing another button, please wait till the previous process is completed.]
- Once done open the default tour and make a small change there
- Save the changes and update the translation.

Thanks and regards, Remy

Januar 12, 2024 unter 4:20 am #15177194

Prosenjit Barman
Supporter

Sprachen: Englisch (English )

Zeitzone: Asia/Dhaka (GMT+06:00)

Hi Remy,

Yes, it's suggested to go through the troubleshooting process, as it often successfully resolves issues like these.

However, if the problem continues even after troubleshooting, please provide access to a site where the issue is reproduced. Ideally, this would be a staging or testing site to ensure the main site remains undisturbed during the debugging phase. After the debugging is finished and the issue is resolved, I will inform you of the steps taken to rectify the problem. This way, you can implement the same solution on your main site.

To securely share access details, I have activated a private box for you. Please make sure to share the access information through the private box.

Looking forward to your response and will be happy to assist you further.

Best regards,
Prosenjit

Januar 15, 2024 unter 11:54 am #15184798

remigiusK

Hi please bear with me 2-3 since I cannot try to resolve the issue at my end. Thank you. Regards, Remy

Januar 16, 2024 unter 3:06 am #15187479

Prosenjit Barman
Supporter

Sprachen: Englisch (English )

Zeitzone: Asia/Dhaka (GMT+06:00)

Hi Remy,
Hope you're doing well.

Please feel free to take your time to conduct the test. We will keep this ticket open for 7-10 days. If it is automatically closed by our system, please don't hesitate to create a new ticket and include the link to this ticket as a reference. I'll be more than happy to assist you further from there.

The private field is still opened for you so that you can securely share the access. Looking forward to your response.

Best regards,
Prosenjit

Januar 22, 2024 unter 7:34 am #15209580

Prosenjit Barman
Supporter

Sprachen: Englisch (English )

Zeitzone: Asia/Dhaka (GMT+06:00)

Hello There,
Thank you for sharing the access information.

Upon investigation, I found that Goodlayer Page Builder has been used to build the site. A detailed examination revealed that all elements of the Goodlayer page builder are included in the "gdlr-core-page-builder" field. you can check by navigating to "WPML > Settings > Custom Field Translation", where this field is marked as "translatable".

To successfully update the page's translation, I performed the following steps:

1. I removed the captions from the Icon list module, saved these changes, and then updated the translation.

2. Next, I went to "WPML > Settings > Custom Field Translation" and changed the translation preference for the "gdlr-core-page-builder" field to 'copy', followed by saving the changes.

3. I then reopened the post and updated it without making any modifications. This action triggered an update in the translation, which I completed by clicking on the update icon (illustrated in this screenshot: versteckter Link).

4. Afterward, I reset the translation preference for the "gdlr-core-page-builder" field back to "Translate" and saved these changes.

5. I reopened the page, updated the post again without any changes, thereby triggering another translation update, and updated the translation using the update icon.

This process ensured that the updated content appeared correctly on the translated page. I understand that switching the translation preference back and forth might seem troublesome, but this approach was necessary due to the syncing issue between the default and translated posts, likely a result of how the Goodlayer plugin manages data.

It would be more effective to reach out to the Goodlayers support team for assistance with this matter. They are likely to provide more suitable guidance for resolving this issue efficiently.

Alternatively, you can use the manual translation to translate your page using the WordPress editor. Kindly check our guide about manual translation for more details: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

Let me know the update. I will be happy to help if you need further assistance in this matter.

Best regards,
Prosenjit

Januar 22, 2024 unter 10:04 pm #15213637

remigiusK

Hi Prosenjit, I am surprised that this should be an issue with Goodlayers. I have this template since 2018 and this was never an issue with the caption field. Furthermore I checked now the French site: versteckter Link
and its not working there. Thank you. Kind regards, Remy

Januar 24, 2024 unter 3:40 am #15219418

Prosenjit Barman
Supporter

Sprachen: Englisch (English )

Zeitzone: Asia/Dhaka (GMT+06:00)

Hello Remy,

Similarly to the method I outlined previously, I was able to update the French translation for the tour successfully. Additionally, I created a video where I detail the steps taken and demonstrate the functionality of the French page. You can view this video at: versteckter Link.

Please note that the "TravelTour" theme you are using is not included in our list of compatible themes(You can check by going here: https://wpml.org/theme/). Therefore, the issue you're having could be a compatibility issue. However, it's important to mention that the Infinite Theme by Goodlayers, which also uses the Goodlayers page builder, is the only Goodlayers theme compatible with WPML. For further information, please refer to the link provided below.

- https://wpml.org/documentation/theme-compatibility/build-multilingual-sites-infinite-theme-goodlayers-builder/

However, if you suspect that WPML is the primary source of the problem, I am willing to conduct a more thorough investigation. Could you please upload the TravelTour theme along with the required plugins to our sandbox site? This will help me replicate the issue. Below, you will find the autologin link to access our sandbox.

- versteckter Link

Once you have finished uploading the theme and plugins, kindly inform me. I will perform some tests, and if necessary, I'll escalate the matter to our development team. Rest assured that if WPML is a contributing factor to this issue, we will make every effort to resolve it.

Thank you for your understanding and cooperation in this matter. Looking forward to your response.

Best regards,
Prosenjit

Februar 3, 2024 unter 9:49 am #15261885

remigiusK

Hi, sorry for the delay. The Sandbox has expired. Could you open an new one please? Thank you and regards, Remy

Februar 5, 2024 unter 5:05 am #15264196

Prosenjit Barman
Supporter

Sprachen: Englisch (English )

Zeitzone: Asia/Dhaka (GMT+06:00)

Hello Remy,
I hope you're doing well.

I've set up a new sandbox environment for you. Click on the following link to access a clean sandbox setup: versteckter Link

Once you're able to replicate the issue, please let me know. I will take a closer look and try my best to assist you in solving the issue.

Thank you for your patience and kind cooperation.

Best regards,
Prosenjit

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.