Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 8 Antworten, has 2 Teilnehmer.

Last updated by Alejandro Vor 1 Monat.

Assigned support staff: Alejandro.

Author Artikel
Oktober 11, 2021 um 3:10 am #9756443

benediktS-15

Sagen Sie uns, was Sie versuchen zu erreichen?

Ich habe das Gefühl, etwas funktioniert nicht richtig. Das Tranlation Management kann ich nicht einrichten.
ich habe nur Probleme , das Produkte nicht angezeigt werden. Inzwischen habe ich es für die übersetzten Produkte geschafft, aber die Produkte in der Englischen Version, werden zwar einzeln angezeigt, aber nicht in den Kategorien. Auch nicht, wenn ich die Kategorie neu anlege und die Artikel kopiere bzw neu importiere.... Bitte helft mir ... ich bin echt am verzweifeln...arbeite an dieser sache jetzt schon das ganze Wochenende...

Ich habe auch immer wieder, das sich Sachen selber überschreiben. Liegt das daran, das ich mit Elementor und einem nicht laufenden Translation Management arbeiten muss?

Folgen Sie einer Dokumentation?

Ja, soweit es geht

Gibt es ein ähnliches Beispiel, das wir sehen können?

hidden link
hidden link

Was ist der Link zu Ihrer Website?

Oktober 12, 2021 um 7:13 am #9767801

Alejandro
Supporter

Languages: Englisch (English ) Spanisch (Español ) Italienisch (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!

I'd like to help you out but we'd need to continue in English since there are no german speakers at the moment, i hope it's alright by you.

1) Let's start by meeting WPML's and WooCommerce's minimum requirements:

Please add the following code in your wp-config.php file, right after the database information lines of code:

define('WP_MEMORY_LIMIT','256M');

2) As i understand you have a few problems here. one of them is that you translated your categories but the products are not appearing inside that category, correct?

If that's the case then i think the problem is that you might've translated the categories after you translated the products.

you might be able to syc them by going to WooCommerce > WooCommerce Multilingual > Categories > Synchronize categories between products.

OR

you can also achieve the same by updating the original products (bulk edit them, for example, then add something like a tag and save them). if that doesn't sync the categories between the language, then you'll need to edit the translation of each of the products, independently and saving the changes so the products are now synced with the categories.

Please try that and let me know if there are other issues still to solve after that, so we can tackle them separately.

Oktober 20, 2021 um 7:41 am #9823841

benediktS-15

I fixed that error with a new frontpage ... but another thing is still confusing. When i hit the button for Translation editor i just get the message, that i need to install it. But when i enter translations from the pages editor the advnace Translation edit load and is working.

Can you give me a good howto for the Translating Elementor Header/Footer with wpml ?

screenshot_53.png
Oktober 20, 2021 um 3:26 pm #9828323

Alejandro
Supporter

Languages: Englisch (English ) Spanisch (Español ) Italienisch (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Alright, please do the following:

1) update your plugins to the latest version we released a few days ago: https://wpml.org/de/account/downloads/

2) Disable all the plugins. then enable them again, leaving WPML as the last plugins to enable.

Then check if the problem is fixed and if it's not then please:

- Write in the next answer the steps to recreate the problem

- Allow me access to your site if possible, using the credential fields i have enabled for your next answer.

Thanks in advance.

November 1, 2021 um 11:37 am #9901389

benediktS-15

I am still trying to Configure WPML Translation Management but it doesn't work. I followed the workaround and downgraded the Plugin as adviced here: https://wpml.org/forums/topic/split-can-not-complete-translation-management-this-quick-setup/ but after the update to actualize, nothing changed for me... is still see this blanko apage with the info, to finish the short setup.

November 2, 2021 um 7:30 am #9905939

Alejandro
Supporter

Languages: Englisch (English ) Spanisch (Español ) Italienisch (Italiano )

Timezone: Europe/Rome (GMT+01:00)

To continue, I'll need temporary access to your site because i would really like to see if there's an error preventing the activation of Translation management.

I have just activated the appropriate boxes for the credential information i need from you. they are private so only you and i will be able to see them.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the fields mentioned above.

November 3, 2021 um 3:08 pm #9918089

Alejandro
Supporter

Languages: Englisch (English ) Spanisch (Español ) Italienisch (Italiano )

Timezone: Europe/Rome (GMT+01:00)

The error seems to come from a JS that was added on your site, seems customly added:

<script id='admin_vdz-call-back-js-after'>
document.getElementById('deactivate-vdz-call-back').onclick=function (e){alert('Thanks for your time with us! (VDZ Call Back Plugin) Have a nice day!');}
</script>

it throws an error on the JS console (right click on the page > inspect) on the back-end and that might be breaking the REST calls that we are doing in WPML > Translation Management to get your site's data.

can you try to remove that code and then check if the problem disappears?

November 4, 2021 um 3:26 pm #9927125

benediktS-15

On which page you've got this error message?... i disabled the vdz plugin and checked the translation management page. nothing is changed...still showing, to complete the short setup...

November 4, 2021 um 3:52 pm #9927495

Alejandro
Supporter

Languages: Englisch (English ) Spanisch (Español ) Italienisch (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Alright. next error is an SSL protocol error.

as soon as you access the back-end and open the JS Inspector you get an error like this one:

Failed to load resource: net::ERR_SSL_PROTOCOL_ERROR

this suggests there might be an issue with the SSL or with the SSL configuration. can you please look into this and fix it?

i won't happen everytime, so you need to refresh your page a few times (sometimes) to see the error.

Let's fix this so i can check what else is going on.

Das Thema ‘[Geschlossen] Translation Management nicht funktionstüchtig’ ist für neue Antworten geschlossen.