Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

Schlagwörter: 

This topic contains 4 Antworten, has 2 Teilnehmer.

Last updated by Cristina vor 1 Jahr, 5 Monate.

Assigned support staff: Cristina.

Autor Beiträge
Mai 11, 2018 um 3:14 pm

vinko-vincenzK

Ich versuche: Until yesterday it works fine, but today, the translated strings are not anymore vissible in the other language. Its shows the original, for example the landing page.

URL der/meiner Website, auf der das Problem auftritt: hidden link

Erwartet hatte ich zu sehen:

Stattdessen bekam ich:

Mai 11, 2018 um 5:39 pm #2093206

vinko-vincenzK

Update: To run the site, i translated it manualy right now. The problem is still actual

Mai 11, 2018 um 6:38 pm #2093534

Cristina

Hallo Vinko,

thanks for contacting and for the access and debug information.

If this has happened overnight, do you remember anything that could have changed in one day if you did not any update or change on the site?

I have logged in to the site to check the settings.

On the Admin > Settings > Reading settings there is a static homepage defined, where the warning exists that the Homepage is not translated.

If you go to this page in croatian, the english page is a duplicate and the german page a translation.

They are connected, so if they are marked as missing by WordPress there may be some temporal information stuck.

Could you check if this problem may have been caused by any workflow mixing the translation modes? As mixing the translation modes can lead to problems.

If you have defined the Translation Editor as translation mode in the settings for multilingual content setup in the Translation Management module, this will be used as default mode for translations.

But when using manual mode, changes in the original content are not updated Translation Editor. Therefore the Translation Editor does not reflect changes made from manual mode.

If you were using the translation editor before and changed something on the original page while the translation still needed an update, this change may have cause the translated page to be set to draft status if you then changed to manual translation mode.

This may be a cause to not see updates reflected correctly in the Translation Editor and on the site. If there was any sort of browser cache active on your side or the browser redirection mislead you, this may have happened before yesterday.

The Translation Editor will show up for everything that was started with that translation mode unless it is saved 100 %. Then it is possible to change the mode without losing any updates.

So in order to check if this was the case, please save the texts that you need in a backup outside the site. Then change the english duplicate to a translation in case you want to translate it, otherwise keep it as duplicate.

Try if changing to the translation editor, and then saving the original page with a minimal change, like a comma. Then open the translated page in the Translation Editor and check if all fields show up. Save all with 100% translated. Then do again a small change in the original page and update the translation. It should show all fields in the editor. If there was an existing translation it will be appear in the corresponding fields.

Then finish the translation with the actual state of the original page, using the save backuped texts you have. This will sync the versions together again. If you save you should also see that in the Admin Settings > Read the warning has disappeared.

In the debug information I see that your value for SiteURL show the https but the HomeURL shows http. This should be the same value and the real value of the homepage. You could check if setting the correct version helps here too.

Looking at your debug information I see that you have several plugins installed. As WPML needs at least 128M to work smoothly and your WordPress memory seems to have only 40M, you may run into issues here also when saving a translation.

Therefore it is advisable that you increase the memory limit to 256MB by adding this code to your wp-config.php, just before the line with “happy blogging” to avoid performance problems in the backend.

define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Kind regards,
Cristina

Mai 18, 2018 um 10:35 pm #2192431

vinko-vincenzK

Hello Cristina,

thank you for your answer, but unfortunatly i did not realy understand.

If you can write maybe in german woudl be perfect.

What i noticed is that only the strings with the plugin ULTIMATE VC Adons from Breinstorm are not showing in the other language also if the translation was done. I dont use the editor, only string translation. I installed the day before this plugin, but start the next day. Proobably is this the issue? Is this plugin not working or compatible with wpml?

I increased the mermory to 512mb. Now i see it works also well everything.

Mai 21, 2018 um 12:15 pm #2201122

Cristina

Hallo Vinko,

gerne antworte ich hier auf Deutsch.

So wie es aussieht, hat sich das Problem mit dem Erweitern des Arbeitsspeichers gelöst.

Im Prinzip ist das Plugin Ultimate VC Addons mit WPML kompatibel, so dass es eventuell ein Problem fehlender Ressourcen gewesen ist, das hier die Übersetzungen nicht korrekt gespeichert wurden.

Was meine vorherige Antwort betrifft, wollte ich nur darauf hinweisen, dass ein Mischen von Übersetzungsmethoden auf der gleichen Seite zu Problemen führen kann.

Wenn der Übersetzungseditor als Standardmethode gewählt ist, wird dieser Übersetzungsmodus immer angewendet. Änderungen, die man dann nachträglich manuell in einer übersetzten Seite hinzufügt, ohne den Übersetzungseditor aufzurufen, werden auf der Seite nicht angezeigt, weil sie dann nicht im Übersetzungseditor gespieichert wurden.

Wenn Sie Seiten manuell (im gleichen Layout wie auf der Originalseite) verändern möchten, sollte zuerst die Übersetzung im Übersetzungseditor fertig und als fertig markiert gespeichert sein. Dann wechselt man erst die Übersetzungsmethode und dann kann man die Seite auch manuell ändern. Da wird dann auch auf der Seite angezeigt.

Aber in diesem Fall scheint es wohl ein Problem von fehlendem Arbeitsspeicher gewesen zu sein.

MfG,
Cristina