Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 7.57 hours from now. Thank you for your understanding.

This topic contains 17 Antworten, has 3 Teilnehmer.

Last updated by David vor 6 Jahre, 1 Monat.

Assigned support staff: Harshad.

Autor Beiträge
Januar 24, 2014 um 2:54 pm #327272

David

Hello,

we use DE as standard language, plus EN and ES.

If we add spanish translations to existing posts, all looks fine, but after saving the posts are set to DE (not ES!) and aren't linked to the standard post.

The problem exists only with translations to ES (EN works). And there is no problem with brand new posts.

WP 3.8.1, newest WPML, same problems without other plugins and the standard theme.

Best regards
David

Januar 24, 2014 um 8:32 pm #327415

Bruno
Supporter

Languages: Englisch (English ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Dear David,

We released a new WPML version today. You have already downloaded? The current version is 3.0.2.

If you have not downloaded, please download it and before upgrading, do the full backup of your site.

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.

Thank you.

Januar 27, 2014 um 2:54 pm #328414

David

Dear Bruno,

it does not resolve the problems.

Best regards
David

Januar 27, 2014 um 8:02 pm #328563

Bruno
Supporter

Languages: Englisch (English ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Dear David,

I'll ask for some information so I can verify the problem. The fields for you to insert the credentials will be below its comment field.

Note: Please make a full backup of your site.

Thank you.

Januar 28, 2014 um 2:11 pm #329063

David

Hi Bruno, OK!

Januar 28, 2014 um 8:45 pm #329307

Bruno
Supporter

Languages: Englisch (English ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Dear David,

I created three test page (WPML Test, Test WPML EN and Test ES). Now the posts are as Draft. The page lost the connection after editing - with the normal editor and the quick edit.

I will send this to our developer check.

Thank you.

Januar 29, 2014 um 10:20 am #329578

David

Hi Bruno,

there were no problems with new posts (post #1), we have not been able to translate existing pages to spanish.

Januar 29, 2014 um 8:05 pm #330066

Bruno
Supporter

Languages: Englisch (English ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Dear David,

I am forwarding your ticket to 2nd tier support.

Soon they will get in touch.

Thank you.

Januar 30, 2014 um 8:40 am #330269

Harshad

Dear David,

I have sent you email.

I have attached development version of WPML CMS plugin, please remove the existing plugin, upload the attached development version and activate it.

Let me know if this helps.

Januar 31, 2014 um 10:01 am #331023

David

Hi Harshad,

unfortunately it breaks the "add page". I'll send you a screenshot.

Best regards
David

Februar 2, 2014 um 6:52 am #331737

Harshad

Dear David,

Sorry for delay, Can you please try this:

Go to wordpress admin wpml -> support, Click on the troubleshooting link at the bottom of the page.

On troubleshooting page
1) Click "Remove ghost entries from translations table" button.
2) Click "General clean up" button.
3) Click "Set language information" button.

Februar 3, 2014 um 1:56 pm #332284

David

Hi Harshad,

I did, but it didn't resolve the problem.

Added a spanisch translation to JOYA Classic (JOYA Classic ES) - after saving the translation is not linked with the original german post.

Februar 4, 2014 um 11:52 am #332944

Harshad

Dear David,

I have only access to wp-content folder, Can you please enable a PHP error log file and check what's there?

From this page:
http://wpml.org/documentation/support/debugging-wpml/

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Let's see what it includes.

Februar 10, 2014 um 5:15 pm #336786

David

Hi Harshad,

creating a translation to ES and saving the page produces only the following error:

WordPress-Datenbank-Fehler Duplicate entry '4001-es' for key 'trid_lang' f\xc3\xbcr Abfrage UPDATE `wp_icl_translations` SET `trid` = '4001', `language_code` = 'es', `source_language_code` = 'de' WHERE `element_type` = 'post_page' AND `element_id` = '3448' von edit_post, wp_update_post, wp_insert_post, do_action('save_post'), call_user_func_array, SitePress->save_post_actions, SitePress->set_element_language_details, referer: hidden link

EN and FR works fine for existing pages, too... but not ES.

Best regards
David

Februar 11, 2014 um 6:52 am #337051

Harshad

Dear David,

I have sent you email.

I have attached development version of WPML CMS plugin, please remove the existing plugin, upload the attached development version and activate it.

Let me know if this helps.