Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 6.90 hours from now. Thank you for your understanding.

Schlagwörter: 

This topic contains 12 Antworten, has 2 Teilnehmer.

Last updated by Marcel Vor 2 Monate, 3 Wochen.

Assigned support staff: Marcel.

Author Artikel
September 22, 2020 um 3:43 pm #7071469

thomasF-69

Hallo, ich wollte meine Globalen Elementor Widgets übersetzten, jedoch bleibt der Status der Übersetzungen auf Übersetzung wird verarbeitet stecken (Sanduhr).

Nun wollte ich in den WPML Einstellungen den Übersetzer und Übersetzungsmanager synchronisieren, bekomme dann aber den den Fehler "TypeError: Failed to fetch".

Können Sie mir da weiterhelfen?

September 22, 2020 um 4:20 pm #7071695

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Thomas,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Die genannte Fehlermeldung könnte ein Zeichen dafür sein, dass z.B. die Seite über eine andere URL als in den WP Einstellungen konfiguriert ist, aufgerufen wird.

Unterschiede könnten z. B.: 301 Weiterleitungen sein, Umleitungen von http -> https oder auch unterschiedliche URLs mit/ohne WWW sein.

Anbei ein ähnlicher Fall: https://wpml.org/forums/topic/failed-to-fetch-advanced-transation-editor/

#1 Um welche URL handelt es sich?
#2 Welche URL ist in den WP Einstellungen unter Settings -> General konfiguriert (Screenshot: https://wpml.org/wp-content/uploads/2019/11/5029379-settings_5.png)

Bitte um Info

Freundliche Grüße
Marcel

September 23, 2020 um 9:40 am #7078057

thomasF-69

Hallo, vielen Dank für die Hilfe.

Es handelt sich um die URL

hidden link

Diese URL ist auch so als "WordPress-Adresse (URL)" und "Website-Adresse (URL)" eingetragen.

Liebe Grüße

September 23, 2020 um 9:59 am #7078259

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Danke fpr die Infos. Also die SeitenURL ist somit korrekt. Ich würde mir das gerne direkt auf Ihrer Seite ansehen. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

September 24, 2020 um 9:21 am #7088675

thomasF-69

Guten Tag, haben Sie meine LogIn Daten erhalten? 🙂

September 24, 2020 um 12:37 pm #7091161

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo! Ja, leider funktionieren diese jedoch nicht:

ERROR: The username or password you entered is incorrect. Lost your password?

Können Sie dies bitte überprüfen? Die nächste Antwort ist wieder als privat markiert. Vielen Dank!

Freundliche Grüße
Marcel

September 25, 2020 um 4:28 pm #7101637

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

haben Sie die REST-API auf Ihrer Seite eingeschränkt? Die WPML Debug Seite zeigt, dass die REST-API nicht aktiv ist. Ein direkter Aufruf scheint jedoch möglich zu sein: hidden link

Die betroffene Seite mit den Elementor Templates meldet hier einen Fehler:

Failed to load resource: net::ERR_NAME_NOT_RESOLVED
<em><u>hidden link</u></em>

Doku: https://wpml.org/documentation/support/rest-api-dependencies/

Die Seite selbst läuft auf hidden link, WPML wurde jedoch für hidden link angelegt. Ich empfehle Ihnen den Key hier zu löschen https://wpml.org/de/account/websites/ und neu in WPML zu hinterlegen, dann sollte der Abgleich mit den Übersetzern wieder funktionieren.

Freundliche Grüße
Marcel

September 27, 2020 um 5:02 pm #7109861

thomasF-69

Hallo, vielen Dank für die Antwort.

Ich komme irgendwie nicht richtig weiter.. Seitdem ich WPML installiert habe, habe ich leider nur noch Probleme mit der Website und ich finde die Lösung nicht.

Ich habe die REST-API nicht bewusst deaktiviert, habe in den PlugIn Einstellungen auch nichts dergleichen gefunden.

Versuche noch einmal genau zu beschreiben, was nicht mehr funktioniert, seitdem ich WPML installiert habe:

Wenn ich Seiten mit ELEMENTOR bearbeiten möchte, öffnet ELEMENTOR nicht mehr, es bleibt im Ladebildschirm hängen. Sobald WMPL deaktiviert ist, lässt sich ELEMENTOR wieder ganz normal öffnen und bearbeiten.

Zudem besteht der Fehler "TypeError: Failed to fetch". in den WPML Einstellungen, wie eingangs beschrieben leider immer noch.

Wäre es möglich, dass Sie sich das noch einmal anschauen?

Liebe Grüße und vielen Dank. Hoffe wir finden bald die Lösung, freue mich schon darauf die Website mit WPML zu übersetzen 🙂

September 28, 2020 um 1:21 pm #7115235

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

grundsätzlich beschrieben Sie genau das Verhalten, welches durch eine eingeschränkte REST-API auftreten kann. Dies kann nicht in WPML oder WordPress eingestellt werden. Dies könnte jedoch z.B. durch eine Servervorgabe oder eine Code-Anpassung eingeschränkt sein.

Haben Sie schon bei Ihrem Hoster angefragt, ob ggf. dieser etwas einschränkt? Bitte leiten Sie dem Hoster dazu diese Anleitung weiter: https://wpml.org/documentation/support/rest-api-dependencies/

"Failed to fetch" tritt ebenso bei einer falschen SSL-Konfiguration auf, was jedoch in Ihrem Fall keine aktuell explizite Warnung ausgibt. Der Hoster sollte dies jedoch ebenso prüfen. Anbei ein Beispiel: https://wpml.org/forums/topic/error-when-trying-to-run-translation-management-setup/

Bitte um Info

Freundliche Grüße
Marcel

September 28, 2020 um 2:58 pm #7116679

thomasF-69

Vielen Dank für die Hilfe,

gerade beim Hoster nachgefragt, von IONOS (Hoster) gibt es keine Einschränkungen. Woran könnte es denn noch liegen, bzw. gibt es eine Möglichkeit herauszufinden, wo die Einschränkungen herkommen?

Danke

September 29, 2020 um 10:40 am #7123389

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

wir haben gerade eine neue Version 4.4.3 veröffentlicht, welchen einen Fehler im Bezug zur REST-API mit einer Multi-Domain Umgebung behebt. https://wpml.org/errata/possible-nginx-issues-with-different-domains-per-language-setting-when-doing-a-rest-api-call/

Bitte installieren Sie diese Version, damit sollte das Problem gelöst sein.

Freundliche Grüße
Marcel

September 29, 2020 um 4:24 pm #7127311

thomasF-69

Vielen Dank, das Problem wurde mit dem Update behoben. Kann die Seite nun wie gewohnt nutzen!

Mai 3, 2021 um 11:22 am #8675277

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

Ich würde mir das gerne direkt auf Ihrer Seite ansehen. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel