Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 9 Antworten, has 3 Teilnehmer.

Last updated by martinR-64 vor 3 Monate, 1 Woche.

Assigned support staff: Andreas W..

Autor Beiträge
Juli 9, 2019 um 10:53 am

mell

Ich versuche: Meine Startseite zu übersetzen im customizer des Themes. Leider ohne Erfolg.
Die Admin_Texte der Strings habe ich Übersetzt. Leider ohne Unterschied.
Der Support des Themes kam leider nicht weiter.
Das Speicherlimit wurde vom Host auf 500 MB hochgesetzt.
(memory limit)
MaxInputVars sind auf 5000

Leider scheint sich nichts verändert zu haben?
Ich kann den Fehler (seit einer Woche) leide rnicht finden.

URL der/meiner Website, auf der das Problem auftritt: hidden link

Erwartet hatte ich zu sehen: Englisch auf der Startseite

Stattdessen bekam ich: Immer noch nur Deutsch

Hier auch das Kommunikationsprotokoll: (Login stelle ich gerne zur Verfügung)

Juli 9, 2019 um 1:22 pm #4171187

mell

Kann ich das Abo wieder kündigen? Sollte es mit dem Theme/ WPML nicht funktionieren?

Juli 9, 2019 um 10:42 pm #4174715

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank, dass Sie das WPML Support Forum kontaktiert haben.

Das OnePress Theme ist kompatible mit WPML und wurde vor 5 Monaten zuletzt getestet.
https://wpml.org/theme/onepress/

Ich habe das Theme unter WPML -> Theme und Plugin Loakalisierung neu gescannt und es wurden 471 neue String gefunden.

Im Grunde müssen hier alle Strings mit der String-Übersetzung berabeitet werden. Es kann aber auch vorkommen, dass Strings manuell hinzugefügt werden müssen. Gehen Sie dazu auf WPML -> String-Übersetzung und scrollen Sie zum Ende der Seite.

Klicken Sie hier auf "Text auf Admin-Bildschirmen übersetzen »".

Hier finden Sie Einträge zu verschiedenen Widgets und Plugin, wie auch Theme Optionen. Finden Sie weitere Strings zum Theme unter den Domains:

+ theme_mods_onepress
+ onepress_sections_settings

Markieren Sie die Strings, die Sie übersetzen möchten und scrollen Sie um Ende der Seite, um dort Ihre Eingabe zu bestätigen. Die Strings sollten nun auf der String-Übersetzung verfügbar sein.

Sollten manche Strings übersetzt sein, aber nicht auf der Website angezeigt werden, so geben Sie mir bitte genaue Angaben oder senden Sie uns passende Screenshots.

Mit freundlichen Grüßen
Andreas

Juli 10, 2019 um 7:42 am #4176845

mell

Hallo Andreas,

das hatte ich leider schon alles versucht und gemacht.
Die Admin Übersetzung hatte ich hinzugefügt und die Strings der Startseite zB finden sich ja auch schon.
Die Häkchen sind auch dran...
Alles bestens.
Die Übersetzung ist da.
(mit Worten wie TEST!!!!) zur besseren Ansicht.
Aber leider ist beim publishen nichts davon zu sehen??
Woran kann das liegen?
Anbei die Screens...und Bilder der Startseiten, bei denen nichts von der Übersetzung zu sehen ist? Ich bitte echt um Hilfe...mir fällt nichts mehr auf. Vielen lieben Dank!

Juli 10, 2019 um 2:59 pm #4181791

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für Ihre Nachricht.

Ich bin mir unsicher wo das Problem liegt, aber ich sehe, dass Ihr System nicht die Mindestvoraussetzungen für WPML erfüllt. Sie teilten mit, dass die Änderungen vorgenommen wurden, allerdings sehe ich unter WPML -> Status, dass dies nicht der Fall ist.

Könnten Sie bitte Ihre Speichergrenze für die WordPress-Speichergrenze (WP Memory Limit) auf mindestens 256 MB erhöhen? Für WPML ist mindestens 128M erforderlich.
Ihre aktuellen Werte sind:

MemoryLimit 512M (PHP Memory Limit in php.ini)
WP Memory Limit 40M (WordPress Memory Limit in wp-config.php)
Fügen Sie diesen Code Ihrer wp-config.php hinzu, um den Arbeitsspeicher von WP zu erhöhen:
[php]
/ * Speichergrenze /
define ('WP_MEMORY_LIMIT', '256M'));
</ code>
Fügen Sie es kurz vor:
[php]
/ That's all, stop editing! Happy blogging. /
</ code>

Diese Einstellungen können direkt von Ihrem Hosting-Provider eingeschränkt werden. Daher empfehle ich Ihnen, sich mit ihnen in Verbindung zu setzen und sie zu bitten, sie direkt zu ändern.

Ich würde Ihnen auch empfehlen den Wert für maxINputVars in der php.ini Datei der verwendeten PHP Version 7.0.33 zu erhöhen.

Sie verwenden den Standardwert von maxINputVars = 1000. Bitte ändern Sie den Wert auf mindestens 3000 oder höher.

Sollten Sie bei den Anpassungen Probleme haben konsultieren Sie bitte Ihren Host-Anbieter.
Es kann sein, dass es hier Einschränkungen gibt, die in Verbindung mit Ihrem aktuellen Hosting-Paket stehen.

https://wpml.org/de/startseite/mindestanforderungen/
Hinweis: WPML erfordert ein Minimum an WP Memory-Limit von 128 MB, um nur in einer minimalen Umgebung zu funktionieren, was sich auf ein Standarddesign ohne zusätzliche Plugins bezieht.

In der Zwischenzeit werden ich das OnePress Theme auf einer neuen WordPress Installation testen. Geben Sie mit bitte Bescheid, ob die Änderungen das Problem beseitigen konnten.

Mit freundlichen Grüßen
Andreas

Juli 10, 2019 um 3:11 pm #4182009

mell

Hallo, vielen Dank für die Antwort.
Ich habe mehrfach schon den Support angerufen und der mir immer bestätigte, dass WP Memory Limit auf 500MB erhöht wurde.
Auch einen größeren Vertrag habe ich dafür schon abgeschlossen.

Wenn ich das script hinzufüge über FTP, und die Datei entsprechend verändere, erscheint ein Fehler und die Seite lädt nicht mehr.
Daher dann Hilfesuche beim Support...

Da wurde mir gesagt, dass MaxInput auf 5000 erhöht wurde und MB auf 256. Sieht man auch in der Info.php? (screenshot)
Nach Abschluss eines neuen Vertrages.

Das habe ich alles schon versucht letzte Woche mehrfach...
Bislang ohne Erfolg alles.
Liebe Grüße

Juli 10, 2019 um 3:41 pm #4182249

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für Ihre Nachricht.

Laut WordPress sind diese Änderungen nicht durchgeführt worden. Sie können dies unter WPML -> Support sehen.

Bitte installieren Sie das Plugin OnePress Plus auf der folgenden Test-Website, um zu prüfen, ob die PRO Version des Themes mit WPML kompatible ist:

Ein-Klick-Anmeldung: hidden link

Hinterlassen Sie mir bitte eine kurze Nachricht, sobald das Plugin installiert wurde.

Mit freundlichen Grüßen
Andreas

Juli 10, 2019 um 5:27 pm #4183295

mell

Hallo Andreas,

leider sagt der Host immer noch, dass es ausgeführt wurde und verweisst auf das php indem man das sehen kann...
Nur bei WPML sieht man keine Veränderung.
Warum ist mir unklar. Bin langsam hilflos.

Das Plugin habe ich auf der Testseite soeben installiert.

Beste Grüße
ml

Juli 10, 2019 um 9:09 pm #4184533

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für Ihre Geduld.

Sie hatten unter WPML -> Theme und Plugin Lokalisierung die Option aktiviert, dass davon ausgegangen werden soll, dass alle String original auf Englisch sind, wobei Ihre WPML Standardsprache Deutsch ist. Außerdem habe ich folgende Option aktiviert:
"Theme- oder Plugin-Text-Domains benutzen, wenn gettext-Befehle keinen Stringliteral verwenden"

Die URL Struktur der Website habe ich außerdem auf "Sprache in Verzeichnissen anzeigen" geändert.

Die Seite erscheint nun folgendermaßen:

hidden link -> Deutsch
hidden link -> Englisch

Die Übersetzungen funktionieren jetzt wie geplant.

Mit freundlichen Grüßen
Andreas

Mit freundlichen Grüßen
Andreas

September 4, 2019 um 12:37 am #4507559

martinR-64

Hallo Andreas,

ich habe mit dem OnePress ein ähnliches Problem. Ich sehe in der String-Übersetzung nicht die einzelnen Strings des Themes. Ich habe sie beim Link "Text auf Admin-Bildschirmen übersetzen »" gefunden und sie haben auch einen Haken, aber in der String Suche sind sie einfach nicht da. Was kann ich tun? Danke.

Liebe Grüße, Martin