Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 8 Antworten, has 2 Teilnehmer.

Last updated by Andreas W. Vor 2 Monate.

Assigned support staff: Andreas W..

Author Artikel
Juni 4, 2022 um 7:27 pm #11388567

hannesP-4

Hallo,

ich habe gerade alles übersetzt und bin danach auf die seitenvorschau, um zu sehen ob alles funktioniert, jetzt ist irgendwie die shop Seite nicht mehr sichtbar bzw geht es nicht wenn ich auf Deutsch bzw englisch gehe. Ich habe jetzt sehr lange den Fehler gesucht aber leider nicht gefunden, daher bitte ich um schnelle Hilfe.

Bei der Übersetzung der Produkte habe ich auch ein Problem, da kommt immer - Warten auf Übersetzer - wie kann ich das Einstellen? Der Button Annehmen und übersetzen funktioniert leider nicht?

Übersetzungen-‹-danler-sleds-com-—-WordPress.png
Juni 5, 2022 um 3:04 am #11389477

Andreas W.
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ist es möglich andere Inhalte zu übersetzen, oder funktioniert der Überseztungseditor generell nicht?

Ich frage deshalb, weil seit unserem letzen Update ein Problem aufgetreten ist, durch welches der Advanced Translation Editor nicht mehr funktioniert.

https://wpml.org/de/faq/translation-status-stuck-or-displaying-the-error-wpml-didnt-manage-to-translate-this-page/

Siehst Du unter WPML > Übersetzungsmanagement oder WPML > Übersetzungen eventuell einen Dialog, der anzeigt, das WPML migriert wurde?
Der WPML Übersetzungseditor kann nicht funktionieren, bis dieser Dialog abgeschlossen wurde.

Prüfe bitte auch, ob alle Benutzer, die den Übersetzungseditor verwenden dürfen, einen gültigen Vor- und Nachnamen im WordPress-Profil haben.

Wenn auch danach das Problem nicht gelöst erscheint, solltest Du versuchen WPML erneut auf der Website zu registrieren.

Du musst dazu die Site URL aus deinem WPML-Konto entfernen und dann erneut eintragen, um eine neuen Site Key abrufen zu können, mit welchem Du dann WPML erneut in WordPress registrierst.

Mehr Information dazu hier:
https://wpml.org/de/faq/so-installieren-sie-wpml/

Du kannst nun ebenso versuchen Du Produkte unter WooCommerce > WooCommerce Multilingual > Produkte übersetzen, solltes es weiterhin Probleme unter WPML > Translations geben.

Zudem, deaktiviere bitte LocoTranslate, das es zu unerwarteten Problemen führen kann, wenn mehr als ein Übersetzungsplugin zur gleichen Zeit verwendet wird.

Solltest Du sonstige Plugin aktiv haben, die momentan nicht auf der Website genutzt werden, so deaktiviere diese bitte auch und teste erneut.

Sollten sich die Probleme nach alle dem trotzdem nicht lösen, gib mir bitte Bescheid.

Mit freundlichen Grüßen
Andreas

Juni 6, 2022 um 7:10 pm #11398663

hannesP-4

Hallo Andreas,

ich habe jetzt alles versucht, aber erfolglos. Irgendwas habe ich wohl noch vergessen.

Es ist möglich sämtliche Inhalte zu übersetzen, aber es lässt mich nicht die Produkte selbst übersetzen und wenn ich auf die Livevorschau gehe, dann kommt immer wieder eine 404 seite wenn ich auf die englische seite gehe. Irgendwie kommt da keine verbindung.

Die Produkte habe ich auch auf WooCommerce selbst probiert zu übersetzen, geht leider auch nicht.

Bitte um weitere Info, Danke!

Juni 8, 2022 um 4:07 am #11409483

Andreas W.
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich kann gerne anbieten mir das einmal genauer anzusehen.

Ich möchte einen temporären Zugriff (wp-admin und FTP) auf die Website anfordern, um das Problem genauer zu untersuchen.

Die dafür erforderlichen Felder findst Du unterhalb des Kommentarbereichs, wenn Du dich anmelden, um die nächste Antwort zu hinterlassen. Die Informationen, die Du angibst sind privat, was bedeutet, dass nur Du und ich sie sehen und darauf zugreifen können.

WICHTIG
Lege bitte unbedingt eine Sicherungskopie der Website und der Datenbank an, bevor Du uns den Zugriff gewährst.
Wenn Du die Felder "wp-admin / FTP" nicht sehen kannst, werden Ihre Anmeldedaten für Post und Website als "PUBLIC" (Öffentlich) festgelegt. Veröffentliche die Daten NICHT, es sei denn, Du siehst die erforderlichen wp-admin / FTP-Felder.

Das private Antwortformular sieht so aus:
hidden link

Klicke beim nächsten Antworten auf "I still need assistance".

Video:
hidden link

Mit freundlichen Grüßen
Andreas

Juni 10, 2022 um 6:33 pm #11436635

hannesP-4

Hallo,

haben Sie es sich schon angesehen?

Grüße

Juni 11, 2022 um 8:50 am #11439417

Andreas W.
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ja, ich hatte mir das Problem bereits angeschaut, aber mich noch nicht gemeldet, weil ich keine Lösung finden konnte.

Momentan lege ich eine Kopie der Website an, um diese auf einem lokalen. virtuellen Server zu testen.

Ich werde mich dazu in kurzer Zeit zurückmelden.

Mit freundlichen Grüßen
Andreas

Juni 11, 2022 um 11:46 am #11439959

Andreas W.
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Auf der lokalen Kopie der Website sehe ich ohne weitere Änderungen vorzunehmen den Sprachwechlser auf der Shopseite in beiden Sprachen.

Bitte leere den Cache der Website und speichere die Permalinks in den WordPress Einstellungen erneut ab.

Frage hier ggfls. bitte beim Hosting Support an, ob hier ein Server-Cache verwendet wird, der nur von deren Seite aus geleert werden kann.

Das Problem sollte sich danach lösen.

Mit freundlichen Grüßen
Andreas

Juni 11, 2022 um 9:31 pm #11440787

hannesP-4

Hallo,

ich habe es alles probiert, aber irgendwie bekomme ich es nicht zum Funktionieren.

Die englischen seiten werden leider nicht gefunden und ich habe keine Ahnung mehr warum es nicht funktioniert.
Vielleicht können Sie mir noch einmal drüber schauen ob ich einen Fehler mit den Links mache etc..
Vielen Dank!

Juni 14, 2022 um 10:29 am #11456937

Andreas W.
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich sehe momentan beide Sprachwechsler auf hidden link

Allerdings versucht die englische Flagge auf hidden link zu verlinken.

Der Link sollte aber auf hidden link führen.

Das Problem scheint zu sein, dass das englische Sprachverzeichnis hier nicht angewendet werden kann.

hidden link

Wenn ich allerdings in WPML das Sprach-URL-Format "Sprachname als Parameter hinzufügen" verwende, so funktioniert es.

Der Grund für das Problem muss an der Server DNS-Einstellung liegen, dann ich sehe das gleiche Problem auch dann, wenn ich alleine mit WPML und dem Twenty Twenty One Theme versuche die englische Homepage aufzurufen.

Lese dazu bitte folgendes und konsultiere im Zweifel bitte den Hosting Support, da wir keine von unserer Seite her keinen Einfluss auf die Servereinstellungen haben.

https://wpml.org/documentation/getting-started-guide/language-setup/language-url-options/cannot-activate-language-directories/

Mit freundlichen Grüßen
Andreas