Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Schlagwörter: 

This topic contains 25 Antworten, has 2 Teilnehmer.

Last updated by Engelhardt Vor 1 Monat, 1 Woche.

Assigned support staff: Andreas W..

Author Artikel
November 23, 2021 um 3:29 pm #10053659

Engelhardt

Hi,

ich habe ein Übersetzungsproblem. Auf der obigen Seite hat der Kunde teilweise mit String Translations gearbeitet, was er eigtl. nicht sollte (wobie die Translations korrekt sind!). Nun hab ich auf einer speziellen Seite das Problem, dass im erweiterten Editor die Übersetzungen korrekt sind, aber auf der Live Site nicht angezeigt werden?

Hier die deutsche Seite: hidden link

Hier die englische Seite (Problem sind die ersten Akkordions mit "Interpretation von Ruhe-EKGs mit HES", was hier fehlerhafterweise Deutsch angezeigt wird): hidden link

Sowohl String Translation als auch die Übersetzungen mittels "WPMLs Übersetzungs-Editor verwenden" sind richtig...

Danke + Grüße,
Martin

P.S.: Wahrscheinlich wird Zugang benötigt, hab hier aber kein Feld, wo ich das eintragen kann, und würde es ungern im Forum machen...

November 24, 2021 um 3:51 am #10056797

Andreas W.
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich würde versuchen die Strings auf String Translation zu löschen, die Originalseite neu zu speichern und die Übersetzungen nochmals zu übernehmen. Sollte die Seite den ATe verwenden, so sind diese Text im Übersetzungsspeicher des ATE gespeichert und die Seite muss nicht erneut übersetzt werden.

Zudem sollten die Plugins aktuialisert werden.

Ich möchte einen temporären Zugriff (wp-admin und FTP) auf Ihre Site anfordern, um das Problem genauer zu untersuchen. Besser wäre eine Testseite, an der das Problem repliziert werden kann.

Die dafür erforderlichen Felder finden Sie unterhalb des Kommentarbereichs, wenn Sie sich anmelden, um Ihre nächste Antwort zu hinterlassen. Die Informationen, die Sie eingeben werden, sind privat, was bedeutet, dass nur Sie und ich sie sehen und darauf zugreifen können.

Vielleicht muss ich Ihre Site lokal replizieren. Dazu muss ich vorübergehend ein Plugin namens „Duplicator“ auf Ihrer Site installieren. Dadurch kann ich eine Kopie Ihrer Website und Ihrer Inhalte erstellen. Sobald das Problem behoben ist, lösche ich die lokale Site. Lassen Sie mich wissen, ob dies bei Ihnen in Ordnung ist.

WICHTIG

Machen Sie eine Sicherungskopie der Site-Dateien und der Datenbank, bevor Sie uns den Zugriff gewähren.
Wenn Sie die Felder "wp-admin / FTP" nicht sehen, werden Ihre Anmeldedaten für Post und Website als "PUBLIC" (Öffentlich) festgelegt. Veröffentlichen Sie NICHT die Details Ihrer Website, es sei denn, Sie sehen die erforderlichen wp-admin / FTP-Felder. Wenn Sie dies nicht tun, bitten Sie mich, die private Box zu aktivieren. Die private Box sieht so aus:
hidden link

Video:
hidden link

Mit freundlichen Grüßen
Andreas

November 24, 2021 um 3:53 pm #10061915

Engelhardt

Die Probleme scheinen sich zu häufen:

Hier: hidden link

sind "Funktionen" und "Vorteile" Orange und Großschrift, aber in der englischen Übersetzung wird das nicht mitgenommen...

hidden link

Betrifft auch einige andere Produktseiten.

November 25, 2021 um 3:12 am #10064777

Andreas W.
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Martin,

Ich kann mich hier leider nicht anmelden und erhalte:

Error: The username **** is not registered on this site. If you are unsure of your username, try your email address instead.

Kannst Du die Angaben bitte nochmal kontrollieren, falls nötig nachträglich editieren und mir dann auf dem Ticket hier Bescheid geben?

Mit freundlichen Grüßen
Andreas

November 25, 2021 um 7:22 am #10065365

Engelhardt

Sorry, sind angepasst, speichern muss man den neuen User natürlich auch :/

November 25, 2021 um 11:39 pm #10071013

Andreas W.
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich sehe das Problem momentan nicht. Siehe Screenshot.

Hat sich das Problem mittlerweile gelöst?

Mit freundlichen Grüßen
Andreas

EN.jpg
DE.jpg
November 25, 2021 um 11:44 pm #10071061

Engelhardt

Hallo Andreas,

steht im grauen Balken: die Headline dort ist beide Male Deutsch! > "Interpretion VON..." müsste eigentlich übersetzt sein.

November 26, 2021 um 2:12 am #10071655

Andreas W.
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Tut mir leid, da war mir igendwie nicht aufgefallen, da ich auf den Dropdown geachtet hatte.

Es ist jedoch sehr ungewöhnlich, dass der Titel auf einem Dropdown funktioniert und auf einem anderen nicht, es scheint sich jedoch um ein Problem mit den Publishpress Gutenberg Blöcken zu handeln.

Moment konnte ich das Problem durch das manuelle Editieren der Übersetzung lösen, wenn wir die Seite aber erneut mit dem WPML-Übersetzungseditor übersetzen, werden die Titel mit dem Originalinhalt überschrieben.

Ich habe daraufhin die Gutenberg String Pakete aus WPML -> Packages geslöscht und die Übersetzung der Seite komplett neu angelegt. Das Problem bleibt aber weiterhin bestehen.

Dann habe ich die original Seite mit "Duplicate Page" dupliziert und erneut übersetzt und auch hier erscheitn das gleiche Problem.

Ich kann anbieten eine Test-Site bereitzustellen, auf der Sie PublishPress Blocks installieren können, damit wir versuchen können das Problem zu replizieren.

Wa smich allerding wundert, ist die Fehlermeldung "invalid content", die im Originalinhalt erscheint und ich vermute, dass diese nicht im Zusammenhang mit WPML steht. Siehe Screenshot.

Ich sende gerne einen Link zu einer Tes-Site mir WPML vorinstalliert.

Mit freundlichen Grüßen
Andreas

invalid content.jpg
November 26, 2021 um 9:39 am #10073435

Engelhardt

Hi Andreas,

lass uns das gerne auf einer Testseite checken. Das Problem muss ich irgendwie in den Griff bekommen. Komisch ist, das es eigentlich bis letzte Woche einwandfrei lief mit allen Übersetzungen. Siehe z.B. auch diese Seite: hidden link

Dort werden die Accordions problemlos übersetzt.

Montag soll die Seite vorraussichtlich live gehen :/

Danke + Grüße,

November 27, 2021 um 3:45 am #10078309

Andreas W.
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Das Problem tritt also auf anderen Seiten nicht auf. Ist das auch noch der Fall, sobald auf der Originalseite das Element erneut editiert wurde?

Ich wäre Dir dankbar, wenn Du versuchen könntest das Problem in einfacher Weise auf folgender Test-Site nachzustellen. WPML ist in aktueller Version vorinstalliert.

Ein-Klick-Anmeldung:
hidden link

Mit freundlichen Grüßen
Andreas

November 28, 2021 um 3:36 pm #10082703

Engelhardt

Hi Andreas,

das Problem tritt auf der Seite nicht auf, wenn ich das Original auf Deutsch bearbeite. Ich habe versucht, das Problem nachzustellen, es klappt aber interessanterweise einwandfrei in der Sandbox... Der Kunde kann mir leider auch nicht genau sagen, was er gemacht hat... :/

Was ich auf der Baustellenseite festgestellt habe, wenn ich die Accordions neu erstelle und neu befülle und anschließend übersetze, dann ist das Problem weg. Der Kunde muss das Element irgendwie durch copy&paste "zerschossen" haben, bzw. einige Elemente... mir bleibt wohl nichts, ausser dieser Workaround, das ich alle Elemente, die betroffen sind neu erstelle und anschließend übersetze.

Viele Grüße,
Martin

November 30, 2021 um 11:26 am #10094879

Engelhardt

Hi Andreas,
also das Problem mit den Accordions habe ich nun eingrenzen können! Es war das Registered Symbol... wenn das hochgestellt einkopiert wird in die deutsche Headline, dann spinnt der Übersetzer. Wenn man es aber normal reinkopiert, dann klappt es:

hidden link

Das Problem mit der farbigen und hochgestellten Headline in Deutsch (FUNKTIONEN -> FUNCTIONS) habe ich umgangen, indem ich das hochgestellt einfach so geschrieben habe und die Farbe über den Gutenberg Block rechts in der Leiste, statt in dem Menü über dem Element vergeben habe:

hidden link

Viele Grüße,

November 30, 2021 um 8:20 pm #10099855

Andreas W.
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für Deine Nachricht.

Kannst Du bitte bestätigen, ob sich das das zuletzt beschrieben Problem auf unserer Sandbox replizieren lässt?

Mit freundlichen Grüßen
Andreas

Dezember 1, 2021 um 9:53 am #10103113

Engelhardt

Hallo Andreas,

Ich habe den Text mit dem "Registered" kopiert und eine Testseite erstellt. Das letzte Akkordion hat diesen Fehler. Es liegt vermutlich am Kopieren des Textes und einfügen, ohne vorher Formatierungen wie das hochgestellte "R" zu entfernen. Wird die Formatierung vorher entfernt (durch einkopieren in ein leeres Textdokument z.B.), dann übersetzt er richtig. Wird sie mitgenommen, bleibt der Text in der Originalsprache.

Das Problem mit der Farbe, die vom Plugin EditorsKit kommt, konnte ich nicht replizieren...

Viele Grüße,
Martin

Dezember 1, 2021 um 10:09 am #10103261

Engelhardt

Jetzt hab ich nur ein anderes Problem... die Seite ist eben live gegangen, Key habe ich neu registriert. Aber ich erhalte im Dashboard folgende Meldung:

WPML Media is enabled but not effective. It requires WPML in order to work. ??

Alle Plugins sind aktiv und auch bei WPML sichtbar...

ENTWARNUNG: Das scheint sich selbstständig gelöst zu haben, vermutlich hat der ServerCache ne Weile gebraucht. Die Meldung ist nun weg!