Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 6 Antworten, has 2 Teilnehmer.

Last updated by Marcel vor 2 Monate, 1 Woche.

Assigned support staff: Marcel.

Autor Beiträge
September 7, 2019 um 1:36 pm #4529349

markusS-65

Hallo, wir die Moos Moos Manufaktur besitzen eine deutsche und ein französische Internetseite. Wir wünschen auf beiden Seiten unterschiedliche Emailadressen bzw. Telefonnummern. Ändert man nun im Advanced Translation Editor die Email bzw. Nummer ändert es leider nicht die im Hintergrund stehende Verlinkung, sondern nur den "Fronttext". bspw. wird auf der französischen Seite moos@moosmoos.fr angezeigt - beim anklicken aber an moos@moosmoos.de versandt. Dies soll natürlich nicht sein. Selbes Problem bei der Telefonnummer. Ändere ich die Telefonnummer / Email im Backend - .FR ist bei der nächsten Aktualisierung alles wieder auf .de >Niveau.

moosmoos.de - moosmoos.fr ( Nummern im unteren Bereich )

Bitte um schnelle Hilfe!
Vielen Dank !

September 9, 2019 um 8:53 am #4534849

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Markus,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Ich würde mir das gerne direkt auf Ihrer Seite ansehen. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

September 10, 2019 um 10:43 am #4544301

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Markus,

vielen Dank. Ich habe versucht dem Shortcode ein Link Element zu übergeben, welches nicht angenommen wird. Können Sie bitte das Problem auf folgender isolierten Sandbox Umgebung hochladen und versuchen das Problem mit einer Telefonnummer und der E-Mail nachzustellen?

hidden link

GGf. kann ich daraus eine andere XML-Konfiguration generieren.

Vielen Dank
Freundliche Grüße
Marcel

September 10, 2019 um 11:45 am #4544957

markusS-65

Hallo Marcel,

leider hab ich keine Möglichkeit das Problem so dazustellen dass es meinem Problem zu ähnelt.
Gibt es keine Möglichkeit bestimmte Bereiche von der Übersetzung auszuschließen bzw. manuell zu übersetzen ?

Muss doch möglich sein auf Sprache A und Sprach B zwei unterschiedliche Telefonnummer (mit Link) zu hinterlegen.

Mfg Markus

September 10, 2019 um 1:09 pm #4545601

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Markus,

ich habe das Problem für Sie auf der Sandbox nachgestellt, meine Änderung wurde korrekt übernommen: hidden link

Es war somit kein genereller Fehler in der Implementierung. Ich habe nun alle Schritte nochmals auch auf Ihrer Seite durchgeführt und nun wird es übernommen: Siehe hidden link

Folgende XML-Konfig löste das Problem:

https://wpml.org/documentation/support/maintaining-the-fusion-builder-avada-compatibility-with-wpml/#testing-the-language-configuration-file:

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>fusion_title</tag>
            <attributes>
                <attribute type="link">url</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

Freundliche Grüße
Marcel

September 11, 2019 um 10:15 am #4552429

markusS-65

Hallo,

vielen Dank für die Info bzw. Problemlösung. Leider kann ich nicht ganz nachvollziehen wie das Problem gelöst wurde. Unter den verschiedenen Portfolioeinträgen besteht das selbe "Telefonnnummern" Problem und ich würde dies gern, auch in Zukunft, selbst verändern wollen.

Mir zudem aufgefallen das einige Seiten ( Home , Moosarten .. ) nu nicht mehr im Advanced Translation Editor geöffnet werden, sondern wie in Grafik 1.jpeg angezeigt wird. Wie kann ich in diesen Modus umschalten bzw. dies bei den Portfolioeinträgen nutzen ?

September 11, 2019 um 10:55 am #4552775

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo,

ich habe dem Shortcode fusion_title ein Link Attribut über eine WPML XML Konfiguration übergeben. Also in Ihrem Fall war [fusion_title ....] der betroffene Shortcode und benötigte ein URL Attribut per

<attribute type="link">url</attribute>

, welches im Standard bei Avada nicht übergeben wird.
Mehr Infos hier: https://wpml.org/documentation/support/maintaining-the-fusion-builder-avada-compatibility-with-wpml/#testing-the-language-configuration-file . Die generelle Doku zu XML Konfigurationen finden Sie hier: https://wpml.org/documentation/support/language-configuration-files/

Zum Editor:
Sie können dies wie hier dargestellt steuern:
https://wpml.org/wp-content/uploads/2019/01/wpml-ate-activation-settings-1.png

- "New content" mit dem Advanced Translation Editor
- darunter "Content that was created with" müssen sie auch auf Advanced Translation Editor umstellen.

Freundliche Grüße
Marcel