Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 4 Antworten, has 2 Teilnehmer.

Last updated by Andreas W. vor 3 Monate.

Assigned support staff: Andreas W..

Autor Beiträge
Juli 15, 2019 um 7:45 pm

jonasT-9

Ich versuche:
Die Seite auch auf Deutsch auf Google zu sehen

URL der/meiner Website, auf der das Problem auftritt:
hidden link

Erwartet hatte ich zu sehen:
Alles auf Deutsch, wenn nach deutschen Begriffen der Webseite gesucht wird

Stattdessen bekam ich:
Alles auf Englisch - bswp. "Tandem Gleitschirmfliegen Berner Oberland"

Juli 15, 2019 um 10:04 pm #4214737

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Darf ich fragen, wann Sie die Übersetzungen mit Yoast SEO angefertigt haben? Nehmen Sie bitte davon Kenntnis, dass Google oft bis zu eine Woche Zeit benötigt, um die Änderungen zu übernehmen.

Ich sehe außerdem, dass WPML und weitere Plugins nicht auf neuestem Stand sind. Bitte aktualisieren Sie alle Plugins und übersetzen Sie die Homepage erneut. Sollte die Website innerhalb von 2-7 Tagen nicht auf Google angezeigt werden, sollten weitere Untersuchungen durchgeführt werden.

Mit freundlichen Grüßen
Andreas

Juli 16, 2019 um 6:50 pm #4223379

jonasT-9

Yoast habe ich seit langem im Einsatz. Ich habe jedoch zusammen mit dem Kauf von WPML vor ca. drei Monaten die Premium-Lizenz erworben und auch die Übersetzungen etwa zu diesem Zeitpunkt erfasst.
Ich werde die Plugins aktualisieren, glaube jedoch nicht, dass dies etwas verbessern wird.
Ich warte seit Wochen auf ein Update vom Google-Crawling...
Vor etwa einem Monat habe ich gelesen auf WPML, dass es auch wegen der Weiterleitung nach Browsersprache sein könnte. Deshalb habe ich dann die Weiterleitung nach Browsersprache deaktiviert - jedoch wie erwähnt ohne Erfolg.
Freundliche Grüsse
JonasThommen

Juli 16, 2019 um 7:56 pm #4223645

jonasT-9

Anbei ein Screenshot - es wird immer Englisch angezeigt. Bin am verzweifeln!

Juli 16, 2019 um 11:11 pm #4224385

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Haben Sie eventuell im Laufe der Zeit die Standardsprache der Website geändert?

Bitte gehen Sie sicher, dass Sie alle Anweisungen aus unserer Dokumentation befolgt haben:
https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/

In der Tat gibt es Probleme mit dem Google Index, wenn in WPML die Option zur Weiterleitung nach Browsersprache aktiviert ist. Wir raten deshalb dazu, dieses Features bitte nicht zu aktivieren.

https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/how-browser-language-redirect-affects-google-indexing/

Ich habe ein Ticket in unserem Forum gefunden, in welchem das Problem anscheinend, durch die Änderung des hreflang attributes unter WPML -> Sprachen -> Sprachen editieren erzielt wurde.

https://wpml.org/forums/topic/translated-pages-are-not-indexed-by-google/

hidden link

Ich sehe allerdings, dass Sie diese Änderungen bereits in Betracht genommen haben. Besteht diese Konfiguration erst seit einigen Tagen oder schon länger?

Sollten Sie die Änderungen erst in den letzten 24 Stunden vorgenommen haben, so geben Sie Google noch etwas Zeit. Ihre Website wurde von Google zuletzt am 15.07. erfasst.

Nehmen Sie bitte auch davon Kenntnis, dass Kunden uns bereits mitteilten, dass Google Monate brauchte, um Änderungen auf der Website auf den Google Index zu übernehmen.
https://wpml.org/forums/topic/language-pages-not-indexed-by-google/

Aktivieren Sie bitte wp-debug, um festzustellen, ob aktuelle PHP-Fehler vorliegen. Geben Sie dazu folgendes in Ihrer wp-config Datei ein:

define( 'WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true);
define( 'WP_DEBUG_DISPLAY', false);

Geben Sie die Codes bitte kurz vor dieser Linie ein:

/* That's all, stop editing! Happy blogging. */

Besuchen Sie nun das Frontend und Backend Ihrer Website. Sollten Fehler vorhanden sein, werden diese erfasst und in der debug.log Datei im Ordner wp-content Ihres Servers gespeichert.

Weitere Informationen zum Aktivieren dieser Funktion finden Sie hier:
https://wpml.org/documentation/support/debugging-wpml/

Lassen Sie mich bitte wissen, ob Sie weitere Hilfe benötigen.

Mit freundlichen Grüßen
Andreas

Das Thema „[Geschlossen] Übersetzung wird auf Google nicht angezeigt“ ist für neue Antworten geschlossen.