Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Schlagwörter: 

This topic contains 13 Antworten, has 3 Teilnehmer.

Last updated by Andreas W. vor 1 Monat, 2 Wochen.

Assigned support staff: Andreas W..

Autor Beiträge
August 1, 2019 um 6:31 pm #4324695

catharinaE

Ich versuche WP von "deutsch (Du)" auf "formales deutsch (Sie)" umzustellen. Dabei bin ich die Schritte aus den Forenbeiträgen:

https://wpml.org/de/forums/topic/kann-nicht-auf-deutsch-sie-de_de_formal-umstellen/
https://wpml.org/de/forums/topic/german-formal-not-working/

durchgegangen.
In den Einstellungen wird alles richtig angezeigt, die Seite ist trotzdem immer noch auf deutsch (Du). Kann man einfach bei der Suche testen. (hidden link)

Schalte ich WPML aus, funktioniert alles.
Screenshots aller Einstellungen anbei.

August 2, 2019 um 9:14 am #4328397

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Catharina,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Dies sieht soweit alles korrekt aus. Ich würde mir das gerne direkt auf Ihrer Seite ansehen. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

August 12, 2019 um 4:32 pm #4382369

catharinaE

Any updates?

August 13, 2019 um 2:12 pm #4388767

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Catharina,

die Einstellungen sehen korrekt aus. Ich konnte es ebenso nachstellen dass die Suche auf formal wechselt, wenn WPML deaktiviert ist. Ich habe nun unseren 2nd Tier Support mit Ihrem Fall kontaktiert und gebe Ihnen umgehend Bescheid, sobald ich eine Rückmeldung erhalte.

Freundliche Grüße
Marcel

August 14, 2019 um 2:44 pm #4396185

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Catharina,

Sie müssen die bereits registrierten, informalen Strings aus Ihrem Enfold Theme entfernen und diese neu einlesen. Auf der Staging Seite ist es bereits korrigiert. WordPress ist somit bereits korrekt, nur das Endfold Theme nutzt noch die informale Anrede.

#1 Bitte öffnen Sie WPML -> String Translation
#2 Wählen Sie die textdomain "avia_framework" aus und klicken Sie die oberste Checkbox an (Damit die gesamte textdomain markiert ist)
#3 Klicken Sie unten auf ausgewählte Strings löschen

Gehen Sie dann zu WPML -> Theme and plugins localization und lesen Sie die textdomain "avia_framework" erneut ein. Nun ist die formale Anrede aktiv, wenn Sie eine neue Suche durchführen.

Doku zum Löschen: https://wpml.org/de/documentation-3/ratgeber-zum-loslegen/string-ubersetzung/#auto-register-fe

Freundliche Grüße
Marcel

August 19, 2019 um 8:35 am #4414655

catharinaE

Hallo Marcel,
erstmal Danke!
Also das hat für einen ersten Schritt geholfen. Löst aber noch immer nicht die Anzeige in der Navigationssuche und führt zu einem neuen Problem.
Siehe Screenshot.
Dort erscheint erscheint noch immer die Anrede [...] aber kein Eintrag erfüllt Deine Suchkriterien. [...]
Und das neue Problem: Der eigentlich deutsche Text: Bitte verwende einen anderen Suchbegriff erscheint jetzt auch englisch: Please try another search term
Kann man sich auch im Produktivsystem anschauen: hidden link

Viele Grüße!

August 19, 2019 um 6:34 pm #4418301

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Mein Kollege Marcel ist leider momentan nicht verfügbar.

Ich habe den genannten String auf der String-Übersetzung gefunden und übersetzt.

Kann ich sonst noch etwas für Sie tun?

Mit freundlichen Grüßen
Andreas

August 19, 2019 um 8:48 pm #4419173

catharinaE

Aber die Anrede ist immer noch ein informelles Du statt das formale Sie.
Das ist das eigentliche Problem.

Ausserdem habe ich Marcels Anleitung vom AUGUST 14, 2019 UM 2:44 PM auf dem Produktivsystem ausgeführt.
Das hat keine Veränderung gebracht und das Problem auch nicht gelöst.
Siehe Screencast: hidden link

mfg.

August 20, 2019 um 1:25 am #4419677

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Wie ich sehe, habe Sie alle Avia Framework String manuell gelöscht. Ich würde Ihnen nicht dazu raten dies zu tun. In der Tat ist die von mir angelegte Übersetzung nun nicht mehr auf der Website sichtbar, obwohl der String übersetzt wurden. Haben Sie irgendwelche weiteren Änderungen vorgenommen?

Nehmen Sie hier bitte Kenntnis davon, dass unsere String Translation für fast alle Themes und Plugins die Standard-Strings auf Englisch erfasst. Sie müssen somit, nach den englischen Strings suchen. Allerdings können Sie auch deutsche Strings lokalisieren, indem Sie die Checkbox "Übersetzungen einbeziehen" markieren und dann mit der Textsuche beginnen.

Auf der Website erscheint nun auf DE meine Übersetzung und auf EN der Avia Standard-Text, wobei ich mir im Moment nicht erklären kann, warum der englische Text nicht mehr erscheint.

Werfen Sie nun bitte mal eben einen Blick auf den Screenshot. Der informale "Du" Text kommt aus der Enfold .mo-Datei und ist dort wohl so hinterlegt. Die Strings, welche sich auf Übersetzungen beziehen, sollten sich mit unserer String Translation ändern lassen, allerdings haben wir keinen Einfluss auf die Avia Sprachdatei.

Melden Sie sich bitte einmal hier an:

hidden link

User: wpml
Password: support

WPML und seine add-ons sind hier deaktiviert. Die Sprache ist Deutsch (de_DE). Die Strings werden auch hier informal mit "Du" angezeigt, da dieser Text von Avia stammt. Ich würde Ihnen raten diesbezüglich den Kriesi Support zu kontaktieren und nachzufragen, ob eine informale deutsche Sprachdatei überhaupt verfügbar ist.

hidden link

Mit freundlichen Grüßen
Andreas

August 20, 2019 um 7:02 am #4420959

catharinaE

1.
Also jetzt bin ich verwirrt. Der WPML Supporter MARCEL hat mich in einem Beitrag hier am AUGUST 14, 2019 UM 2:44 PM <b>ausdrücklich</b> aufgefordert, alle Strings zu löschen.
Siehe oben. Das war also flasch?

2. Wenn ich WPML ausschalte, dann erscheint überall das formale Sie
Somit kann es nicht an themespezifischen Sprachdateien oder Strings liegen, sonst würde ja auch beim Ausschalten von WPML die informelle
Dun erscheinen. Oder?

mfg.

August 21, 2019 um 1:31 am #4426901

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Tut mir leid für die Verwirrung. In der Tat ist der deutsche Standard-Enfold-.mo-Datei in informaler Sprache, es sei denn Sie stellen WordPress auf Deutsch(Sie). Dann lädt WordPress die im Enfold Theme hinterlegte de_DE_formal.mo Datei.

Im Fall von WPML sollte es funktionieren,wenn Sie auf "de_DE_formal" stellen und die Strings neu einlesen, das ist korrekt. Ob es wirklich nötig ist dazu alle Strings aus Avia manuell zu löschen, werde ich in Erfahrung bringen, allerdings ist dies bei einem Umfang von mehr als 5000 Strings sehr aufwändig.

Auf Ihrer Seite, hatte ich die Strings manuell übersetzt, aber jetzt finde ich auf beiden Sprachen im Suchfeld deutschen Text und ich kann nicht nachvollziehen, wieso dies zustande gekommen ist.

Ich habe dann die Enfold de_DE_formal.po Sprachdatei für Deutsch-Formal über String Translation importiert. Dies löste das Problem für die informale Ansprache, allerdings wird der Text im Such-Widget auf der englischen Seite weiterhin auf Deutsch angezeigt.

Auf dem Screenshot im Anhang sieht man auch das eigentliche Problem.

Der String ist auf Standard in Englisch, die automatische Übersetzung ist Deutsch informal, obwohl formal in den Sprachoptionen eingestellt ist und dann schließlich, sehen Sie die formale Übersetzung, welche ich nun mit der Enfold de_DE_formal po.-Datei importiert habe und welche nun auch dort auf der deutschen Seite angezeigt wird, solange Enfold eine Übersetzung für betroffene Strings angelegt hatte.

Ich würde diesbezüglich gerne morgen mein Kollegen konsultieren, um in Erfahrung zu bringen, warum Enfold hier nicht automatisch die korrekte .mo-Datei lädt, die solche Strings automatisch übersetzen sollte, ohne dass eine .po-Datei manuell importiert wird und wieso der Text im Suchfeld nicht auf Englisch angezeigt wird.

Ich bitte Sie diesbezüglich um etwas Geduld.

Mit freundlichen Grüßen
Andreas

August 21, 2019 um 9:14 pm #4435131

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich möchte hinzufügen, dass der Vorschlag von Marcel funktionieren sollte, aber es nicht die ideale Lösung ist, da die .mo-Datei automatisch geladen werden sollte. Dies ist auch auf einer neuen Installation von WP mit Enfold und WPML der Fall.

Im Grunde wird nun alles korrekt angezeigt, nur die .mo-Daten laden nicht korrekt. Dies sollte aber keinen Einfluss auf die Übersetzungen haben, da diese bereits manuell mit der formalen deutschen Sprache (de_DE_formal.po) überschrieben wurden, als ich die Enfold .po-Datei in String Translation importiert habe.

Sie finden nun auch diese Dateien in Ihrem Child-Theme Verzeichnis im Ordner /lang/. Ich ging davon aus, dass wenn die Sprachdateien im Child-Theme vorhanden sind, diese bevorzugt geladen werden, was aber leider nicht der Fall war.

Das Problem mit dem Suchboxtext, welche im Englischen nicht korrekt angezeigt wurde, war auf den Cache meines Browsers bedingt und sollte nicht weiterhin auftreten. Die Strings sind korrekt übersetzt.

Ich konsultiere nun unseren 2. Level Support in Bezug auf die .mo-Datei und werde mich daraufhin wieder bei Ihnen melden.

Mit freundlichen Grüßen
Andreas

August 27, 2019 um 11:53 pm #4470053

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Das Problem wurde an unsere Entwickler weitergeleitet, welche in den kommenden Tagen Ihre Website genauer untersuchen werden.

Ich konnte ein gleiches Problem leider nicht auf einer neuen WordPress Installation feststellen, da hier die Sprachdateien automatisch korrekt geladen wurden.

Wir bitten Sie deshalb um etwas Geduld. Ich werde mich bei Ihnen melden, sobald ich eine Rückmeldung von unserem Team erhalten habe.

Mit freundlichen Grüßen
Andreas

September 5, 2019 um 4:05 pm #4520679

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Unsere Entwickler haben die Zuordnung der .mo-Datei in der Datenbank geändert und empfehlen die Einstellung auf "Themes und Plugins nur mit WPMLs String Translation übersetzen (Keine .mo-Dateien laden)" zu belassen. In diesem Fall, wird die .mo-Datei nur im Hintergrund geladen, sollte keine Übersetzung vorhanden sein.

Im Grunde sollte Sie, nachdme ich zusätzlich die de_DE-formal.po Daten importiert hatte, keine weiteren unerwünschten String vorfinden.

Lassen Sie mich bitte wissen, ob Sie weitere Hilfe benötigen.

Mit freundlichen Grüßen
Andreas