Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 5 Antworten, has 2 Teilnehmer.

Last updated by Andreas W. vor 8 Monate, 3 Wochen.

Assigned support staff: Andreas W..

Autor Beiträge
Februar 21, 2019 um 5:18 am

stefanieW-2

Nach Installation und Aktivierung von WPML habe ich mich als erstes an die Übersetzung meiner Kategorien und Schlagwörter gemacht. Nachdem ich diese synchronisiert habe, tritt folgendes Problem auf:

Die Unterkategorien meines Blogs werden nicht mehr angezeigt (Hauptkategorien funktionieren), dazu treten verschiedene Fehlerszenarien auf:

Während Hauptkategorien funktionieren, indem alle dieser Kategorie zugeordneten Artikel angezeigt werden, mit Option auf Weiterlesen (Afrika = Hauptkategorie): hidden link
führt z.B. dieser Link zu einer 404-Fehlermeldung: (Tansania = Unterkategorie von Afrika)

Klick auf hidden link
führt wiederum zu einem konkreten Artikel in dieser Kategorie:
hidden link
während die Kategorie "Asien" funktioniert.

Sobald ich "China" nicht mehr als Unterkategorie zu "Asien" anlege, sondern als Hauptkategorie, besteht dieses Problem nicht.
Zudem spielt es keine Rolle, ob ich die Unterkategorien über die Navigation ansteuere, oder über einen anderen Weg, z.B. Klick im Artikel.

Ich habe bereits vor einigen Tagen ein Ticket dazu geöffnet (englisch) und bin bereits mit einem Supporter in Kontakt. Jedoch sind wir bisher noch keinen Schritt weiter gekommen, da der mir seit Tagen Anweisungen schickt, wie ich ein Duplikat meiner Seite erstelle, oder diese migrieren kann, damit er sich überhaupt erst einmal das Problem anschauen kann. Dies leider bisher ohne Erfolg.

Zudem arbeitet der Supporter in der Zeitzone Südamerika, ich bin aktuell in Asien, was zu enormen zeitlichen Verzögerungen in der Beantwortung führt. Die Thematik zieht sich nun schon über eine Woche und wie gesagt bisher noch ohne, dass der Supporter überhaupt einen Blick auf meine Seite werfen konnte.

Ich bitte Sie nun, sich meinem Ticket seitens des deutschsprachigen Supports anzunehmen!

Vielen Dank!
Mit besten Grüßen
Stefanie

Februar 21, 2019 um 8:59 pm #3230033

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Leider funktionieren die von Ihnen übermittelten Zugangsdaten nicht, weshalb ich diese leider erneut anfordern muss. Ihre nächste Antwort ist auf privat gestellt.

Haben Sie bereits versucht unter Einstellungen -> Permalinks diese einfach erneut zu speichern? Auf diese Weise sollte der 404 Error eigentlich nicht mehr erscheinen.

Zum Thema Taxonomien, haben Sie diese unter WPML -> Taxonimie-Übersetzung beabreitet? Bitte überpräfen Sie hier, ob alle Taxonomien korrekt übersetzt wurden und nutzen Sie bitte den Abschnitt Hirarchie-Synchronisierung, falls erforderlich.

Sollte das aklles nichts zum gewünschten Erfolg geführt haben, machen Sie bitte eine Sichrungskopie Ihrer Datenbank und gehen Sie bitte auf WPML -> Support und klicken Sie auf Fehlerbehebung (am Ende des ersten Abschnitts).

Nutzen Sie hier bitte die Option zum synchronisieren von Taxonomien in Beiträgen, Seiten, etc. (Siehe Screenshot).
Wählen Sie dann noch die Option "Sprachinformationen einstellen".

Ich hoffe sehr, dass dies zur Lösung des Problem geführt hat. Teilen Sie mir bitte mit, ob Sie weitere Hilfe benötigen.

Zusätzlich möchte ich empfehlen Ihre Speichergrenze für PHP (MemoryLimit) auf 512M und die WordPress-Speichergrenze (WP Memory Limit) auf mindestens 256 MB erhöhen? Für WPML ist mindestens 128M erforderlich, was allerdings nur für einfache Blogseiten gilt.

Ihre aktuellen Werte sind:

MemoryLimit 256M
WP Memory Limit 40M

Fügen Sie diesen Code Ihrer wp-config.php hinzu, um den Arbeitsspeicher von WP zu erhöhen:
[php]
/ * Speichergrenze /
define ('WP_MEMORY_LIMIT', '256M'));
</ code>
Fügen Sie es kurz vor:
[php]
/ That's all, stop editing! Happy blogging. /
</ code>

Diese Einstellungen können direkt von Ihrem Hosting-Provider eingeschränkt werden. Daher empfehle ich Ihnen, sich mit ihnen in Verbindung zu setzen und sie zu bitten, diese direkt zu ändern.
Wenn Sie noch höhere Werte erhalten können, wäre das großartig. Achten Sie auch bitte darauf, dass die Speichergrenze für PHP immer etwas höher sein sollte, als das WP Memory Limit.
Das MemoryLimit für PHP lässt sich in der php.ini Datie Ihrere aktuellen PHP version 7.2.7 geändert werden, welche sich auf Ihrem Server befindet.

Ich würde Ihnen auch empfehlen hier den Wert für maxINputVars in der gleiche php.ini Datei zu erhöhen.

Sie verwenden den Standardwert von maxINputVars = 1000. Bitte ändern Sie den Wert auf mindestens 3000.

Sollten Sie bei den Anpassungen Probleme haben konsultieren Sie bitte Ihren Host-Anbieter.

https://wpml.org/de/startseite/mindestanforderungen/

Mit freundlichen Grüßen
Andreas

Februar 22, 2019 um 9:58 am #3231691

stefanieW-2

Hallo Andreas,

vielen Dank für die Kontaktaufnahme und die Tipps, die bisher jedoch leider nicht zum gewünschten Erfolg geführt haben.

Die Permalinks hatte ich bereits neu abgespeichert (unter Einstellungen --> Permalinks einfach auf "Änderungen speichern" klicken, oder?

Zur Übersetzung der Taxonomien hatte ich unter WPML -> Taxonomie-Übersetzung gearbeitet, ja und auch hier hatte ich die Hierarchie-Synchronisierung bereits vorgenommen.
Hier erscheint nun für beide Sprachen (deutsch & englisch) "Die Taxonomie-Hierarchie ist bereits synchronisiert".

Nun habe ich mich an die von Dir vorgeschlagenen Steps in der WPML Fehlerbehebung gemacht:
- Für Beiträge, Seiten und Medien: "Beitragstaxonomien synchronisieren" sowie
- "Sprachinformationen einstellen" geklickt.
Einen Screenshot konnte ich in deiner Antwort zwar nicht finden. Ich hoffe aber du meintest genau diese Felder.

Zusätzlich habe ich noch unter:
- "Verlinkung übersetzbarer Taxonomien" für "category" "verlinkt auf Kategorein" angeklickt. (Hier war vorher nichts ausgewählt und
- unter "Aufräumen" "den Cache in WPML leeren" geklickt.

Leider alle Maßnahmen ohne Erfolg. das beschriebene Problem besteht weiterhin wie beschrieben. Ich würde dich also bitten einen Blick auf den Admin-Bereich meiner Seite zu werfen und mir entsprechend nochmal die Felder zur Privat-Vermittlung der Zugangsdaten zur Verfügung stellen. Diese Option habe ich hier in dieser Antwort aktuell nicht.

Zu deinen Tipps den php-Arbeitsspeicher zu erhöhen:
Wo finde ich meine "wp-config.ph"? Innerhalb meines WordPress-Dashboards? Oder muss ich das über den Hoster anfragen?

Vielen Dank für deinen Support!
Stefanie

Februar 22, 2019 um 2:53 pm #3232878

stefanieW-2

Hallo Andreas,
da du laut deinem Profil aktuell wieder online sein solltest, schick mir doch bitte kurz das private Formular zur Übermittlung der WP LogIn-Daten, damit du dir meine Problematik überhaupt genauer anschauen kannst.
Da ich aktuell in Asien bin und es hier schon 23 Uhr ist, bin ich nicht mehr lange online, sodass wir uns zeitlich verpassen...
Dankeschön!
MfG, Stefanie

Februar 22, 2019 um 7:26 pm #3233817

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Stefanie,

Tut mir leid, dass ich es nicht früher geschafft habe mich zu melden.

Sie haben meine Anweisungen bestens befolgt. Anscheinend haben wir es hier mit einem Kompatibilitätsproblem zu tun. Ich werde gerne einen Blick drauf werfen und eine Kopie Ihrer Website anlegen.

Die wp-config.hp befindet sich auf Ihrem Server im Ordner Ihrer WordPress Installation. Hier muss das wp-memory-limit auf mindestens 256M geändert werden. Sie können auch gerne Ihren Host-Anbieter kontaktieren und darum bitten die Änderung vorzunehmen.

Es sind noch weitere Änderungen in der php.ini Datei von PHP 7.2.7 nötig, welche sich ebenfalls auf Ihrem Server gefindet. Bitten Sie darum, dass man das Memory Limit hier auf mindestens 512M erhöht un den Wert von maxInputVars auf 3000 festlegt. Das PHP memory Limit sollte immer etwas höher sein als das WP-Memory Limit.

Ich möchte einen temporären Zugriff (wp-admin und FTP) auf Ihre Site anfordern, um das Problem genauer zu untersuchen. Besser wäre eine Testseite, an der das Problem repliziert werden kann.

Die dafür erforderlichen Felder finden Sie unterhalb des Kommentarbereichs, wenn Sie sich anmelden, um Ihre nächste Antwort zu hinterlassen. Die Informationen, die Sie eingeben werden, sind privat, was bedeutet, dass nur Sie und ich sie sehen und darauf zugreifen können.

Vielleicht muss ich Ihre Site lokal replizieren. Dazu muss ich vorübergehend ein Plugin namens „Duplicator“ auf Ihrer Site installieren. Dadurch kann ich eine Kopie Ihrer Website und Ihrer Inhalte erstellen. Sobald das Problem behoben ist, lösche ich die lokale Site. Lassen Sie mich wissen, ob dies bei Ihnen in Ordnung ist.

 WICHTIG

Machen Sie eine Sicherungskopie der Site-Dateien und der Datenbank, bevor Sie uns den Zugriff gewähren.
Wenn Sie die Felder "wp-admin / FTP" nicht sehen, werden Ihre Anmeldedaten für Post und Website als "PUBLIC" (Öffentlich) festgelegt. Veröffentlichen Sie NICHT die Details Ihrer Website, es sei denn, Sie sehen die erforderlichen wp-admin / FTP-Felder. Wenn Sie dies nicht tun, bitten Sie mich, die private Box zu aktivieren. Die private Box sieht so aus:
hidden link

Mit freundlichen Grüßen
Andreas

Es wärenaußerdem Änderungen

Februar 23, 2019 um 9:37 am
Februar 26, 2019 um 5:11 pm #3246437

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Mein Kollege Diego hat bereits eine Kopie Ihrer Website auf unseren Test-Server migirert. Er wird die Angelgenheit untersuchen, und falls notwendig diese an unser Kompatibilitätsteam oder unsere Entwickler weiterleiten.

Ich möchte Sie herzlichst bitten dieses Ticket für nun zu schließen. Ich bin mir sicher, Diego wird sich um die Problem bestens kümmern können.

Sollten weitere Probleme auftreten erstellen Sie bitte ein neues Ticket. Wir helfen Ihnen gerne weiter.

Mit freundlichen Grüßen
Andreas