Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 3 Antworten, has 2 Teilnehmer.

Last updated by Marcel vor 3 Monate, 2 Wochen.

Assigned support staff: Marcel.

Author Artikel
Juli 2, 2019 um 9:44 am

stephanP-10

Ich habe eine WordPress-Installation in deutsch und englisch.
Für beide Sprachen habe ich zwei verschiedene URL's im System hinterlegt.

Rufe ich die englische URL mit www auf, funktioniert alles wie es soll.

Rufe ich diese jedoch ohne www. auf, werde ich zur deutschen URL weitergeleitet.

URL meiner Website, auf der das Problem auftritt: hidden link

Erwartet hatte ich zu sehen: die englische Übersetzung.

Stattdessen bekam ich: die deutsche Sprachversion

Juli 2, 2019 um 10:38 am #4125811

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo xxx,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Sie haben einen 301 Redirect aktiv. Da kein zusätzliches Redirect Plugin installiert ist sowie die .htaccess normal aussieht vermute ich Ihre DNS Einstellung als Problem.

>>> <em><u>hidden link</u></em>

> --------------------------------------------
> 301 Moved Permanently
> --------------------------------------------

Status:	301 Moved Permanently
Code:	301
Server:	nginx
Date:	Tue, 02 Jul 2019 10:33:51 GMT
Content-Type:	text/html; charset=UTF-8
Content-Length:	0
Connection:	close
X-UA-Compatible:	IE=edge
X-Redirect-By:	WordPress
Location:	<em><u>hidden link</u></em>

>>> <em><u>hidden link</u></em>

> --------------------------------------------
> 200 OK
> --------------------------------------------

Status:	200 OK
Code:	200
Server:	nginx
Date:	Tue, 02 Jul 2019 10:33:51 GMT
Content-Type:	text/html; charset=UTF-8
Connection:	close
Vary:	Accept-Encoding
X-UA-Compatible:	IE=edge
Link:	<<em><u>hidden link</u></em>;; rel=shortlink

Können Sie das bitte überprüfen? Eventuell ist hier die URL so konfiguriert.

Freundliche Grüße
Marcel

Juli 2, 2019 um 12:43 pm #4127011

stephanP-10

Hallo Marcel,
laut Hoster wurden keine DNS weiterleitungen angelegt.

Daher scheint es daran nicht zu liegen.

Viele Grüße
Torben

Juli 2, 2019 um 1:44 pm #4127519

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Torben,

ich habe für einen Moment WPML deaktiviert. Das Problem tritt auch auf, wenn alle WPML Komponenten deaktiviert sind.

#1 Fragen Sie bitte Ihren Hoster ebenso den HTTP Server Einstellung zu überprüfen: Siehe HTTP-Servers

#2 Mir ist auch aufgefallen, dass WPML zu wenig Speicher zugwiesen hat. Fügen Sie bitte diesen Code Ihrer wp-config.php hinzu, um den Arbeitsspeicher von WP zu erhöhen. Damit wird der Speicher von aktuell 40MB auf 256 erhöht. WPML benötigt mind. 128MB.

define ('WP_MEMORY_LIMIT', '256M'); 

Fügen Sie es kurz vor:

 
/* That's all, stop editing! Happy blogging. */

Freundliche Grüße
Marcel