Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

This topic contains 5 Antworten, has 2 Teilnehmer.

Last updated by Marcel vor 3 Wochen, 4 Tagen.

Assigned support staff: Marcel.

Autor Beiträge
September 11, 2019 um 8:38 am #4551735

hans-peterD

Ich versuche: Englische Shop-Übersetzung (WooCommerce).
a. Ware im Warenkorb hinzufügen (ok)
b. weiter zur Kasse/Bezahlung (die Seite wird nicht gefunden)

alle anderen Sprachen (DE, FR, ES, IT, NL) funktionieren

URL der/meiner Website, auf der das Problem auftritt: hidden link

Erwartet hatte ich zu sehen: "Checkout"

Stattdessen bekam ich: "Oops! That page can’t be found."

September 11, 2019 um 10:09 am #4552395

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Hans-Peter,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Bitte prüfen Sie ob die Checkout als Seite existiert und ob dieser ggf.

- als Entwurf gespeichert ist
- im Papierkorb eine identische Seite liegt

Sie können auch unter WooCommerce -> WooCommerce Multilingual - Status unter "WooCommerce Store Pages" prüfen, ob hier eine Meldung erscheint, dass die Store Pages angelegt werden müssen

Bitte um Info

Freundliche Grüße
Marcel

September 11, 2019 um 10:44 am #4552707

hans-peterD

Hallo Marcel,

Danke für das schnelle Feedback.

Zu Deinen Fragen:

1. Bitte prüfen Sie ob die Checkout als Seite existiert und ob dieser ggf.
a. als Entwurf gespeichert ist > Nein
b. im Papierkorb eine identische Seite liegt > Nein

2. Sie können auch unter WooCommerce -> WooCommerce Multilingual - Status unter "WooCommerce Store Pages" prüfen, ob hier eine Meldung erscheint, dass die Store Pages angelegt werden müssen

Unter Shop-URLs sind keine Meldungen zu fehlenden Seiten vorhanden.

Grundsätzlich:
Die Seite ist im Original (DE) unter "Kasse" angelegt und für die einzelnen Sprachen im WPML Translation Editor übersetzt. Lediglich in der Sprache "englisch" erfolgt die genannte Fehlermeldung.

Bei der Überprüfung der Basisseite mit den jeweiligen Sprachen sind alle Einstellungen identisch, ausgenommen die jeweilige Übersetzung in der Seiten URL, bzw. in den übersetzten Attributen.

Mit besten Grüßen
Hans-Peter Dorn

September 11, 2019 um 11:13 am #4552885

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Ich würde mir das gerne direkt auf Ihrer Seite ansehen. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

September 17, 2019 um 7:31 am #4586083

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

vielen Dank, um ein PHP Debugging zu aktivieren bräuchte ich bitte den FTP Zugang. Das übermittelte Log aus dem WordPress Health Monitor zeigt mir nicht alle Details bzw. nicht den aktuellen Stand. Ansonsten kann ich den Fehler nicht lokalisieren.

Freundliche Grüße
Marcel

September 24, 2019 um 3:34 pm #4632871

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

mir sind im Log keine speziellen Fehler aufgefallen. Jedoch leitete der Warenkorb in allen Sprachen wieder auf den Warenkorb, bzw. ohne WPML auf die Startseite. Dies habe ich durch ein erneutes Abspeichern der Einstellungen lösen können.

Auch bekam ich div. Andere Fehler beim Aufrufen der Seite bzw. bemerkte auch, dass WooCommerce im Backend keine Icons für die Hilfetexte anzeigt. Bevor Sie die Seite neu erstellen, würde ich Ihnen empfehlen WooCommerce neu zu konfigurieren. Wenn möglich testweise auf einem Server der nicht von Stato stammt.

Freundliche Grüße
Marcel