Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 6 Antworten, has 2 Teilnehmer.

Last updated by sebastianK-89 Vor 1 Monat, 1 Woche.

Assigned support staff: Andreas W..

Author Artikel
Oktober 26, 2021 um 2:36 pm #9865723

sebastianK-89

URL der/meiner Website, auf der das Problem auftritt:
Wordpress 1:1 Kopie unserer Live-Seite (https:kommit-bike.de/shop) -
Produktansicht sowie Shopannsicht ist vom Problem betroffen:
hidden link

Erwartet hatte ich zu sehen:
Anzeigen der Sterne und die Gesamtbewertung.

Stattdessen bekam ich:
Ausgabe keine Sterne und keine Gesamtbewertung.

Das Problem trat nach der Installation von WPLM inkl. Addons (Woocommerce, Media Translation, Strings etc.) auf.
Das Problem besteht sowohl in der Deutschen wie Englischen Version der Seite.
Das Problem tritt sowohl mit nur Woocommcerce Core Bewertungen auf, also auch mit dem zusätzlichen Plugin Custom Reviews (hidden link)

Gerne lasse ich Euch einen Admin-Zugang zur 1:1 Kopie unserer Live-Seite zukommen:
login: admin-support pw: YZHFuzFYnQZOZC
hidden link

Bei Rückfragen gerne melden.

Bildschirmfoto 2021-10-26 um 15.45.05.png
Bildschirmfoto 2021-10-26 um 15.25.02.png
Bildschirmfoto 2021-10-26 um 15.24.54.png
Oktober 27, 2021 um 8:53 am #9871653

Andreas W.
Supporter

Languages: Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich kann anbieten eine Kopie der Website anzulegen, um diese einmal auf einem lokalen Server zu testen.

Was jedoch Zeit sparen könnte, wäre zu versuchen, das Problem auf folgender Test-Site zu replizieren, damit ich es intern eskalieren kann. Installieren Sie dazu bitte das "Customer Reviews for WooCommerce" Plugins:

Ein-Klick-Login:
hidden link

Bitte hinterlasse mir eine kurze Nachricht sobald das Plugin installiert wurde.

Ich habe zudem das private Antwortformular aktiviert, solltest Du bevorzugen, dass ich zuerste einen Blick auf die Website werfen. Wie Du alelrdings sagtest, tritt das Problerm nur dann auf, wenn WPML aktiviert wird, weshalb ich denke wir sollten direkt versuchen das Problem nachzustellen und direkt zu eskalieren.

Mit freundlichen Grüßen
Andreas

Oktober 28, 2021 um 3:21 am #9878777

Andreas W.
Supporter

Languages: Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Sebastian,

Das Problem scheint eventuell mit einem weiteren Plugin verbunden zu sein.

Auf meiner Test-Site, kann ich nachdem ich ein Produkt gekauft habe, diese in beiden aktiven Sprachen bewerten. Die Sternwertung wird dabei synchronisiert und je Sprache kann man die jewiligen Bewertungen je Sprache einsehen.

Wenn ich nun auf Deiner Tes-Site die gleichen Plugins verwende, werden Sie Sterne überhaupt nicht angezeigt.
Ob das am Theme liegt, kann ich leide rnicht sagen, weil ich auf der Test-Site keine Erlaubnis habe dieses zu wechseln.

Die Sternewertung erscheitn nur dann auf Deiner Website, wenn ich GP Premium aktiviere.

Bitte installiere das Theme und GP Premium auf unserer Test-Site und versuche das Problem zu replizieren.

Gib mir danach bitte Bescheid.

Mit freundlichen Grüßen
Andreas

Oktober 28, 2021 um 7:44 am #9879919

sebastianK-89

Hallo Andreas,

habe das Theme und das GP Premium Plugin auf deiner Testumgebung installiert. Habe auch die Grundeinstellung (Customizier) importiert und die selben Module in GP Premium aktiviert.
Die Sterne werden immer noch angezeigt. Also daran liegt es nicht.

Kann es sein, dass es an den alten/bestehenden Bewertungen liegt, und die nicht sauber übernommen wurden, nach der Installation von WPML?

-> BAM! Ich habe gerade eine neue Bewertung ohne die Einstellung "Verifizierter Kauf" erstellt (Siehe Bilder) und jetzt tauchen die Sterne + Gesamtbewertung wieder auf: hidden link

In der Englischen Version zumindest unter Reviews. Neben dem Produkt keine Sterne.

Bildschirmfoto 2021-10-28 um 09.43.13.png
Bildschirmfoto 2021-10-28 um 09.40.23.png
Bildschirmfoto 2021-10-28 um 09.40.03.png
Oktober 28, 2021 um 10:33 am #9881925

sebastianK-89

Hi Andreas,

ich habe nochmal nachgesehen. Ich habe die Einstellung in Woocommerce > Einstellungen > Produkt > Produktbewertungen erlauben

Hier habe ich einmal die Option
"Bewertungen können nur von "Verifizierten Besitzern" hinterlassen werden"
deaktiviert > speichern und wieder aktiviert > speichern. Danach wurden die Sterne und die Gesamtbewertung wieder angezeigt.

Bildschirmfoto 2021-10-28 um 10.08.53.png
Oktober 28, 2021 um 11:15 pm #9887331

Andreas W.
Supporter

Languages: Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Das ist ja recht seltsam.

In dem Fall würde ich dazu raten von der Option Notiz zu nehmen, sollte das Problem erneut auftreten.

Intern eskalieren kann ich es nur, wenn es uns möglich wäre das Problem auf der Sandbox nachzustellen.

Ich hoffe dazu mit Deinem Verständnis.

Du kannst gerne nochmal versuchen, ob sich das Problem irgendwie auf der Sandbox nachstellen lässt und mir dann Bescheid geben.

Mit freundlichen Grüßen
Andreas

Oktober 28, 2021 um 11:26 pm #9887333

sebastianK-89

Alles klar. So machen wir es. Vielen Dank.