Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
On the Classic Translation Editor the text field is empty when set to the visual tab.

Solution:
Indeed, this is a known issue which came up with the Update for WordPress 5.6 and should be solved by the WP Core Team with one of the upcoming updates for WordPress.

Relevant Documentation:
Source:
https://core.trac.wordpress.org/ticket/52133

Workarounds from our side can be found here:
https://wpml.org/errata/visual-tab-in-classic-translation-editor-is-not-showing-contents-after-update-to-wordpress-5-6/

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

This topic contains 2 Antworten, has 2 Teilnehmer.

Last updated by Fabian J. Vor 1 Jahr, 3 Monate.

Assigned support staff: Andreas W..

Author Artikel
März 3, 2021 um 5:02 pm #8220597

Fabian J.

Hi,

I have this issue on a clients site and also on the testsite I made afterwards:
I try to translate products via the woocommerce multilingual plugin. The translation editor appears but does not show the content to translate - unless I reload the page for 1 up to x times.
-> Before I reload the page the text to translate is visible when I activate the text-mode but not in the visual-mode of the editor ==> in the visual-mode the textarea-element in the editor-box is set on "display:none" by an inline-css, the font is set to white via editor.css: .js .tmce-active .wp-editor-area {color:#fff;}.

Some good advice would really be appreciated. Thank you!

2021-03-03-wpml-support-woocommerce-multilingual-01.jpg
2021-03-03-wpml-support-woocommerce-multilingual-02.jpg
März 4, 2021 um 6:26 am #8224221

Andreas W.
Supporter

Timezone: America/Lima (GMT-05:00)

Hello,

Indeed, this is a known issue which came up with the Update for WordPress 5.6 and should be solved by the WP Core Team with one of the upcoming updates for WordPress.

Source:
https://core.trac.wordpress.org/ticket/52133

Workarounds from our side can be found here:
https://wpml.org/errata/visual-tab-in-classic-translation-editor-is-not-showing-contents-after-update-to-wordpress-5-6/

Best regards
Andreas

März 4, 2021 um 4:20 pm #8229957

Fabian J.

My issue is resolved now. Thank you!