Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

This topic contains 7 Antworten, has 2 Teilnehmer.

Last updated by Marcel vor 3 Monate, 1 Woche.

Assigned support staff: Marcel.

Autor Beiträge
Mai 28, 2019 um 10:19 am

Sebastian Kabis

Ich versuche:
Custom Attributes mit Umlauten zu übersetzen (z.B. "Größe"). Ähnlich wie hier https://wpml.org/de/forums/topic/produkteigenschaften-variable-produkte-werden-auf-produktseite-nicht-uebersetzt/ werden Übersetzungen für Attribute mit Umlauten nicht gespeichert. Sobald ich "Größe" in "Groeße" ändere klappt es wieder. Anscheinend wurde das Problem bereits in Version 4.1.0 gelöst, tritt hier allerdings in WooCommerce Multilingual 4.6.3 wieder auf.

URL der/meiner Website, auf der das Problem auftritt:
hidden link

Mai 29, 2019 um 1:00 pm #3915713

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Sebastian,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Können Sie bitte versuchen das WordPress Memory Limit zu erhöhen?

Fügen Sie bitte diesen Code Ihrer wp-config.php hinzu, um den Arbeitsspeicher von WP zu erhöhen. Damit wird der Speicher von aktuell 40MB auf 256 erhöht. WPML benötigt mind. 128MB.

define ('WP_MEMORY_LIMIT', '256M'); 

Fügen Sie es kurz vor:

 
/* That's all, stop editing! Happy blogging. */

Freundliche Grüße
Marcel

Mai 29, 2019 um 1:05 pm #3915785

Sebastian Kabis

Hallo Marcel,

das ist erledigt. Löst aber das Problem nicht.

Nachtrag: Was ich noch rausfinden konnte: Das Problem tritt auf wenn Produkte zuerst in deutscher Sprache angelegt wurden und dann in englisch übersetzt werden. Wenn ich ein Produkt in englisch anlege mit dem Attribut "Größe" und das dann in deutsch übersetze, funktioniert alles einwandfrei.

Viele Grüße
i.A. Dennis

Mai 29, 2019 um 1:16 pm
Mai 29, 2019 um 1:24 pm #3915869

Sebastian Kabis

Ich habe nun zwei Testprodukte angelegt und als Beispiel zwei Custom Attribute.

Testprodukt lässt sich "Größe" nicht von deutsch zu englisch übersetzen. Daten werden einfach nicht gespeichert und sind nach einem Reload weg. Eine Fehlermeldung erscheint nicht. (s. Screenshot)

Testprodukt (en) lässt sich ohne Probleme von englisch zu deutsch übersetzen.

Mai 31, 2019 um 1:57 pm #3931065

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Sebastian,

vielen Dank. Ich habe die Sandbox überprüft und diese mit allen Informationen an unser Team eskaliert und geben Ihnen umgehend Bescheid, wenn ich eine Rückmeldung dazu erhalten habe.

Freundliche Grüße
Marcel

Juni 3, 2019 um 2:44 pm #3943643

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Sebastian,

das Problem wurde bestätigt und ein Bug Tracker Eintrag an unsere Entwickler übermittelt. Ich gebe Ihnen umgehend Bescheid, wenn das Problem behoben wurde.

Freundliche Grüße
Marcel

Juni 6, 2019 um 1:23 pm #3969465

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Sebastian,

das Problem wurde behoben und ist im nächsten Release enthalten.

Freundliche Grüße
Marcel

Juli 11, 2019 um 10:34 am #4188727

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Sebastian,

bitte aktualisieren Sie WPML inkl. Add-Ons sowie WooCommerce Multilingual. Das Problem wurde behoben.

Freundliche Grüße
Marcel