Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
Ich habe versucht die Shop-URLs der Produkte zu übersetzen. Jedoch werden diese nicht ins englische übernommen.

Solution:
Ein erneutes Abspeichern des Werts wie im Screenshot ersichtlich löste das Problem. Hierzu habe ich zuerst auf "products2" umgestellt und den Wert dann wieder mit "products" überschrieben.

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

This topic contains 9 Antworten, has 2 Teilnehmer.

Last updated by timoM-19 Vor 1 Monat, 1 Woche.

Assigned support staff: Marcel.

Author Artikel
Juni 27, 2022 um 2:51 pm #11552601

timoM-19

Hallo zusammen,

ich habe versucht die Shop-URLs der Produkt zu übersetzen. Jedoch werden diese nicht ins englische übernommen.

Beispiel:
hidden link
wird zu
hidden link

Dabei sollte "produkt" im englischen eigentlich "product" heißen

Meine Einstellungen als Screenshot

Screenshot 2022-06-27 165021.png
Screenshot 2022-06-27 164702.png
Juni 27, 2022 um 4:10 pm #11553313

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

haben Sie nach der Anpassung die Permalinks aktualisiert? Falls nicht, erstellen Sie bitte ein Backup und versuchen Sie es damit erneut.

Freundliche Grüße
Marcel

Juni 28, 2022 um 8:06 am #11556829

timoM-19

Danke für die Antwort.
Wo kann ich denn die Produkt-Permalinks aktualisieren? Bzw. was ist damit gemeint?

Vielen Dank

Juni 28, 2022 um 8:17 am #11556901

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

damit sind die WordPress Permalinks unter Settings -> Permalinks gemeint.

Freundliche Grüße
Marcel

Juni 28, 2022 um 8:29 am #11556973

timoM-19

Die permalinks sind wie im screenshot zu sehen eingestellt:
Und "produkt" ist unter den shop-urls zu "product" übersetzt

Screenshot 2022-06-28 102330.png
Juni 28, 2022 um 9:26 am #11557629

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

die aktuelle Permalink Einstellung ist hier nicht das Problem, es sollte nur überprüft werden, ob die Permalink Einstellung überhaupt ausgeführt wird. Funktioniert es im Frontend, sobald Sie dort die Permalinks erneut abspeichern?

Bitte sichern Sie Ihre Seite vor diesem Test.

Freundliche Grüße
Marcel

Juni 28, 2022 um 9:48 am #11558035

timoM-19

Wollt ihr eventuell mal kurz einen Blick darauf werfen? Ich komme hier leider nicht weiter. Dann erstelle ich euch kurz eine Staging-Area?

Beste Grüße

Juni 28, 2022 um 10:08 am #11558179

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

ich würde mir das gerne direkt auf Ihrer Seite ansehen. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Die dafür benötigten Felder finden Sie unterhalb des Kommentarbereichs. Die Informationen, die Sie eingeben, sind privat, d.h. nur Sie und ich können sie sehen und haben Zugriff darauf.

WICHTIG
Bitte erstellen Sie eine Sicherungskopie der Site-Dateien und der Datenbank, bevor Sie uns Zugang gewähren.
-Wenn Sie die wp-admin/FTP-Felder nicht sehen, bedeutet dies, dass Ihre Post- und Website-Login-Daten ÖFFENTLICH gemacht werden. Posten Sie Ihre Website-Details NICHT, wenn Sie die erforderlichen wp-admin/FTP-Felder nicht sehen. Wenn Sie das nicht tun, bitten Sie mich, die private Box zu aktivieren. Die private Box sieht wie folgt aus:
hidden link

Für die Footer Widgets können Sie gerne ein getrenntes Ticket anlegen, dann können wir dies ebenso überprüfen. Dies ist eigentlich kein Fehler, da Übersetzungen typischerweise in Englisch im Theme mitgeliefert werden. Daher werden Sie eine falsche Ausgangssprache sehen. Dies lässt sich über einen Button anpassen: https://wpml.org/documentation/getting-started-guide/string-translation/how-to-change-the-source-language-of-strings/.

Freundliche Grüße
Marcel

Juni 28, 2022 um 5:02 pm #11561789

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

danke für den Zugang.

Ein erneutes Abspeichern des Werts im Screenshot löste das Problem: hidden link. Hierzu habe ich zuerst auf "products2" umgestellt und den Wert dann wieder mit "products" überschrieben.

Freundliche Grüße
Marcel

cpt.png
Juni 29, 2022 um 8:18 am #11564809

timoM-19

Super, vielen Dank!
Damit ist das Problem gelöst 🙂