Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This thread is resolved. Here is a description of the problem and solution.

Problem: Nach einem Update bekomme ich die Meldung "WordPress Fehler: Konnte Sprachdatei nicht laden".

Solution: Das Problem trat nur auf, wenn das Plugin "VRBooking" Plugin aktiv war. Wenn Sie den Domain Path unter vrbooking.php (welcher auf /languages konfiguriert ist) entfernen, funktioniert die Englische Seite (und auch Englisch als User Sprache)

Bitte überprüfen Sie diese Implementierung Ihres Custom Plugins.

Relevant Documentation: https://developer.wordpress.org/plugins/internationalization/how-to-internationalize-your-plugin/#domain-path

Schlagwörter: 

This topic contains 5 Antworten, has 2 Teilnehmer.

Last updated by dirkM vor 2 Monate, 1 Woche.

Assigned support staff: Marcel.

Author Artikel
Juli 31, 2019 um 10:52 am #4313759

dirkM

Ich versuche:
Habe lediglich Plugins aktualisiert (u.a. auch WPML), im Anschluss kommt im Frontend nach Umstellung von der Standardsprache Deutsch auf z.B. Englisch oder Spanisch diese Fehlermeldung.

URL der/meiner Website, auf der das Problem auftritt:
hidden link

Erwartet hatte ich zu sehen:
Die englische Seite

Stattdessen bekam ich:
WordPress-Fehler: Konnte Sprachdatei nicht laden

Juli 31, 2019 um 2:06 pm #4315159

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Dirk,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Es scheint, als ob das Avada Theme die Sprachfiles nicht laden kann. Passiert dies auch mit dem WordPress Standard Theme TwentyNinteen?

Bitte um Info

Freundliche Grüße
Marcel

Juli 31, 2019 um 2:34 pm #4315405

dirkM

Hallo Marcel,

leider kann ich dies nicht testen, da bereits alle anderen Themes vom Kunden entfernt wurden und ich nicht einfach jetzt ein Standardtheme installieren möchte/darf. Es hat ja aber vor der Aktualisierung der WPML - Plugins funktioniert. Weder Avada noch die Fusion Plugins wurden aktualisiert. Nur WPML Plugin und ein eigenes entwickeltes.

Juli 31, 2019 um 2:49 pm #4315489

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Dirk,

können Sie ggf. ein Duplicator Package bereitstellen oder eine Testumgebung? Alternativ kann ich Ihnen auch anbieten, dass Sie die Seite mithilfe eines Plugins unkompliziert auf unseren Cloudways Server migrieren.

Ich kann nicht 100% sagen, ob dies von WPML oder WordPress ausgelöst wird. Das Design der Fehlermeldung kommt aus dem WP Core. Möglicherweise sind keine Sprachfiles (.po Files) mehr hinterlegt, das müsste ich somit über das Theme testen.

Bitte um Info

Freundliche Grüße
Marcel

August 1, 2019 um 12:32 pm #4321677

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Dirk,

vielen Dank für das Duplicator File.

Das Problem tritt nur auf, wenn ihr VRBooking Plugin aktiv ist. Wenn Sie den Domain Path unter vrbooking.php (welcher auf /languages konfiguriert ist) entfernen, funktioniert die Englische Seite (und auch Englisch als User Sprache)

https://developer.wordpress.org/plugins/internationalization/how-to-internationalize-your-plugin/#domain-path

Bitte überprüfen Sie diese Implementierung Ihres Custom Plugins.

Freundliche Grüße
Marcel

August 2, 2019 um 9:12 am #4328389

dirkM

My issue is resolved now. Thank you!