Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 7.23 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: Auto update is not showing in plugins

Solution: https://wpml.org/de/forums/topic/wpml-does-not-update-like-before/#post-4662513

This topic contains 4 Antworten, has 2 Teilnehmer.

Last updated by martinG-20 vor 2 Wochen, 4 Tagen.

Assigned support staff: Riffaz.

Autor Beiträge
September 30, 2019 um 6:38 am #4662493

martinG-20

Since some weeks I have the problem that WPML isn't telling me anymore, that I have to update the Plugins. The hint is missing. Before on every Plugin Update I have received the common message. I have tried to unregister and register the page again - doesn't solve the problem unfortunately. Can you please help here? Thanks in advance.

Best

September 30, 2019 um 6:51 am #4662513

Riffaz
Supporter

Languages: Englisch (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

- Go to Dashboard -> Updates
- Press the "Check Again" button : hidden link
- Press the "Update" button at the bottom of the page
- Try to update the plugins

- Go to Plugins -> Add New -> Commercial
- Press the "Check for updates" button
- Try to update the plugins

- Go to https://wpml.org/account/sites/ look for your current key and erase it.
- Create a new one for your site.
- Go to Plugins -> Add New -> Commercial
- Click on the "Unregister WPML from this site" button
- Register WPML adding your new key.
- Try also disabling the "Keep wpml.org up-to-date about which theme and plugins I use" option

If that does not fix the issue you can manually update the plugins.
❌ Before proceeding please make a full website backup! ❌
- Download the latest version of WPML from https://wpml.org/account/downloads/
- Disable WPML Multilingual CMS
- Delete WPML Multilingual CMS (the settings and the translations are saved in the database so they will not be deleted)
- Upload the freshly downloaded WPML plugin from Plugins -> Add New -> Upload Plugin
- Activate WPML

Let me know how it goes.

Regards,
Riffaz.

September 30, 2019 um 1:42 pm #4664937

martinG-20

Hi Riffaz,

thanks for your help.

About the "Commercial" section of the plugins page, I could update the plugins BUT... before I have tried to delete the Key like you have mention it. This wasn't possible. Furthermore I didnt received the hint on the plugin page, that there are some updates for the WPML plugins. 🙁 So actually the problem still exists but it was possible to update it via the "commercial" page.

Oktober 1, 2019 um 4:13 am #4668667

Riffaz
Supporter

Languages: Englisch (English )

Timezone: Asia/Colombo (GMT+05:30)

hi,

it was possible to update it via the "commercial" page.
- so all WPML plugins are up to date now, right?

Furthermore I didnt received the hint on the plugin page, that there are some updates for the WPML plugins.
- try this again future updates will be shown there:
- Go to Dashboard -> Updates
- Press the "Check Again" button : hidden link
- Press the "Update" button at the bottom of the page
- Try to update the plugins

- delete server cache and check.
- deactivate all the plugins and reactivate and check

Hopefully, you will not experience the same issue again with the updates.

Regards,

Oktober 2, 2019 um 6:27 am #4677283

martinG-20

Thanks so far Riffaz. At the moment the WPML-Plugins are updated. I can't see any new versions for now and hope it will work for future Updates. I will take a look into the "Commercial" tab of the plugin section. There I can see if there is a newer version for WPML Plugins. Perhaps I will come back, but for now you can mark this as resolved. Thanks.