Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 2.69 hours from now. Thank you for your understanding.

This topic contains 9 Antworten, has 3 Teilnehmer.

Last updated by George Botsev vor 1 Jahr.

Assigned support staff: Cristina.

Autor Beiträge
Oktober 8, 2018 um 12:14 pm #2795938

christianB-102

Die Installation von WPML hat geklappt, allerdings beim Einrichten des Plugins nachdem ich die derzeitige Sprache ausgewählt und auf "Weiter" geklickt habt, kommt folgende Meldung: Der Link, dem du gefolgt bist, ist abgelaufen.

Oktober 8, 2018 um 3:39 pm #2796773

Cristina

Hallo Christian,

diese Meldung kenn ich so gar nicht, aber wenn Sie keinen längeren Zeitraum zwischen den beiden Installationsschritten verstreichen gelassen haben, dann könnte hier eventuell ein anderes Script eingewirkt haben.

Könnten Sie in WPML >Support gehen und dort in der Fehlerbehebungsseite die Option wählen (falls verfügbar), um die Sprachen zurückzusetzen?

Das wäre einmal unter "Aufräumen" die Option "Dieser Vorgang wird die Sprachtabellen von WPML zurücksetzen und neu installieren. Alle kundenspezifischen Sprachen, die Sie hinzugefügt haben, werden entfernt." und weiter unten die Option "Zurücksetzen".

Damit würden die installierten Sprachinformationen gelöscht. Wenn danach der Cache ebenfalls geleert wird, könnten Sie versuchen, den Installer noch einmal laufen zu lassen.

Die andere Option wäre ein Reset von WPML, wenn noch keine Übersetzungen vorhanden sind. In dem Fall würde man die Option "Reset" durchführen, mit alle WPML Tabellen gelöscht würden. Dann kann man das Plugin erneut aktivieren und ganz neu anlegen.

Wenn Sie das tun, deaktivieren Sie bitte vorher jeden Cache und die unbeteiligten Plugins auf der Seite, um mögliche Konflikte mit dem Installer zu vermeiden.

Um das Problem besser zu identifizieren, falls dies nicht hilft, wäre es hilfreich, wenn Sie uns die Informationen des WordPress Debugs zukommen lassen könnten.
Das sind die Fehlermeldungen im WordPress selbst, nicht die von WPML.

Dafür müssten Sie in der Datei wp-config.php im Root-Verzeichnis der WordPress-Installation diese Zeile suchen:

define('WP_DEBUG', false);

Bitte ändern Sie dort "false" auf "true" und fügen Sie eine weitere Zeile ein, so dass es wie folgt lautet:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY',false);

Damit werden die PHP-Fehler in eine Datei namens debug.log im Verzeichnis /wp-content/ gespeichert.

Es handelt sich um eine Textdatei, die wir über den Link kopieren und analysieren können.
Wenn Sie den Inhalt in die Antwortbox hineinkopieren, entsteht sonst ein ziemlich unübersichtlicher Textsalat. Wenn Sie diese Datei (debug.log) kopieren und auf pastebin.com verlinken könnten, wäre das sehr hilfreich für uns.

Vielen Dank und schönen Gruß,
Cristina

Oktober 8, 2018 um 4:57 pm #2796993

christianB-102

Hallo Cristina,

vielen Dank für die Tipps, aber es hat leider nicht geholfen. Es wird auch keine debug.log angelegt. Vielleicht ist es besser, wenn ich Ihnen die Zugangsdaten gebe:

Sollten Sie auch die FTP-Zugangsdaten benötigen, sagen Sie bitte kurz Bescheid.

Vielen Dank und liebe Grüße
Christian.

Oktober 8, 2018 um 6:29 pm #2797092

Cristina

Hallo Christian,

danke für die Login-Daten, aber sie waren nicht in einer privaten Antwort, so dass ich sie von dem Post gelöscht habe.

Ich aktiviere die Private Antwortbox für Ihre nächste Antwort, so dass Sie hier neue Zugangsdaten einsetzen, die nur für Sie und den Support sichtbar sind. Bitte löschen Sie das alte Passwort.

Wenn Sie einen etwas komplexeren Aufbau für das WordPress haben, das nicht dem einfachen Standard entspricht, kann es eventuell ein Problem mit WPML geben.

Haben Sie Zugang auf Ihre wp-config.php Datei im WordPress Ordner im FTP?

Ich probiere gerne die Installation auf der Seite, aber wenn es zu einem 500 Fehler kommt, muss man die Plugins im Plugin-Ordner umbenennen um wieder in den Adminbereich zu kommen.

MFG,
Cristina

Oktober 10, 2018 um 8:38 am #2803455

Cristina

Hallo Christian,

ich glaube, das Problem hier liegt an einer Sicherheitseinstellung, die den Abruf der XML Konfiguration von den WPML - Server blockiert.

Ich habe einen kurzen Test durchgeführt, und die Verbindung zu WPML an sich besteht und ist korrekt, wenn man die Server direkt mit einer Datei anspricht.

Der Server gibt aber bei dem Setup-Wizard einen 403-Fehler zurück, was so etwas wie ein "Betreten Verboten" Schild für den Abruf ist, so dass der Installer hier stoppt, weil er abgewiesen wird.

In der .htaccess Datei im WordPress Verzeichnis gibt es ganz oben zwei Zeilen, die das eventuell bewirken. Hier wird dauerhaft von http auf https umgeleitet.

WPML an sich ist eigentlich transparent, was http oder https betrifft. Da aber die von den WPML Servern abgerufene URLs inzwischen von https auf http umgestellt wurden, weil umgekehrt manche Webseiten mit dem https Probleme hatten, könnte es hier ein Problem bei der Antwort geben.

Der andere mögliche Grund für den 403-Code könnte sein, dass die Rechte im wp-content Verzeichnis den Rückruf verhindern. Normalerweise erlauben 750 und 755 die Kommunikation. Der WPML Plugin-Ordner hat die Rechte 755, während wp-content nur 750 Rechte hat.

Das könnte dazu führen, dass beim dem zweiten Schritt, bei dem die verfügbaren Sprachen abgerufen werden und auch die entsprechenden Sprachdateien heruntergeladen werden (von WPML und von den WordPress Servern) bei der Antwort blockiert wird.

Ich würde jetzt drei Dinge versuchen:

Option 1

Für die WPML Installation, die beiden ersten Zeilen auskommentieren oder entfernen und probieren, ob der Wizard dann korrekt weiterführt, wenn es keinen zusätzlichen Serverbefehl gibt.

RewriteEngine On
//diese beiden Zeilen sind vom Benutzer hinzugefügt (das xxx ist im Klartext die Domain) und erstellen eine dauerhafte Umleitung von http auf https:
// in der .htaccess wird mit #auskommentiert:

# RewriteCond %{SERVER_PORT} !=443
# RewriteRule ^(.*)$ <em><u>hidden link</u></em> [R=301,L]

// Hier beginnt der WordPress Standard:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Die URLS, die WPML abruft und für die Einrichtung nutzt, sind diese:
- Amazon Cloud Service: hidden link
- WPML API mit der IP: 74.50.57.24

Option 2
Die Rechte für den Ordner wp-content und auch den Plugins-Ordner wp-content/plugin auf 755 ändern, so dass das Verzeichnis durchsucht werden kann.

Option 3

Die https-URLs von WPML abrufen, so dass hier kein Problem mit dem Protokoll entsteht.

Sie würden dann die Konfigurationsdatei so ändern, dass die sichere Version abgerufen wird.

Dafür müssen Sie in der Zeilen 945 in der Datei constants.php im Verzeichnis sitepress-multilingual-cms/inc/ die URL der aufgerufenen Datei von http auf https ändern.

Dann ist die Zeile wie hier unten geschrieben und ruft eine https-Verbindung auf. Das sollte dann kein Hindernis für den Port sein.

//diese Zeile
define( 'ICL_REMOTE_WPML_CONFIG_FILES_INDEX', '<em><u>hidden link</u></em>' );

//würde dann zu 

define( 'ICL_REMOTE_WPML_CONFIG_FILES_INDEX', '<em><u>hidden link</u></em>' );

Wenn jetzt diese https URL abgerufen wird, sollte die Umleitung auf https kein Hindernis sein.

Das ist jetzt nichts geheimes, nur soll das nicht zum Standardrezept für jedes Verbindungsproblem werden und das wird bei jedem Plugin-Update überschrieben werden.

Wenn keine der drei Optionen etwas bringt, muss ich das an die Kollegen eskalieren, denn dann liegt das wohl etwas tiefer versteckt.

MfG,
Cristina

Oktober 10, 2018 um 10:25 am #2803822

christianB-102

Hallo Cristina,

erstmal vielen Dank für Deine intensive Hilfe. Leider haben die 3 Vorschläge auch nichts geholfen. Habe nach dem Test die Anpassungen wieder rückgängig gemacht.

Ich hoffe trotzdem noch, dass Ihr es schaffen werdet 🙂

Liebe Grüße, Christian.

Oktober 11, 2018 um 11:06 am #2807738

Cristina

Hallo Christian,

ich habe das an den 2nd Level eskaliert.

Ich denke, dass es mit irgendwelchen Sicherheitseinstellungen zu tun hat, aber das schauen sich dann die Kollegen an.

MfG,
Cristina

Oktober 12, 2018 um 7:07 am #2810930

George Botsev
Supporter

Languages: Englisch (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello!
I am George from second tier support.
I visited your site and fixed the problem.
I cannot tell the exact piece of code that made this problem, as I did not dig that deep, but once I switched your theme to Twenty Seventeen (one of the default WordPress themes) then I was able to continue the setup.

Oktober 12, 2018 um 9:52 am #2811528

christianB-102

My issue is resolved now. Thank you!

Oktober 12, 2018 um 12:42 pm #2812023

George Botsev
Supporter

Languages: Englisch (English )

Timezone: Europe/Sofia (GMT+03:00)

Glad to be of assistance!
Have a nice day and a wonderful weekend!