Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 7 Antworten, has 2 Teilnehmer.

Last updated by Marcel vor 1 Monat.

Assigned support staff: Marcel.

Author Artikel
September 9, 2019 um 8:55 am #4534853

joernJ

The mentioned error message leads to the error log which continually shows this error:

2019-09-08 20:59:109719 get_option app_error wpml_config_files_arr Missing data
2019-09-08 20:59:109691 index wp_error wpml-config/config-index.json

code: http_request_failed
message: cURL error 7: Failed to connect to cdn.wpml.org port 80: No route to host

Currently, as long it's in developement, the website is behind a frontend password protection. Should not be a problem, should it?

September 9, 2019 um 10:22 am #4535909

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Jörn,

Vielen Dank, dass Sie den WPML Support kontaktiert haben. Ihr Server kann die Konfig Dateien per cURL nicht laden.

#1 Bitte deaktivieren Sie den PW Schutz einen Moment
#2 Klicken Sie auf folgender Seite auf "Check Now" hidden link und schauen Sie, ob das Problem damit gelöst wird (grüner Haken)
#3 Dann können Sie den PW Schutz wieder aktivieren.

Freundliche Grüße
Marcel

September 9, 2019 um 10:33 am #4535965

joernJ

Hallo Marcel,

Danke für die schnelle Antwort. Das Häkchen bei cURL ist allerdings auch vorher schon gesetzt gewesen, jeweils mit und ohne Passwortschutz. Falls es hilft - der Installer-Log auf dieser Seite gibt folgende Meldung aus:

Request URL
hidden link

Response
Installer cannot contact our updates server to get information about the available products and check for new versions. If you are seeing this message for the first time, you can ignore it, as it may be a temporary communication problem. If the problem persists and your WordPress admin is slowing down, you can disable automated version checks. Add the following line to your wp-config.php file:<br /><br />

define("OTGS_DISABLE_AUTO_UPDATES", true);

Component
repositories-fetching

Den define() Eintrag in der wp-config.php habe ich auch schon angelegt. Sollte auch nicht zu der ursprünglichen Fehlermeldung führen, oder?

Herzliche Grüße,

jörn

September 9, 2019 um 2:43 pm #4538125

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Halo Jörn,

Ich würde mir das gerne direkt auf Ihrer Seite ansehen. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

September 9, 2019 um 5:04 pm #4539199

joernJ

Hallo Marcel,

vielen Dank für das Angebot. Im Moment kann ich allerdings leider noch keinen Zugang einrichten, da ich kurz vor der Projektübergabe an den Kunden stehe (WPML funktioniert in den Bereichen, in denen ich es benötige derzeit weitestgehend). Ich würde am Wochenende einen Developer Account mit der duplizierten Seite aufsetzen und Ihnen dann den entsprechenden Zugriff einrichten. Und mich dann noch einmal melden.
Sie können also meine nächste Nachricht noch einmal einmal auf Privat einstellen.

Herzliche Grüße,

jörn

September 10, 2019 um 7:20 am #4542407

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Jörn,

geht in Ordnung, die nächste Nachricht ist als privat markiert.

Freundliche Grüße
Marcel

September 10, 2019 um 11:34 am #4544743

joernJ

Hallo Marcel,
Sie haben meinen anderen Post (Installations-Problem – Invalid argument supplied for foreach()) schon übernommen. Dort habe ich einen Zugang eingerichtet, der auch für diesen Post gelten würde. Das wäre der Developer-Zugang geworden, wenn nicht das nächste Problem aufgetreten wäre. Zwangsläufig müssen wir nun beide Probleme verbinden.

Herzliche Grüße,

jörn

September 10, 2019 um 1:40 pm #4546003

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Jörn,

dies hängte auch mit dem zweiten Ticket zusammen. Nun passt es. Das Installer Log hat keine weiteren Fehler mehr gemeldet.

Freundliche Grüße
Marcel