Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

This topic contains 10 Antworten, has 3 Teilnehmer.

Last updated by Verein Vor 6 Jahre, 9 Monate.

Assigned support staff: Denise.

Author Artikel
Dezember 14, 2014 um 3:10 pm #528169

Verein

Lieber Andreas,
ich habe Woocommerce installiert. Erst ging alles sehr gut, die Produkte konnte ich einfach wie bei Pages/Seiten in DE und EN eingeben. Nun komme ich auf aber auf keine Produktseiten in EN sondern nur zu komischen Teilübersetzungen und dies scheint auf "Your product permalink base is not translated in Deutsch. The urls for the translated products will not work. Go to the String Translation to translate." Dabei habe ich festgestellt, dass, bestellt man in EN zB. gewissen Sachen wie "Versandkostenpauschale" oder Teile der der Überweisung (Screenshot bei eines Bestellungsbsp. anbei) nicht übersetzt sind. Kannst Du mir hierbei bitte helfen? Am besten schaust Du mal: hidden link bzw schicke ich Dir die Zugangsdaten? Danke für Deine Antwort!
Liebe Grüße von Maria

Bildschirmfoto 2014-12-14 um 16.06.31.png
Dezember 15, 2014 um 6:50 am #528315

Andreas Neuber
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Kann mich noch gut an deine Website erinnern 🙂
Ich empfehle folgendes zu machen..

1) Lege ein Datenbank-Backup an - zum Beispiel mit "phpMyAdmin -> Export"

2) Besonders wenn Woocommerce zum Einsatz kommt, sollten alle WPML-Plugins auf den neuesten Stand sein. Wir haben eine ganze Reihe von Sachen verbessert - du solltest diese Versionen zusammen verwenden:

WPML Multilingual CMS 3.1.8.4
WPML String Translation 2.0.14
WPML Translation Management 1.9.9
WPML Media 2.1.8
WooCommerce Multilingual 3.4.2
Woocommerce 2.2.8

3) WordPress
Könntest du auch WordPress auf die neueste Version 4.0.1 updaten?

..und dann..

4) Zu "WPML > Stringübersetzung > Box "Ausgangssprache der Strings"" gehen
Ist dort Englisch eingestellt?

Vielen Dank!

Dezember 15, 2014 um 9:15 am #528416

Verein

Lieber Andreas,

danke für Deine rasche Antwort! Ich freu mich natürlich, dass Du Dich bei der Fülle von Webseiten an meine erinnern kannst 😉

Ich werde alle von Dir angegebenen Schritte durchführen.

Nur zur Sicherheit 2 Fragen dazu bevor ich loslege:

ADD: 03) mir wurde geraten zu warten bis WP 4.0.1. auch in Deutsch verfügbar ist (da meine Adminsprache in Deutsch ist). Ist das also für meinen Site egal?

ADD: 04) Zu "WPML > Stringübersetzung > Box "Ausgangssprache der Strings"" gehen
Ist dort Englisch eingestellt? : Nein, ist noch Deutsch eingestellt --> also: ENGLISCH einstellen.

DANKE inzwischen und einen schönen Wochenbeginn!
Maria

Dezember 16, 2014 um 6:49 am #529083

Andreas Neuber
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Vielen Dank!

Zu 3):
WPML hat eine eingebaute Funktion mit der alle WordPress Übersetzungen eingepflegt werden können.
(unter "WPML > Theme & Plugins Localization")
Also selbst wenn du die Englische Version verwendest und in der Datei "wp-config.php" ist kein Wert für "WPLANG" gesetzt wäre das kein Problem.
Aber - ich denke wir können das im Augenblick so lassen, denke das Problem liegt woanders..

Zu4):
Verwirrend? Unter "WPML > Sprachen" ist als "Standardsprache Deutsch eingestellt, aber dann bei den Strings soll Englisch rein.. 🙂
Grund:
Wenn du in die Dateien von z.B. Woocommerce schaust wirst du feststellen, dass Textstrings immer mit einem __() oder _e() "umwickelt" sind. Der Text dort ist immer Englisch. Auch bei den allermeisten anderen Themes/Plugins ist das der Fall. Sollte die Texte dort ausnahmsweise Deutsch sein, dann müsste man Deutsch einstellen; ist aber sehr selten der Fall.

Dezember 16, 2014 um 10:00 pm #529804

Verein

Lieber Andreas,

Danke für Deine Antwort!
(Siehe Screenshot:) die Strings waren schon auf Englisch eingestellt. Ich hab dann mal auf "Optionen speichern und Strings erneut durchsuchen" geklickt: jetzt sind es 1685 Strings die man übersetzen sollte ...
Aber es ist nach wie vor, dass zB. Paypal - Zahlen in der De-Version auf En ist und umgekehrt.

Wie kann ich die Plugins updaten?
Wenn ich es versuche kommt immer wieder "Plugin failed" - auch wenn ich die bereits installierte Version lösche - vielleicht liegt es daran - hier bin ich mit diesen dreien:
WPML Multilingual CMS 3.1.8.4
WPML String Translation 2.0.14
WPML Translation Management 1.9.9
nicht up to date.

Also, ich hoffe es ist bald geschafft. Jetzt schon Danke für Deine Antwort!

Liebe Grüße von Maria

Bildschirmfoto 2014-12-16 um 22.54.22.png
Dezember 17, 2014 um 7:00 am #529901

Andreas Neuber
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Vielen Dank für den Screenshot! Gut, die Einstellung stimmt soweit.
Aber das mit den Update-Problemen ist echt eigenartig.

# Wäre es möglich mir Zugangsdaten bereitzustellen?
Ich hab dafür wieder gesichertes Webform eingeblendet, sollte unterhalb meiner Antwort zu sehen sein.

Dezember 18, 2014 um 7:36 am #530679

Andreas Neuber
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Vielen Dank!
Ich hab mir erlaubt ein zusätzliches Backup mit deinem Backup-Plugin anzulegen - sicher ist sicher.

Die Plugins sind jetzt alle up-to-date. Ich hab es per FTP manuell geschafft.

# Falls du dich wunderst warum da jetzt was von "Site registrieren" erwähnt wird. Die neusten WPML Versionen habe eine verbesserte Update-Funktion eingebaut. Damit sind dann all zukünftigen Updates wesentlich leichter.
Mehr Details dazu hier: http://wpml.org/de/faq/so-installieren-sie-wpml/

# Seite: "WPML > Woocommerce-Multilingual"
Ich würde folgendes empfehlen um diese Warning mit dem "product permalink" los zu werden:

> "Settings > Permalinks" auf "Postname" setzen
> dann "WPML > Sprachen > Sprach-URL-Format" auf die erste Option mit "Verzeichnissen" setzen
> und dann "WPML > Woocommerce-Multilingual" auf den "Go to String-Translation" Link klicken
> "product" übersetzen z.B. "produkt"

Check dann nochmal ob für Deutsche Produkte die Englische Übersetzung ohne Probleme angezeigt wird.

Januar 15, 2015 um 11:29 am #543032

Verein

Lieber Andreas, bitte 1000 Mal um Entschuldigung! Ich bin über Weihnachten und Neujahr aus Zeitgründen verschwunden. Mein Problem ist leider nicht gelöst!
Erstmal VIELEN Dank für Deine vorangegangene Hilfe!!!!

Ich habe 2 Fehlermeldungen bekommen: das Backup (danke übrigens für die Mühe!) ist leider fehlgeschlagen.

Die Anleitung aus Deiner letzten Nachricht (bei mir ist alles auf Deutsch eingestellt, liegt es daran) konnte ich nicht umsetzen. Was jetzt aber wirklich ein Problem ist: ich kann plötzlich auf die Produktseite in Englisch überhaupt nicht mehr zugreifen, noch sie verändern - im Woocommerce. Im Anhang hab ich versucht als Beispiel eine deutsche Seite mitzuschicken: wenn ich auf DE ein Produkt bearbeite zeigt es mir 2 Texteingaben, Produktgallerie, usw. -- klicke auf Bearbeiten der Englischen Version komme ich plötzlich zu WPML und kann nichts mehr ändern, - es wird nicht diese Bearbeitungs-Seite angezeigt sondern - siehe zweites Image: eine WPML Seite. Die Texte - auch wenn ich auf bearbeiten gehe und ok drücke, kann ich nicht ändern. Oje oje ;-/
Hast Du eine Ahnung?
Danke jetzt schon für Deine Hilfe!
Maria

Bildschirmfoto 2015-01-15 um 12.27.01.png
Bildschirmfoto 2015-01-15 um 12.20.07.png
Januar 16, 2015 um 8:28 am #543615

Verein

Lieber Andreas, guten Morgen! Ich schicke Dir hier noch 3 Screenshots um das (zusätzlich aufgetretene) Problem "einfacher" zu erklären: 1 = die Konfigurationswarnung, 3=wenn ich die Englische Prooduktseit bearbeiten möchte klicke ich hier (siehe Bild) und anstatt der zu bearbeitenden Seite kommt Bild 2 - und ich kann nichts an der Übersetzung mehr ändern. Das ging anfangs: jetzt ist irgendwas umgestellt, es geht nicht mehr ;-/ Ich wollte Dir auch mitteilen, dass ich ab Montag unterwegs bin und noch organisieren muss wie ich zu einem Internet komme, falls wir uns vorher nicht mehr "lesen".
Danke für Deine Antwort & Hilfe! Liebe Grüße! Maria

3.png
2.png
1.png
Januar 16, 2015 um 3:48 pm #544041

Denise

Hallo Maria,

iche werder dir weiter damit helfen denn Andreas ist jetzt beschäftig in einen anderen Bereich.

1. Kannst du entweder diese Konfigurationswarnung entlassen oder deine string "Product" übersetzen. (seh Bild 1) Es ist eigentlich egal weil deine Produkt URL's funtionieren in beide Deutsch und English.

2. Das passiert wenn das Original Artikel bearbeitet war.Du darfst deine Produkt Inhalte bearbeiten aber in WooCommerce Multilingual Produkte Format (seh Bild 2) Um das zu ändern bitte geh mal in WPML - WooCommerce Multilingual - Allgemeine Einstellungen - Produkt-Übersetzungsoberfläche und "Gehen Sie zum nativen WooCommerce-Produktbearbeitungsbildschirm" wählen. (seh Bild 3)

Danke,
Denise

1.png
2.png
3.png
Januar 18, 2015 um 9:51 am #544444

Verein

Liebe Denise,

vielen Dank!!!!
Ich bin nun voraussichtlich 5-6 Wochen ohne Internet, ich werde alles mal so machen und ggf. später einen neue Anfrage machen!

Danke inzwischen und liebe Grüße!
Maria