Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Schlagwörter: 

This topic contains 7 Antworten, has 2 Teilnehmer.

Last updated by guidoM-3 vor 5 Monate, 3 Wochen.

Assigned support staff: Marcel.

Autor Beiträge
April 27, 2019 um 4:30 pm

guidoM-3

Ich versuche: EIne funktionierende Staging Seite per BackupBuddy auf demselben Server zu installieren

URL der/meiner Website, auf der das Problem auftritt:
werusys.de bzw. werusys.voltaire.graphics
Erwartet hatte ich zu sehen: EIne funktioniernde Seite

Stattdessen bekam ich:WSOD

April 29, 2019 um 7:38 am #3700653

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Guido

Vielen Dank, dass Sie den WPML Support kontaktiert haben. Um zu prüfen, ob das Problem von WPML verursacht wird, empfehle ich Ihnen folgendes:

1. PHP Debugging aktivieren und auf PHP Fehler überprüfen

Dazu bitte die wp-config.php Datei öffnen und nach folgender Zeile suchen:

define('WP_DEBUG', false); 

Diese bitte auf foldene Werte ändern. Damit wird das Debugging aktiviert sowie die Logausgabe gesteuert:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', true ); 

Es werden dann etwaige Fehler auf direkt auf der Seite angezeigt und eine "debug.log" Datei unter /wp-content/ geschrieben.

Anbei eine Dokumentation (in Englisch):
https://codex.wordpress.org/Debugging_in_WordPress

2. PHP Speichergrenze (MemoryLimit) erhöhen

Könnten Sie bitte Ihre WordPress-Speichergrenze (WP Memory Limit) auf mindestens 256 MB erhöhen? Für WPML ist mindestens 128M erforderlich. Sie verwenden momentan 40MB.

Fügen Sie diesen Code Ihrer wp-config.php hinzu, um den Arbeitsspeicher von WP zu erhöhen:

define ('WP_MEMORY_LIMIT', '256M'); 

Fügen Sie es kurz vor:

/ That's all, stop editing! Happy blogging. / 

Bitte geben Sie mir Bescheid, welche Fehler Sie im Log lokalisieren konnten.

Freundliche Grüße
Marcel

April 29, 2019 um 8:43 am #3701195

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Nachtrag: Könnten Sie bitte auch die Debug Information anhängen, falls das Memory Limit das Problem nicht löst? Vielen Dank!

https://wpml.org/de/faq/so-liefern-sie-fehlerbehebungsinformationen-fuer-schnelleren-support/

April 29, 2019 um 2:40 pm #3704461

guidoM-3

Hallo Marcel

danke schonmal.

Leider sehe ich keinerlei Log obwohl ich den Debug Modus aktiviert habe.

Ich hänge privat einen Admin Zugang zur Hauptseite an die bisher nicht on war.

Hier besteht das Problem auch nach dem einfüger der Codezeile zum erhöhen des WP_MEMORY_LIMIT auf 256 MB weiter. Ist das das gleiche wie das PHP_MEMORY_LIMIT?
Entschuldige die Naive Frage.

Sobald ich das WPML Hauptplugin aktiviere > WSOD.

Merkwürdigerweise wie gesagt nur hier. Auf der Staging die auf dem gleichen Server läuft funktioniert alles problemlos. Also kann es doch an der Serverkonfiguration nicht liegen, oder?

Brauchst Du noch einen FTP Zugang?

April 29, 2019 um 2:42 pm #3704513

guidoM-3

Hm, wo ist denn die Option für private Informationen?

April 29, 2019 um 3:51 pm #3705191

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Guido,

ich habe nun dafür ein privates Feld aktiviert.

Ich bräuchte bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

April 30, 2019 um 7:56 am
April 30, 2019 um 3:08 pm #3712643

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Guido,

das Debugging ist zwar aktiv, ich habe jedoch keine ausreichende Rechte um zum Test eine debug.log anzulegen. Es sieht aus, als ob der Server kein Recht hat diese Datei anzulegen (CHMOD). Fragen Sie dazu bitte direkt beim Webhoster nach, eventuell kann dieser etwas einstellen.

Ich habe ähnliche Meldungen zu BackupBuddy gefunden. Der Fehler kann durch folgenden Log Eintrag ausfindig gemacht werden:

Fatal error: method_exists(): The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition "unknown" of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide an autoloader to load the class definition in /public/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-templates.php on line 304 

Siehe: https://wpml.org/forums/topic/blank-page-after-migrate-with-backupbuddy-2/#post-3530205

#1 Können Sie bitte mit Ihrem Hoster feststellen, ob das Log identisch ist, wenn Sie es generieren können?
#2 Können Sie bitte folgenden Workaround ausprobieren?

https://wpml.org/forums/topic/wpml-preventing-backupbuddy-managewp-from-restoring-backups/page/2/#post-3114186

Bitte geben Sie mir Bescheid, ob es geklappt hat, dann füge ich Ihre Ticket an das bereits bestehende Entwicklungsticket dran.

Freundliche Grüße
Marcel

Mai 1, 2019 um 9:44 am #3717287

guidoM-3

Hallo Marcel

das Löschen des Datenbankeintrages "wpml_language_switcher" war die Lösung.

Ich mußte lediglich den Switcher im Menu neu einrichten und dann lief es.

Danke!

Weiss iThemes von dem Bug?

Beste Grüße

Guido