Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This thread is resolved. Here is a description of the problem and solution.

Problem:
Meine String Übersetzung des "Speed Contact Bar" Plugins wird nicht angezeigt.

Solution:

Es werden von Speed Contact Bar die Optionen zu früh abgerufen. Bitte ändern Sie wp-content/plugins/speed-contact-bar/public/class-speed-contact-bar.php Zeile 349:
von

$this->stored_settings = $this->get_stored_settings();

zu

		add_action ('init', function(){
		$this->stored_settings = $this->get_stored_settings();
		});

Nachtrag: 10/09/2019. Der Plugin Autor hat diesen Workaround in die Version 6.0.5 integriert. Mit dieser Version sind keine manuellen Anpassungen im Plugin notwendig.

Schlagwörter: 

This topic contains 9 Antworten, has 2 Teilnehmer.

Last updated by Marcel vor 1 Monat.

Assigned support staff: Marcel.

Autor Beiträge
August 26, 2019 um 1:23 pm #4459175

erwinL-4

Habe noch ein anderes Probelm, auf der Seite ist das Plugin speed contact bar im Einsatz. Hier habe ich ebenfalls die wpml-config.xml wie folgt angepasst:
<wpml-config>
<admin-texts>
<key name="speed-contact-bar-options">
<key name="address" />
<key name="phone_text" />
<key name="address_url" />
<key name="email" />
<key name="email_text" />
</key>
</admin-texts>
</wpml-config>

Ich sehe dann zwar die zu übersetzenden Strings, diese wurden auch übersetzt (hidden link), jedoch bleibt auf der it Seite nach wie vor alles auf deutsch. Ist die Datei so korrekt? Oder wo könnte der Fehler liegen?

Viele Grüße
Martin

August 26, 2019 um 1:27 pm #4459193

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Martin,

Ich würde mir das gerne direkt auf Ihrer Seite ansehen und das XML validieren. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

August 26, 2019 um 5:42 pm #4460619

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Martin,

ich habe das XML auf der Testseite hinzugefügt und es hat korrekt validiert sowie die Texte in der String Translation Tabelle sichtbar gemacht. Jedoch kann es hier ebenso nicht im Frontend angezeigt werden.

Können Sie bitte versuchen Ihre PHP Einstellung "max_input_vars" über die php.ini von 3000 auf 10000 zu erhöhen? Falls Sie darauf keinen Zugriff haben, kontaktieren Sie bitte Ihren Hoster.

Doku: hidden link

Freundliche Grüße
Marcel

August 26, 2019 um 6:09 pm #4460765

erwinL-4

Hallo Marcel,

den Wert habe ich in der htacess auf 10000 erhöht und dann erneut versucht zu übersetzen...leider ohne Erfolg.

Viele Grüße
Martin

August 27, 2019 um 9:38 am #4464451

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Martin,

dieses Plugin wurde bisher von uns nicht getestet. Ich habe nun eine Testinstallation aufgesetzt. Können Sie bitte versuchen das Problem hier nachzustellen?

hidden link

Wenn Sie es nachstellen können, kann ich mit der Testinstallation den Fall an unser Kompatibilitäts-Team weitergeben, welches versuchen wird den Plugin Autor zu kontaktieren.

Sie können diesen ebenso gerne in unser Go-Global Programm einladen. Hier helfen wir dem Autor sein Plugin multilingual zu machen.

Freundliche Grüße
Marcel

August 27, 2019 um 5:44 pm #4468765

erwinL-4

Hallo Marcel,

auf der Testseite habe ich bei String Tranlation die Übersetzungen hinzugefügt it en.
Die wpml-config.xml Datei im Plugin habe ich nicht angepasst, da ich keinen ftp Zugang habe.

Viele Grüße
Martin

August 28, 2019 um 12:50 pm #4474319

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Martin,

vielen Dank. Die XML Konfig hatte ich bereits in der XML Option in den Einstellungen aktiv. Das Plugin übernimmt somit die Übersetzungen nicht. Ich habe den Fall nun an unserer Kompatibilitäts-Team weitergegeben. Die werden versuchen eine Lösung dafür zu finden, sowie ggf. den Plugin Author kontaktieren.

Um diesen Prozess zu beschleunigen können Sie gerne wie oben erwähnt den Autor in unser Go-Global Programm einladen: https://wpml.org/documentation/theme-compatibility/go-global-program/

Ich gebe Ihnen Bescheid, sobald ich von meinen Kollegen eine Rückmeldung dazu erhalte.

Freundliche Grüße
Marcel

August 28, 2019 um 2:38 pm #4475161

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Martin,

wir haben bereits eine Lösung. Siehe hidden link

Und zwar werden von Speed Contact Bar die Optionen zu früh abgerufen. Bitte ändern Sie wp-content/plugins/speed-contact-bar/public/class-speed-contact-bar.php Zeile 349:

von

$this->stored_settings = $this->get_stored_settings();

zu

		add_action ('init', function(){
		$this->stored_settings = $this->get_stored_settings();
		});

Dies löst das Problem.

Freundliche Grüße
Marcel

August 29, 2019 um 8:57 am #4478821

erwinL-4

My issue is resolved now. Thank you!

September 10, 2019 um 1:11 pm #4545605

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Erwin,

kurzes Update zum erledigten Ticket: Der Autor hat uns geantwortet und unseren Fix in die Version 6.5.0 übernommen.

Freundliche Grüße
Marcel