Skip Navigation

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

This topic contains 12 respuestas, has 2 mensajes.

Last updated by macarenaM hace 4 years, 11 months.

Assigned support staff: Otto.

Autor Mensajes
noviembre 19, 2015 a las 10:45 am #749968

macarenaM

Hola, al activar el plugin WooCommerce Multilingual el sitio en el que estoy trabajando se va a blanco. Su url es hidden link

He comprobado que ocurre lo mismo con el tema twenty twelve. Desactivando todos los plugins a excepción de los del pack wpml el error persiste. Si instalo y activo uno por uno, veo que el problema ocurre al activar el WooCommerce Multilingual, si bien si no activo el WPML String y sí el de la traducción para el del comercio electrónico (que no está operativo al faltarle el primero) no genera error.

Con el modo debug activado, el mensaje de error es el siguiente: Fatal error: Call to undefined function wc_get_page_id() in /srv/data/web/vhosts/www.artedifusion.com/htdocs/wp-content/plugins/woocommerce-multilingual/inc/store-pages.class.php on line 38

Espero puedan ayudarme lo antes posible,

Muchas gracias

Maki

noviembre 19, 2015 a las 12:12 pm #750096

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola Maki,

Gracias por contactarte con el foro de soporte!

Para poder ayudarte mejor, podrías proveerme la información de WPML Debug?
http://wpml.org/faq/provide-debug-information-faster-support/
He habilitado los campos necesarios para que lo hagas en tu próxima respuesta.

Quedo a la espera de tu información.

Un saludo cordial

noviembre 19, 2015 a las 12:31 pm #750131

macarenaM

En el mensaje tiene la información que me solicita,

gracias.

noviembre 19, 2015 a las 5:11 pm #750475

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola Maki,

Por favor, podrías por favor incrementar la memoria a 256MB:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Tienes configurado 40M y el mínimo requerido es 128M.

Si el problema persiste, para poder investigar mejor el problema necesitaría, si fuera posible, que me permitas acceder a tu sitio temporalmente. Mucho mejor si tuvieras un sitio de pruebas en donde esté replicado el problema.

Encontrarás los campos necesarios debajo del área de comentarios. He marcado la próxima respuesta como privada, por lo que la información que ingreses solo la veremos tu y yo.

Por favor, realiza un backup completo de tu sitio.

Muchas gracias.

Es posible que necesite replicar tu sitio localmente. Para eso voy a necesitar instalar un plugin llamado "Duplicator". Con él podré crear una copia completa de tu web. Una vez que el problema esté resuelto, borraré la copia local. Dime por favor si estás de acuerdo.

Un saludo cordial

noviembre 20, 2015 a las 11:11 am #751085

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Muchas gracias por los datos de acceso.

Antes de ingresar al sitio, por favor prueba con la última versión de WooCommerce Multilingual (3.7.4), acaba de salir y soluciona unos cuantos problemas.

Dime si esta nueva versión funciona correctamente en tu sitio por favor.

Un saludo cordial

noviembre 20, 2015 a las 11:54 am #751120

macarenaM

Hola,
¿has llegado a entrar en la web? Ahora mismo me da un error 500 del servidor y necesito depurar un poco las causas...

Gracias.

noviembre 20, 2015 a las 12:20 pm #751155

macarenaM

Solucionado el errro del servidor, ahora pruebo con la actualización del plugin woocommerce multilingual y te cuento...

noviembre 20, 2015 a las 1:30 pm #751245

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

No, no había entrado. Pero me alegro que se haya solucionado el error 500 🙂

Quedo a la espera de tus resultados luego de la actualización.

Un saludo cordial

noviembre 20, 2015 a las 1:44 pm #751259

macarenaM

Lo siento, no logro descargar la versión 3.7.4, quizás sea debido a un exceso de peticiones...

noviembre 20, 2015 a las 1:55 pm #751267

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Yo he podido descargarlo desde aquí:
https://wordpress.org/plugins/woocommerce-multilingual/

Y lo he subido aquí:
hidden link

Prueba alguna de estas opciones y dime cómo resulta.

Un saludo cordial

noviembre 20, 2015 a las 1:59 pm #751271

macarenaM

Desde wordpress.org sí que he podido descargar, gracias. Pero al activar me vuelve a suceder lo mismo, la página se va a blanco.

Desinstalo para que puedas entrar.

noviembre 20, 2015 a las 6:51 pm #751604

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Muchas gracias.

He hecho una copia local de tu sitio.

En ella, primero actualicé WooCommerce a su última versión. Una vez hecho esto, instalé WooCommerce Multilingual 3.7.4 y no observo ningún error.

Por favor pruébalo en tu sitio y dime si funciona (haz un back up antes de hacerlo)

Un saludo cordial

noviembre 21, 2015 a las 10:58 am #751823

macarenaM

Hola,

con la actualización de WooCommerce parece que todo funciona bien.

Muchas gracias por la atención,

saludos¡