Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 1.52 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

El problema: No coge ningún estilo y estructura de la versión en español.

La solución: - Sigue las instrucciones de la Errata a continuación.

Documentación: https://wpml.org/errata/elemntor-page-layout-is-not-duplicated-to-the-secondary-language-page/

This topic contains 7 respuestas, has 2 mensajes.

Last updated by asociaciOn-colombiana-de-unive hace 2 meses, 1 semana.

Assigned support staff: Andrés.

Autor Publicaciones
agosto 7, 2019 a las 1:52 am

asociaciOn-colombiana-de-unive

Estoy tratando de: traducir todo el sitio y no funciona correctamente, solo he hecho 2 páginas y una de ellas llamada "Objetivos" no coge ningún estilo y estructura de la versión en español. No hice mas paginas ya que no funciona correctamente. Ver link abajo

URL donde aparece el problema: hidden link

Yo esperaba ver: que la versión en ingles fuera igual a la de español con todos los elementos de la plantilla.

La plantilla sobre la cual esta montado el site es hidden link

Adicionalmente sale este warning en wordpress:

"There is a problem with the String Translation table in your site. This problem is not causing a problem running the site right now, but can become a critical issue in the future. WPML support team knows how to fix it. Please add a message in the relevant support thread and we'll fix it for you."

Favor ayudar a resolver estos 2 temas. gracias

agosto 7, 2019 a las 5:13 am #4352093

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

1. Acabo de visitar tu sitio y veo que lo has creado con el plugin Elementor. Para que lo puedas traducir fácilmente, necesitas instalar adicionalmente nuestro WPML String Translation:
https://wpml.org/documentation/plugins-compatibility/elementor/

Una vez lo hagas, sigue las instrucciones de esta errata para que todos los estilos se copien correctamente:
https://wpml.org/errata/elemntor-page-layout-is-not-duplicated-to-the-secondary-language-page/

2. Para asegurarnos que WPML funcione correctamente, ¿podrías incrementar la Memory Limit y WP Memory Limit a 256M? Si puedes suministrar más recursos, sería ideal.
Tus valores actuales son:
- MemoryLimit 256M
- WP Memory Limit 40M
https://wpml.org/home/minimum-requirements/

Edita tu archivo wp-config.php y agrega la siguiente línea:

define('WP_MEMORY_LIMIT', '256M');

Muchas veces estos ajustes son bloqueados directamente desde la administración de tu hosting. En ese caso te recomiendo que los contactes directamente y si puedes pedir valores superiores a 128M, sería recomendable.

Nota: 128M es el mínimo necesario para WPML sin otros plugins y con un tema por defecto de WordPress.

Un saludo,
Andrés

agosto 7, 2019 a las 10:06 pm #4358459
asociaciOn-colombiana-de-unive

Hola Andrés, voy a intentar hacer lo que indicas. Pero otro lado no mencionar como se soluciona este warning que apareció justo despues de instalar el string translation. Yo lo desinstalé pensando que asi se quitaba el warning pero no pasó, ahi sigue.

There is a problem with the String Translation table in your site. This problem is not causing a problem running the site right now, but can become a critical issue in the future. WPML support team knows how to fix it. Please add a message in the relevant support thread and we'll fix it for you.

Los hilos nuevos creados por Andrés y vinculados a este se encuentran a continuación:

https://wpml.org/es/forums/topic/split-al-traducir-una-pagina-se-pierden-los-estilos-imagenes-y-estructura-de-plantill/

agosto 7, 2019 a las 11:42 pm #4358587

asociaciOn-colombiana-de-unive

Hola, ya le incrementé la memoria a 256M, pero aun tengo problemas para traducir la 1er página, no copia estilos, ni imagenes ni nada a la versión de inglés.

Instalé el WPML Translation Management para probar y configuré el advance editor, pero es horrible, no funciona. No encuentro como ponerlo como editor clásico, asi que desactivé ese plugin. sigo sin poder hacer 1 traducción. y el warning del string translation sigue apareciendo en rojo arriba.

Favor ayuda, pq nada funciona como debería.
Gracias

agosto 8, 2019 a las 5:45 am #4359819

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

En el ticket que abrí solucioné tu problema relacionado con tu alerta ya que solo podemos manejar un problema por ticket.

Ahora bien, he activado el Editor clásico y seguido las instrucciones de la errata para traducir la página objetivos y todo funciona correctamente. ¿Podrías verificarlo?

Saludos

agosto 8, 2019 a las 2:49 pm #4364025
asociaciOn-colombiana-de-unive

Buen día Andrés,

Parece que ya funciona correctemente. Tengo 2 preguntas:

1. Arriba sale un aviso o boton que dice:
"Un paso más antes de que pueda traducir al Elementor
Para traducir correctamente, active el Editor de traducción de WPML. [ACTIVAR]"

¿que hago?

2. ¿Es posible cambiar la bandera de españa por una colombia que indique el idioma español?

Los hilos nuevos creados por Andrés y vinculados a este se encuentran a continuación:

https://wpml.org/es/forums/topic/split-al-traducir-una-pagina-se-pierden-los-estilos-imagenes-y-estructura-de-plantill-2/

agosto 8, 2019 a las 5:13 pm #4364985

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Me alegra saber que tu problema inicial ha sido resuelto. 🙂

Por esta razón he vuelto a abrir un nuevo ticket, ¿podrías continuar en él y cerrar los otros que tienes abiertos?

Saludos

agosto 8, 2019 a las 6:24 pm #4365369

asociaciOn-colombiana-de-unive

My issue is resolved now. Thank you!