Skip Navigation

Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en los foros 6 días a la semana, 22 horas por día.

Autor Mensajes
octubre 31, 2019 a las 5:59 am

pilarM-4

Estoy tratando de: traducir cadenas woocommerce y de la plantilla instalada

URL de (mi) sitio web donde aparece el problema: piliferrer.com

Yo esperaba ver: las cadenas traducidas

En vez de eso, obtuve:
Algunas cadenas del dominio "woocommerce" no se traducen correctamente. Originariamente son del idioma "Inglés" pero no traducen correctamente al idioma predefinido del WP Español. Sí lo hace al tercer idioma "catalán".

octubre 31, 2019 a las 4:16 pm #4866035

pilarM-4

Hola, alguna solución?
Gracias

noviembre 4, 2019 a las 7:24 am #4878265

pilarM-4

Buenos días, alguna solución? Gracias

noviembre 4, 2019 a las 8:22 am #4878495

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Muchas gracias por contactar con el servicio de soporte de WPML.

Perdone la demora en el mensaje pero hemos tenido un aumento inusual en la cantidad de tickets y estamos haciendo todo lo posible por resolverlos lo antes posible. Muchas gracias por su comprensión.

1.- He revisado el sitio y al entrar en WPML -> Idiomas -> Justo debajo de la sección "Formato URL del idioma" puedo ver el siguiente mensaje de error:
"Notice: Undefined property: stdClass::$depth in /home/piliferr/public_html/wp-content/plugins/ovic-addon-toolkit/includes/extends/megamenu/includes/megamenu-settings.php on line 422"

Por favor contacte con los autores de dicho plugin y hágales saber que está ocurriendo este problema.

2.- Con respecto a la traducción de las cadenas, le pido que realice los siguientes pasos:
- Ve a WPML -> Traducción de cadenas -> Busque las cadenas -> Selecciónelas y bórrelas.
- Ve a WPML -> Localización de temas y plugins -> Escanea Woocommerce y el tema activo.
- Ve a WPML -> Traducción de cadenas -> Vuelve a traducir las cadenas.

Me puede decir el resultado de los pasos anteriores?

Saludos,
Carlos

noviembre 4, 2019 a las 9:12 am #4878901

pilarM-4

Hola Carlos,
Gracias por la respuesta.
Ya he comunicado el error al autor del plugin.

De otro lado, entiendo que ¿se tendrán que volver a traducir todas las cadenas que están fallando.? En este momento fallan algunas, no todas, en el idioma principal (español). En la versión en catalán sí que funcionan correctamente.
Hay alguna manera de saber que cadenas fallan para no tener que actualizarlas todas. Entiende que muchas cadenas tan solo se activan en situaciones "menos normales".
Gracias
Saludos

noviembre 4, 2019 a las 9:39 am #4879251

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Muchas gracias por su mensaje.

Perdón si no me expliqué correctamente. Las cadenas a las que me referí en mi mensaje anterior y que recomendé borrar son solamente las dos que tienen el problema. Las otras cadenas del sitio no hace falta tocarlas.

Saludos,
Carlos

noviembre 4, 2019 a las 11:20 am #4880281

pilarM-4

El problema está es que es muy difícil saber cuantas cadenas fallan. No solo son dos, hay muchas más. El problema es investigar cuales son las que fallan si no te las encuentras directamente en la navegación, ya que algunas están bastante escondidas y responden a ciertas acciones no tan frecuentes.

noviembre 4, 2019 a las 11:40 am #4880451

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,

Entiendo lo que me plantea, sin embargo el problema original menciona dos cadenas y me gustaría comenzar a resolver el problema de ambas cadenas antes de pasar al resto.

Saludos,
Carlos

noviembre 4, 2019 a las 11:51 am #4880515

pilarM-4

Ok. He realizado el proceso con las Cadenas "New" y "Search here ..." del domino "kute-boutique".
Ninguna de las dos han funcionado en la versión "español" (idioma principal).

P.D: Te recuerdo que estoy a la espera de la actualización del Plugin "Yoast SEO Multilingual" versión 1.0.2. Actualmente tengo instalada la 1.0.1 porque la semana pasada vosotros encontrásteis un bug en el plugin. Incidencia: #484387

noviembre 4, 2019 a las 12:48 pm #4881031

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,

He aplicado varias pruebas pero el problema persiste. Sospecho que la causa del problema es que el tema no es compatible con WPML. Puede verificar que no aparece en nuestro listado de temas compatibles: https://wpml.org/es/documentation-2/compatibilidad-del-tema/

En este caso he creado un sitio de pruebas con WPML instalado y configurado al que puede acceder a través de este enlace: hidden link

Le pido que realice los siguientes pasos:
- Acceda al sitio de pruebas -> Active y configure Woocommerce y Woocomerce Multilingual (ya están instalados).
- Instale y configure el tema -> Intente reproducir el problema de las dos últimas cadenas "New" y "Search here ..."

Me puede decir si el problema persiste?

Saludos,
Carlos

noviembre 4, 2019 a las 2:15 pm #4881953

pilarM-4

Hola Carlos,
El tema es compatible con WPML. Directamente funcionaba a la perfección hasta que actualizasteis la versión 1.0.1 del "Yoast Seo Multilingual" a la 1.0.2 (con bugs reportados por múltiples clientes vuestros y nos dijeron que la nueva versión estaría en los próximos días. Tienes los hilos disponibles en el número de incidencia que te he pasado). A partir de aquí empezó a fallar todo. Andrés, que fué el que me dió soporte me dijo que volviera a la versión 1.0.1. Pero las cadenas empezaron a fallar (tan solo en la versión española).

De otro lado, el tema del sitio de pruebas no sé ni como tengo que hacerlo.

noviembre 4, 2019 a las 2:53 pm #4882359

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,

Usted tiene alguna copia de seguridad del sitio antes de la actualización de Yoast SEO Multilingual? Si la tiene me gustaría pedirle que la restaure y me diga si el problema persiste.

En caso de que no tenga una copia de seguridad o de que no pueda restaurarse entonces le pido su autorización para realizar una copia del tema e instalarlo en el sitio de pruebas.

Saludos,
Carlos

noviembre 4, 2019 a las 3:48 pm #4882811

pilarM-4

Sí, puedo restaurar días atrás.
Pero como ya la tengo visible al cliente y promocionando en redes sociales quizás la mejor opción es la segunda. En este caso le autorizo ha hacer la copia al sitio de pruebas.
Gracias.

noviembre 4, 2019 a las 4:04 pm #4882963

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hola,
Muchas gracias por su autorización.

Ya he instalado el tema en el sitio de pruebas. Le pido que acceda al sitio de pruebas, termine de configurar el tema y me diga si persiste el problema con las cadenas.

Saludos,
Carlos

noviembre 5, 2019 a las 7:22 am #4886023

pilarM-4

Buenos días Carlos,
He probado en el sito de pruebas y funciona correctamente. Fíjate que el menú superior izquierda de "usuaria" está correctamente traducido. En mi web la versión española despareció en ese proceso que te comenté ayer. En tu sitio de pruebas funciona perfectamente.
Luego he generado cadenas para la plantilla que instalaste ayer y he traducido la cadena "Last Post". Como ves en en la captura funciona perfectamente, también en la de catalán.

Es evidente que no es problema de la pantilla.

P.D. Otra cosa que detecté cuando instalé la 1.0.2 es que productos del Woocommerce no relinkaban correctamente a su traducción, todo y que aparecían bien linkadas. Lo solucioné modificando los enlaces del padre y de los hijos.
Por ejemplo:
El producto hidden link empezó a relinkar hacia hidden link (Producto no existente, vacio).
Para solucionarlo tuve que modificarlo a: hidden link
Así funciona, pero si vuelvo a suprimir el añadido (_esp) me vuelve a relinkar hacia:
hidden link

Volviendo a la 1.0.1 no se ha recuperado.

Gracias.
Saludos.