Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This topic contains 6 respuestas, has 2 mensajes.

Last updated by pilarB-2 hace 3 semanas, 6 días.

Assigned support staff: Andrés.

Autor Publicaciones
septiembre 21, 2019 a las 9:22 am #4615645

pilarB-2

Tenía traducidos los campos del checkout del plugin WooCheckout y al actualizar se han vuelto a poner en español y aunque guarde las traducciones nuevamente no siguen apareciendo algunos campos en español (Nombre, apellidos, país y teléfono)

URL de (mi) sitio web donde aparece el problema: aceitedelcampo.com

septiembre 23, 2019 a las 5:27 am #4620327

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenida al soporte de WPML.

¿Podrías revisar si tu situación se ajusta al caso descrito en el siguiente erratum? Trata de desmarcar la opción que allí se explica y, si es necesario, refresca la traducción de la cadena problema.

¿Soluciona tu problema?

Erratum:
https://wpml.org/errata/string-translations-disappearing-on-sites-where-default-language-is-not-english/

Un saludo,
Andrés

septiembre 23, 2019 a las 12:47 pm #4624063

pilarB-2

Hola, no, no se ajusta al caso. Yo SI que puedo ver las cadenas de traducción pero dicha traducción no se ve reflejado en el front

septiembre 23, 2019 a las 1:56 pm #4624789

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por tus indicaciones, ¿quieres decir que has seguido mis instrucciones anteriores y no ves ningún cambio?

Para asegurarnos que WPML funcione correctamente, ¿podrías incrementar la WP Memory Limit a 512M? Si puedes suministrar más recursos, sería ideal.
Tus valores actuales son:
- MemoryLimit 1024M
- WP Memory Limit 40M
https://wpml.org/home/minimum-requirements/

Edita tu archivo wp-config.php y agrega la siguiente línea:

define('WP_MEMORY_LIMIT', '512M');

Muchas veces estos ajustes son bloqueados directamente desde la administración de tu hosting. En ese caso te recomiendo que los contactes directamente y si puedes pedir valores superiores a 128M, sería recomendable.

Nota: 128M es el mínimo necesario para WPML sin otros plugins y con un tema por defecto de WordPress.

septiembre 23, 2019 a las 2:47 pm #4625173

pilarB-2

Hola, a tu pregunta:
¿quieres decir que has seguido mis instrucciones anteriores y no ves ningún cambio? ---> Lo que quería decir es esa opción ya estaba desmarcada previamente hidden link
He cambiado las traducciones y vuelto a guardarlas y siguen apareciendo los textos en ingles.

He subido el wp_memory_limit a 512M como me has indicado, he probado a volver a guardar las traducciones desmarcando el checkbox Traduccion terminada y volviendo a activar pero el error persiste.

Gracias

septiembre 23, 2019 a las 3:49 pm #4625519

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por la aclaración. Acabo de confirmar que, por ejemplo, la cadena nombre no aparece traducida en ningún idioma:

- Ve a WPML > Traducción de cadenas.
- Elimina la cadena "Nombre".
- Ve a tu plugin y guárdala de nuevo.
- Regresa a la Traducción de cadenas.
- Tradúcela.
Por otra parte, asegúrate que no tengas otras cadenas "Nombre" en el panel de traducción y, si es así, tradúcelas también.

Saludos

septiembre 24, 2019 a las 4:42 pm #4633085

pilarB-2

Gracias Andrés, ya lo he podido traducir todo.