Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This topic contains 19 respuestas, has 2 mensajes.

Last updated by Noman hace 2 meses, 1 semana.

Assigned support staff: Noman.

Autor Publicaciones
junio 30, 2019 a las 6:21 pm #4114747

pabloQ

Hola!

Tengo unas cadenas traducidas del plugin Woocommerce Subscriptions que con alguna de las últimas actualizaciones de WPML han dejado de mostrarse.

En vez de verse en español (la web está únicamente en español), se muestra las cadenas originales en inglés.

Adjunto imagen de lo que se ve en el frontend y de cómo esa string está traducida correctamente (muestra solamente una parte de la original, expresamente).

¿Cuál es el problema? Agradecería una solución.

junio 30, 2019 a las 7:43 pm #4114851

Noman
Supporter

Languages: Inglés (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I am going to reply this in English, if you still need Spanish support please let me know.

Could you please try to re-save the translation:

1. Go to WPML >> String Translation >> Search and Open your translated text >> delete the translation >> Save.

2. Then again go to: String Translation >> Re-add your translated text >> and re-save. Make sure that "Translation is complete" checkbox is selected.

3. Please delete all sorts of caches on your site / server cache if any / plugin cache / CDN cache (if any), clear browser cache and then see if it resolves the issue afterwards. You can also disable cache plugin temporary while you update this string.

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

julio 1, 2019 a las 5:05 am #4115597

pabloQ

Hi Norman,

Thank you for your message.

I've followed your instructions (website has WP Rocket plugin) but issue isn't solved.

Would appreciate any help.

julio 1, 2019 a las 8:27 am #4116501

Noman
Supporter

Languages: Inglés (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

julio 2, 2019 a las 5:37 am #4124115

pabloQ

Hi Noman!

Migration has been completed.

julio 2, 2019 a las 6:43 pm #4129461

Noman
Supporter

Languages: Inglés (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for Moving your site to cloud server. To narrow down this issue, I had deactivated your current theme and activated Twenty Seventeen theme. Then I refreshed frontend page of your site and found out that particular string was disappeared.

I tried to activate previously activated theme but page layout and string wouldn't appeared.

Now I’ll again migrate your site and debug this issue.

Thank you for your cooperation and patience.

julio 2, 2019 a las 6:57 pm #4129575

pabloQ

Hi Norman!

OK, I'll wait for your next message then.

Regards

julio 4, 2019 a las 6:26 pm #4145815

Noman
Supporter

Languages: Inglés (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have followed below steps in cloud server:

1. Went to WPML >> String Translation >> Search and Open your translated text >> delete the translation >> Save.

2. Re-scan “woocommerce-subscriptions” plugin from WPML >> Theme and plugin localization.

3. Then again went to WPML >> String Translation >> Re-add your translated text >> and re-save.

And now string is showing correct translation at frontend of your site as you can see in the attached screenshot.

Here is the link:
hidden link

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

julio 5, 2019 a las 6:11 am #4147883

pabloQ

Hi Noman,

Thanks for your message.

It does NOT solve the issue as I can't replicate.

I've proceeded to follow your instructions and took the string shown within the image as the 'test string'. But still original string shows.

I could be because of me, I don't know anymore. Is there a video that shows your steps?

On the other hand, I've changed option of Localisation as shown in image wpml1.jpg from 1 to 2, as I need admin panel to be shown in Spanish.

What can I do? Everything was fine until one of WPML updates.

I'm considering quiting WPML and going back to .po/.mo translations...

julio 7, 2019 a las 5:13 pm #4158015

Noman
Supporter

Languages: Inglés (English )

Timezone: Asia/Karachi (GMT+05:00)

Sorry for the delay, I ran into my weekend, my off days are Friday and Saturday. I am going to check this issue further and let you know my findings soon.

Thank you for your cooperation and patience.

julio 8, 2019 a las 4:56 pm #4164425

Noman
Supporter

Languages: Inglés (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I am attaching screenshots of steps that I followed to translate that string in cloud server.

1. Removed existing translation:
Went to WPML >> String Translation and searched ‘%1$s with %2$s free trial’ string and delete the translation.

2. Re-scan plugin:
Went to WPML >> Theme and plugin localization and selected “woocommerce-subscriptions” plugin and pressed ‘Scan selected plugins for strings’ button.

3. Re-add Translation:
Went to WPML >> String Translation and searched ‘%1$s with %2$s free trial’ string and added this text “%1$s con %2$s prueba gratis” as translation.

You can test that string by using the link below and review the changes in frontend.

Backend link:
hidden link

Frontend link:
hidden link

Thank you

julio 10, 2019 a las 5:50 am #4176231

pabloQ

Hi Noman,

First of all, thank you for message and your explanation with screenshots.

I've followed your instructions step by step but still translation doesn't show up on frontend.

I've clicked on all options within WPML > Soporte > Solucionar de problemas, with no effect. I've even removed cache when there's no need (cache is not applied to admins), with no effect.

Can you try to follow these steps into production site? How can we resolve it?

julio 11, 2019 a las 7:50 am #4186871

Noman
Supporter

Languages: Inglés (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have also tried the same steps in your site but translation not showing at frontend. I have compared both (cloud and your’s) servers settings and found below differences. Could you please follow below steps and see if this resolves your issue.

- Please increase MaxInputVars to 10000 or more. For this, please try to set these variables in your php.ini:

max_input_vars = 10000;
suhosin.post.max_vars = 10000;
suhosin.request.max_vars = 10000;

You may need to contact your hosting provider to set them.

- Please downgrade PHP to 7.1.30. You can contact your website hosting company to do this for you.

Please let me know the results,

Thank you

julio 15, 2019 a las 5:38 am #4207231

pabloQ

Hi Noman,

Thank you for your message and sorry for my delay.

I've downgraded PHP version and added the PHP variables you mention in a php.ini file.

Then I've repeated the process you told me before but still translation doesn't show up.

I upload an image so you can see that variables were changed. I've finally uploaded PHP to the last version.

What can be done?

julio 16, 2019 a las 3:02 pm #4221469

Noman
Supporter

Languages: Inglés (English )

Timezone: Asia/Karachi (GMT+05:00)

I have now escalated this issue to our 2nd tier support for further review and we will get back to you with an update.

Thank you for your cooperation and patience.

El debate ‘[Cerrado] Cadenas traducidas no se muestran’ está cerrado y no admite más respuestas.