Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Etiquetado: 

This topic contains 4 respuestas, has 2 mensajes.

Last updated by Carlos Rojas hace 5 meses, 2 semanas.

Assigned support staff: Carlos Rojas.

Autor Publicaciones
junio 5, 2019 a las 8:18 am #3958047

eduardoR-3

Hola,
Tengo instalado el idioma Portugués, y las URL las crea con pt-pt.
Me gustaría que solo apareciera pt.

He seguido las indicaciones de este hilo:
https://wpml.org/forums/topic/how-can-i-change-the-pt-pt-in-the-url-to-be-only-pt/#post-1516916

Todo bien, excepto que ahora me aparece el mensaje siguiente:

WordPress no puede descargar traducciones automáticamente para los siguientes idiomas:

Portugués (región actual: pt) - regiones sugeridas: pt_BR, pt_PT_ao90, pt_PT
Para solucionarlo, abra "Edit Languages" y defina los valores de "configuración regional predeterminada" como se muestra arriba.

Si voy a Edit Language y modifico "configuración regional predeterminada" con pt_PT, no se guarda la configuración y aparece el error:
La configuración local predeterminada ya existe.

He restaurado la copia de base de datos que tenía así que si hay una solución mejor, puedo repetir los pasos de nuevo.

Saludos,

junio 5, 2019 a las 2:35 pm #3961523

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por contactar con el servicio de soporte de WPML.

Me gustaría pedirle que realice los siguientes pasos:
- Cree una copia de seguridad del sitio completo antes de realizar cualquier cambio.
- Actualice todos los temas y plugins, especialmente los plugins de WPML. Funcionalidades desactualizadas pueden causar conflictos en el código.
- Borre cualquier memoria cache que pueda existir.

Me puede decir si el problema persiste?

Saludos cordiales,
Carlos

junio 6, 2019 a las 10:31 am #3968227

eduardoR-3

Hola Carlos,
He actualizado todos los plugins, y además he hecho un reset de WPML ya que, por otros motivos, quería empezar de zero. No utilizo ningún plugin de caché.

Al definir de nuevo los idiomas de la web, el Portugués lo he agregado directamente de manera manual, y sigue saliendo el mismo error y no guarda el nuevo idioma.

Lo puedes ver en la captura que adjunto.

junio 6, 2019 a las 10:55 am #3968349

eduardoR-3

Hola,
He hecho una prueba que creo que ha funcionado:
- He añadido el idioma Portugués que viene por defecto y les he cambiado el valor de la Configuración regional por "pt".
- Luego he creado manualmente otro idioma Portugués, pero a éste le he puesto pt_PT
- Por último, he eliminado el idioma portugués predeterminado.

Esta vez no aparece ningún error y se ha guardado el idioma añadido manualmente.

Supongo que con esto lo he resuelto.
Es solo para que me confirmes que está bien hecho.

Gracias.

junio 6, 2019 a las 11:24 am #3968645

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por su respuesta.

Usted ha realizado los pasos que estaba a punto de sugerirle 🙂
Todo debe funcionar correctamente.

Saludos cordiales,
Carlos