Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 5.46 hours from now. Thank you for your understanding.

This topic contains 14 respuestas, has 2 mensajes.

Last updated by Silvia Tejera hace 1 año, 7 meses.

Assigned support staff: Otto.

Autor Publicaciones
junio 4, 2018 a las 5:28 pm #2271093

Silvia Tejera

Estoy tratando de: Instalar WPML

URL de (mi) sitio web donde aparece el problema: /wp-admin/admin.php?page=sitepress-multilingual-cms%2Fmenu%2Flanguages.php

Yo esperaba ver: checkbox de selección de Idioma Español durante la instalación

En vez de eso, obtuve: El checkbox de "Español" aparece inactivo, y aún seleccionando otros idiomas no puedo continuar con la instalación.
He probado esta solución https://wpml.org/forums/topic/i-cant-select-english-as-a-language-in-the-language-setting-bold-but-inactive/ pero aún seleccionándolo no continúa con la instalación.
Y he probado también a "Reiniciar" y "Limpiar" toda la configuración de WPML desde la página de Solución de Problemas.

También he comprobado que no puedo cambiar el idioma por defecto en WordPress, está configurado con Español, y aunque lo cambie de idioma y lo guarde, vuelve a estar en Español.

Gracias.

junio 4, 2018 a las 5:36 pm #2271098

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Por favor, en primer lugar, ¿podrías incrementar la Memory Limit y WP Memory Limit a 256M? Si puedes suministrar más recursos, sería ideal.
Tus valores actuales son:
- MemoryLimit 768M
- WP Memory Limit 40M
https://wpml.org/home/minimum-requirements/

Edita tu archivo wp-config.php y agrega la siguiente línea:

define('WP_MEMORY_LIMIT', '256M');

Muchas veces estos ajustes son bloqueados directamente desde la administración de tu hosting. En ese caso te recomiendo que los contactes directamente y si puedes pedir valores superiores a 128M, sería recomendable.

Nota: 128M es el mínimo necesario para WPML sin otros plugins y con un tema por defecto de WordPress.

Una vez hecho esto, reinicia WPML (SOLO si no tienes contenido traducido aún).

Luego, si fuera posible para ti, prueba lo siguiente:

***Antes de continuar haz un backup completo y confiable***

-Desactiva todos los plugins
-Cambia a un tema por defecto de WP (Twenty Sixteen por ejemplo)
-Activa WPML y realiza la configuración
-Si el problema desaparece, reactiva uno por uno los plugins y el tema

Quedo a la espera de tus resultados.

Un saludo cordial,

Otto

junio 4, 2018 a las 7:58 pm #2271513

Silvia Tejera

Gracias por la respuesta.

He modificado el límite de memoria a 256M tanto en wp-config.php como ha indicado, como en php.ini, pero WPML sigue especificando 40M.

He reiniciado WPML sin resultado

Desactivé todos los plugins y cambié el theme a uno por defecto y tampoco

He vuelto a reiniciar y todo sigue igual

Y por último desinstalé y borré las tablas icl de la base de datos, y volví a instalar y tampoco hubo resultado.

junio 4, 2018 a las 10:44 pm #2272042

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Muchas gracias.

Para poder investigar mejor el problema necesitaría, si fuera posible, que me permitas acceder a tu sitio temporalmente. Mucho mejor si tuvieras un sitio de pruebas en donde esté replicado el problema.

Encontrarás los campos necesarios debajo del área de comentarios. He marcado la próxima respuesta como privada, por lo que la información que ingreses solo la veremos tu y yo.

Es posible que necesite replicar tu sitio localmente. Para eso voy a necesitar instalar un plugin llamado "Duplicator". Con él podré crear una copia completa de tu web. Una vez que el problema esté resuelto, borraré la copia local. Dime por favor si estás de acuerdo.

** IMPORTANTE **

- Por favor haz un back up completo de tu sitio y base de datos antes de proveer los datos de acceso

- Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

En ese caso, pídeme que vuelva a habilitar una respuesta privada.

Muchas gracias.

Un saludo cordial,

Otto

junio 5, 2018 a las 2:16 pm #2275798

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

El Español no es seleccionable en el paso dos dado que es el idioma por defecto seleccionado en el paso uno.

He añadido el inglés y he podido completar el setup sin problemas.

Hay algo que no esté entendiendo adecuadamente? En el sitio en producción ocurre algo diferente?

Gracias!

Quedo a la espera de tu respuesta.

Un saludo cordial,

Otto

junio 5, 2018 a las 4:50 pm #2276552

Silvia Tejera

En producción (y juraría que en pruebas también, disculpa si no ha sido así) nunca puedo pasar del paso 2 "Translation languages". Primero no me deja pulsar en "next" eligiendo solo Inglés, y luego si elijo otro idioma adicional me permite pulsar pero vuelve a la misma página, y así contínuamente.

Gracias.

junio 5, 2018 a las 5:56 pm #2276741

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Es posible para ti permitirme acceder al sitio en producción?

Seré lo mas cuidadoso posible pero por favor, no olvides hacer un backup confiable y que puedas restaurar por las dudas.

En general el problema del checkbox deshabilitado se soluciona con este pequeño "hack":
-Posicionas el ratón sobre le checkbox
-Hacés click con el botón derecho > Inspeccionar
-Esto te permite editar el HTLM "en vivo" (los cambios solo afectan a tu navegador no al sitio en si)
-Eliminas el tag "disabled"
-Esto te permite marcar el checbox y continuar

Puede que mi explicación sea complicada, si no puedes hacerlo no te preocupes, solo te lo cuento porque es lo que voy a intentar en tu sitio 🙂

Marco la próxima respueta como privada.

Un saludo cordial,

Otto

junio 5, 2018 a las 6:35 pm #2276930

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Disculpa, lo había olvidado.

He descargado el Duplicator Package y lo he instalado localmente y también pude completar el setup.

Tu sitio de pruebas y el sitio en producción están en el mismo servidor? Si no es así, puede ser problema de Siteground. Es posible deshabilitar las opciones de caching en el lado del servidor?

Por otro lado, una solución poco elegante pero que puede funcionar es: migrar el sitio en producción al sitio de pruebas, completar el setup y volver a migrarlo. Es viable? Te parece una solución razonable?

Quedo a la espera de tu respuesta.

Un saludo cordial,

Otto

junio 5, 2018 a las 6:45 pm #2276940

Silvia Tejera

Hola, no, están en servidores distintos; pero hay otras instalaciones wordpress en el mismo servidor dónde sí se ha podido instalar WPML sin problemas. Voy a probar esto último que me has comentado.
Gracias.

junio 5, 2018 a las 6:48 pm #2276944

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Muchas gracias.

Dime como resulta por favor.

Un saludo cordial,

Otto

junio 8, 2018 a las 1:18 pm #2400150

Silvia Tejera

Hola, Otto, he desactivado la caché del servidor y así he conseguido terminar la instalación del WPML. Pero entonces me han desaparecido las páginas de la web, voy a "páginas" y dice que hay 5 páginas "(0)" en español y "(0)" en inglés y no muestra ninguna... como si no detectara el idioma de las páginas originales y entonces no las sirviera ni en el backend ni en el frontend. ¿Puedo especificar el idioma desde la base de datos? Si quieres echarle un vistazo tienes aún el mismo acceso, pero no actives hoy el WPML, por favor, pues hoy hay una presentación y no quiero que alguien entre y le lleve a la página de error.

Gracias.

junio 8, 2018 a las 1:32 pm #2400176

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Las credenciales no me han funcionado, podrías revisarlas?

Si necesitas enviar nuevas, por favor, edita la respuesta privada anterior.

No publiques información privada en una respuesta normal, ya que quedará expuesta.

De todos modos, creo que el problema que describes se solucionará de esta manera:
Ve a WPML > Support > Troubleshooting > Clean up y haz click en "Set language information"

No ignores la advertencia sobre el backup por favor.

Quedo a la espera de tus resultados.

Un saludo cordial,

Otto

junio 11, 2018 a las 1:18 pm #2405136

Silvia Tejera

Hola, Otto, acabo de cambiar la contraseña en el mensaje privado, ya podrías entrar. No se ha arreglado con lo que me comentabas de Clean up > Set language information. De momento se ha desactivado porque desaparecen las páginas al activarlo.

Gracias.

junio 11, 2018 a las 2:51 pm #2405436

Otto
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hola,

Gracias. Realmente lamento todos estos inconvenientes.

Por favor prueba lo siguente:
Incrementa la WP Memory Limit a 256M? Si puedes suministrar más recursos, sería ideal.
Tus valores actuales son:
- MemoryLimit 768M
- WP Memory Limit 40M
https://wpml.org/home/minimum-requirements/

Edita tu archivo wp-config.php y agrega la siguiente línea:

define('WP_MEMORY_LIMIT', '256M');

Muchas veces estos ajustes son bloqueados directamente desde la administración de tu hosting. En ese caso te recomiendo que los contactes directamente y si puedes pedir valores superiores a 128M, sería recomendable.

Haz un "Reset" de WPML. Haz un backup de tu sitio antes de hacerlo por favor.

-Desactiva todos los plugins
-Cambia a un tema por defecto de WP (Twenty Sixteen por ejemplo)
-Activa WPML y haz el setup

Yo lo he hecho localmente y ha funcionado.

Dime si resulta en tu sitio también por favor.

Un saludo cordial,

Otto

junio 11, 2018 a las 4:38 pm #2405762

Silvia Tejera

Gracias, Otto, se ha solucionado, después hacer un reset ahora sí funciona todo correctamente. Aunque sigue apareciendo 40M por mucho que modifique el wp-config, lo hablaré con el hosting como dices.
Muchas gracias.