Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This topic contains 6 respuestas, has 2 mensajes.

Last updated by Andrés hace 2 años, 2 meses.

Assigned support staff: Andrés.

Autor Publicaciones
agosto 4, 2017 a las 6:25 am #1334805

augustoP

Tell us what you are trying to do?
Instale un certificado SSL en mi sitio, mi sitio no aparece completamente seguro, desistalo el plugin WPML Multilingual CMS y luego me muestra completamente seguro mi url con el candado en la barra del explorador.

El problema que me esta presetando es que algunos enlaces estan apuntando al http y no al https.

Podrian ayudarme por favor.

Augusto P

What is the link to your site?
hidden link

agosto 4, 2017 a las 7:51 am #1334883

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola Augusto,

Bienvenido al soporte de WPML.

Al visitar tu página hidden link, veo a través de la consola el siguiente error:

Mixed Content: The page at '<em><u>hidden link</u></em>' was loaded over HTTPS, but requested an insecure image '<em><u>hidden link</u></em>'. This content should also be served over HTTPS.

Este señala que el logo que se encuentra en la parte inferior viene de un dominio http (no es el caso con el logo superior que viene del https).

1. ¿Podrías ir a Ajustes > Enlaces permanentes y guardar de nuevo tus ajustes? ¿Soluciona tu problema?

2. Si el paso anterior no funciona, podrías utilizar un plugin como el Search & Replace y verificar que todos tus enlaces se han movido correctamente del http hacia el https?
https://wordpress.org/plugins/search-and-replace/

3. Para poderte ayudar más rápidamente he activado la casilla para enviar la información de debug de WPML en este ticket. Por favor, lee el siguiente artículo si tienes dudas de como enviarnos esta información:
https://wpml.org/es/faq/como-proporcionar-informacion-de-depuracion-para-obtener-soporte-mas-rapidamente/

Un saludo,
Andrés

agosto 4, 2017 a las 12:29 pm #1335194

augustoP

Hola Andres, realice los pasos que me indicaste, pero continuo con el problema.
Por lo que puedo ver es un conflicto con static-footer-text.php en get_stylesheet_directory_uri() lo apunta a http y no https, (pero como te explique desactivo el plugin WPML Multilingual CMS y me deja mi url completamente segura)

agosto 4, 2017 a las 1:35 pm #1335265

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por tu información, Augusto.

Para comenzar, ¿podrías desactivar y desinstalar las extensiones las siguientes extensiones ya que desde WPML 3.2 ellas vienen integradas en WPML y WPML Translation Management?
- WPML Translation Analytics
- WPML XLIFF

Por otro lado, acabo de revisar la misma página anterior y continúo viendo que la img del footer viene del http. Como puedes ver se trata de un <img>, por tanto, esta no puede venir de una hoja de estilos.

¿Podrías verificar esta situación?

Finalmente, ¿me podrías qué te hace pensar que el problema viene del static-footer-text.php?

agosto 4, 2017 a las 7:52 pm #1335626

augustoP

Hola Andres, Gracias por la actualizacion,
Ya elimine las extensiones
- WPML Translation Analytics
- WPML XLIFF

Con el plugin Search & Replace verifique y todas las url fueron movidas de http a https incluso la url
hidden link

Cuando borro las <img> de static-footer-text.php el sitio aparece completamente seguro.

A continuacion te copio el codigo static-footer-text.php
<?php /* Static Name: Footer text */ ?>
<div id="footer-text" class="footer-text">
<?php $myfooter_text = apply_filters( 'cherry_text_translate', of_get_option('footer_text'), 'footer_text' ); ?>

<?php if($myfooter_text){?>
<?php echo $myfooter_text; ?>
<?php } else { ?>

<a href="<?php echo home_url(); ?>/" class="logo_h logo_h__img"><img src="<?php echo get_stylesheet_directory_uri(); ?>../images/footer_logo.png" alt="<?php bloginfo('name'); ?>" title="<?php bloginfo('description'); ?>"></a>
© <?php echo date ('Y'); ?>
<a href="<?php echo home_url(); ?>/privacy-policy/" title="<?php echo theme_locals('privacy_policy'); ?>"><?php echo theme_locals("privacy_policy"); ?></a>

<?php } ?>
<?php if( is_front_page() ) { ?>

<?php } ?>
</div>

Agradezco tu ayuda.

agosto 4, 2017 a las 9:21 pm #1335675

augustoP

Hola Andres, Gracias por la actualizacion,
Ya elimine las extensiones
- WPML Translation Analytics
- WPML XLIFF

Con el plugin Search & Replace verifique y todas las url fueron movidas de http a https incluso la url
hidden link

Cuando borro las <img> de static-footer-text.php el sitio aparece completamente seguro.

A continuacion te copio el codigo static-footer-text.php
<?php /* Static Name: Footer text */ ?>
<div id="footer-text" class="footer-text">
<?php $myfooter_text = apply_filters( 'cherry_text_translate', of_get_option('footer_text'), 'footer_text' ); ?>

<?php if($myfooter_text){?>
<?php echo $myfooter_text; ?>
<?php } else { ?>

<a href="<?php echo home_url(); ?>/" class="logo_h logo_h__img"><img src="<?php echo get_stylesheet_directory_uri(); ?>../images/footer_logo.png" alt="<?php bloginfo('name'); ?>" title="<?php bloginfo('description'); ?>"></a>
© <?php echo date ('Y'); ?>
<a href="<?php echo home_url(); ?>/privacy-policy/" title="<?php echo theme_locals('privacy_policy'); ?>"><?php echo theme_locals("privacy_policy"); ?></a>

<?php } ?>
<?php if( is_front_page() ) { ?>

<?php } ?>
</div>

Agradezco tu ayuda.

agosto 7, 2017 a las 6:49 am #1336132

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola Augusto,

Gracias por tu aclaración. Finalmente, creo que estábamos hablando de lo mismo. Si revisas la captura de pantalla aquí adjuntada, verás que la imagen a la que me refiero sigue proviniendo del http, y además esta es la imagen proveniente del static-footer. Es por esta razón que cuando la borras, todo se soluciona.

He revisado, y esta imagen sigue proviniendo del dominio http, ¿podrías revisarlo de nuevo?

Saludos,
Andrés