Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This thread is resolved. Here is a description of the problem and solution.

Problem: Mi sitio web cambie de idioma y aparezca en el idioma que pinchas. Resulta que si tú pones la URL en español y cambias al ingles (que es el idioma principal) sí va. Pero si lo haces del ingles al español no funciona vuelve a salir en inglés.

Solution: La causa del problema es que las páginas no están traducidas al Español. Por favor traduzca las páginas siguiendo los pasos descritos en este enlace: https://wpml.org/es/documentation-2/traducir-los-contenidos/

Relevant Documentation:

This topic contains 13 respuestas, has 2 mensajes.

Last updated by mistwallS hace 1 mes, 3 semanas.

Assigned support staff: Carlos Rojas.

Autor Publicaciones
agosto 13, 2019 a las 10:46 am #4387131

mistwallS

Estoy tratando de: Mi sitio web cambie de idioma y aparezca en el idioma que pinchas. Resulta que si tú pones la URL en español y cambias al ingles (que es el idioma principal) sí va. Pero si lo haces del ingles al español no funciona vuelve a salir en inglés.

URL de (mi) sitio web donde aparece el problema: hidden link

Yo esperaba ver:

En vez de eso, obtuve:

agosto 13, 2019 a las 11:01 am #4387283

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por contactar con el servicio de soporte de WPML.

1.- Me gustaría pedirle que realice los siguientes pasos:
- Cree una copia de seguridad del sitio completo.
- Actualice todos los plugins y temas desactualizados.
- Borre cualquier memoria cache que pueda existir.
- Asegúrese que las páginas están correctamente traducidas.
- Ve a WPML -> Support -> Enlace 'Troubleshooting' -> Aplica las opciones señaladas en la imagen adjunta.

Me puede decir el resultado de los pasos anteriores?

2.- Por favor suministre la información de depuración del sitio siguiendo los pasos descritos en este enlace: https://wpml.org/faq/provide-debug-information-faster-support/

Saludos cordiales,
Carlos

agosto 13, 2019 a las 11:26 am #4387383

mistwallS

He realizado paso a paso lo que me ha indicado y sigue igual.

agosto 13, 2019 a las 11:34 am #4387401

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,

En este caso me gustaría solicitar acceso temporal al sitio (wp-admin y FTP) con el objetivo de ver el problema más de cerca. Su próxima respuesta será privada y en ella encontrará los campos correspondientes a las credenciales solicitadas.

Aunque no realizaré ningún cambio en el sitio siempre es recomendable crear una copia de seguridad del sitio completo antes de compartir las credenciales de acceso.

Saludos,
Carlos

agosto 13, 2019 a las 11:57 am #4387693

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por las información suministrada.

La causa del problema es que las páginas no están traducidas al Español. Por favor traduzca las páginas siguiendo los pasos descritos en este enlace: https://wpml.org/es/documentation-2/traducir-los-contenidos/

Puede confirmar que el problema está resuelto?

Saludos,
Carlos

agosto 13, 2019 a las 12:20 pm #4387943

mistwallS

Hola buenas.

He leído el artículo que me ha enviado. Las páginas están traducidas tal cual pone en el documento. Le adjunto una captura para que veas que las páginas están hechas. De hecho sino no aparecería en español. Si pone hidden link le sale la página entera traducida al español. Pincha en el menú y le da al cambio de idioma (en este caso, inglés) y se cambia correctamente. Ahora haga click en ver la página en español y no funciona. Le dejo adjuntado la captura para que vea que la home está en español.

agosto 13, 2019 a las 2:09 pm #4388733

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,

Al parecer se han creado las páginas en Español, pero de manera separada y no siguiendo la documentación de WPML. Para crear una traducción de una página o un post debe hacer click en el símbolo de más (+) esto lo llevará al editor de traducción que tenga activo o simplemente al editor de WordPress si tiene establecida la traducción como manual.

Sin embargo, estas páginas se pueden enlazar con sus traducciones. Le pido que realice los siguientes pasos;
- Edita las páginas en Español -> En el bloque de idiomas que aparece a la derecha debe aparecer la opción de 'Esta es una traducción de' y ahí puede seleccionar la página en Inglés que corresponde.

Le pido que visite este enlace donde encontrará los pasos a seguir para traducir el contenido correctamente: https://wpml.org/es/documentation-2/traducir-los-contenidos/

Saludos cordiales,
Carlos

agosto 13, 2019 a las 2:32 pm #4388861

mistwallS

Finalmente lo he solucionado de la otra manera. Me he dado cuenta de que estaban hechas, pero no enlazadas. Me he metido en páginas y le he dado al botón de (+) y ya he hecho la traducción correctamente. Está todo enlazado !! Pero ahora hay un enlace de la web en inglés (que se ha puesto solo) hidden link lo que ves justo después del .com se ha añadido automáticamente y en esa única pestaña ¿por qué ha sucedido?

Y otra pregunta ¿cómo puedo poner la selección de idioma fuera del menú? Para que sea visible a simple vista.

Gracias!!

agosto 14, 2019 a las 9:15 am #4393699

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Me alegra saber que el problema original está resuelto 🙂

Lo siento pero no he entendido el problema del enlace en la web. Le pido que adjunte una captura de pantalla y señale el enlace, de esta manera será más fácil comprenderlo.

Nota: Con respecto a selector de idiomas y cómo ponerlo en otros lugares de la web le pido que visite este enlace donde encontrará los pasos a seguir para lograrlo: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#custom-locations

Saludos cordiales,
Carlos

agosto 14, 2019 a las 10:10 am #4394043

mistwallS

Hola mira, respecto al problema que te estaba comentando del enlace, tras la traducción. Ahora el enlace (unicamente ese enlace en inglés) me sale así como te voy a adjuntar en fotos.

Un saludo

agosto 14, 2019 a las 11:03 am #4394367

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,

Esta estructura de la URL se debe a que la página 'About us' es hija de la página Home. Para resolver este problema solo debes editar la página 'About us' y en la columna derecha, dentro del bloque 'Page attributes' vas a encontrar que en la opción 'Parent' está seleccionado 'Home'. Debe dejar en blanco esta opción y guardar los cambios.

Saludos cordiales,
Carlos

agosto 20, 2019 a las 8:32 am #4421589

mistwallS

Hola buenas,

Respecto al tema de las banderas quiero añadirlas fuera del menú, ya que el menú que tengo en la web es el siguiente (véase la imagen). Quiero que se quede justo al lado de las 3 rayitas. Leí el documento que me pasaste, pero no sé que códigos tengo que añadir ni dónde. Si fueras tan amable de ayudarme con eso, te lo agradecería.

agosto 20, 2019 a las 8:48 am #4421745

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,

Como este problema es diferente del original le pido amablemente que cree un nuevo ticket y me lo asigne directamente. De esta manera estaremos siguiendo las reglas del foro de tener un problema por ticket. De esta manera también estaremos ayudando a futuros clientes a encontrar respuestas a problemas similares de manera más fácil cuando busquen en el foro.

Muchas gracias por su comprensión.
Saludos cordiales,
Carlos

agosto 20, 2019 a las 8:56 am #4421857

mistwallS

My issue is resolved now. Thank you!