Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Our next available supporter will start replying to tickets in about 3.79 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: Desaparece Menú en los productos de la tienda en Inglés

Solution:He realizado los siguientes pasos en el producto 'Pañuelo las Velas' y el problema ha desaparecido: - Edité el producto en el idioma original (Español) -> Hice click en el botón 'Actualizar' -> Actualicé la traducción -> Guardé los cambios y el problema desapareció.

Relevant Documentation:

This topic contains 9 respuestas, has 2 mensajes.

Last updated by Carlos Rojas hace 2 meses, 1 semana.

Assigned support staff: Carlos Rojas.

Autor Publicaciones
julio 31, 2019 a las 12:00 pm

Jose Manuel Gómez-Zorrilla Sanjuán

Estoy tratando de: arreglar mi sitio

URL de (mi) sitio web donde aparece el problema: hidden link

Yo esperaba ver: el menú dentro de los productos en inglés

En vez de eso, obtuve: un gran disgusto

Un saludo.

julio 31, 2019 a las 1:55 pm #4314915

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por contactar con el servicio de soporte de WPML.

Al parecer la causa del problema era que faltaba la traducción de la página de la tienda (shop) al idioma secundario. He creado la página y el problema parece haber desaparecido.

Puede confirmar que el problema desapareció?

Saludos cordiales,
Carlos

agosto 1, 2019 a las 7:58 am #4319467

Jose Manuel Gómez-Zorrilla Sanjuán

Hola, seguimos sin ver el header en los productos en Inglés.

Muchas gracias!

Carlos

agosto 1, 2019 a las 11:28 am #4321113

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por su respuesta.

He intentado volver a revisar el problema pero el sitio no me carga. Puede revisar que el sitio este funcionando correctamente?

Saludos,
Carlos

agosto 1, 2019 a las 1:40 pm #4322419

Jose Manuel Gómez-Zorrilla Sanjuán

Hola, ahora ya debes de poder entrar correctamente, el problema persiste tanto en;

- hidden link
- hidden link (el acceso para esta no deberías de tener problema)

Te paso el user y el pass para ambos sitios;
User: ***
Pass: ***

Un saludo.

agosto 1, 2019 a las 6:27 pm #4324641

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por las credenciales suministradas.

He accedido al sitio y realizado los siguientes pasos:
- Borrar la cache del plugin Varnish Cache.
- Desactivar el plugin Varnish Cache que tiene problemas conocidos de compatibilidad con WPML.
- Ir a WPML -> Idiomas -> Activar la opción de 'Filtrado de idiomas para operaciones AJAX'.

Ahora el problema está resuelto (ver las imágenes adjuntas).

Puede confirmar que el problema esté resuelto?
Saludos,
Carlos

agosto 2, 2019 a las 7:11 am #4327321

Jose Manuel Gómez-Zorrilla Sanjuán

Buenos dias,

Por desgracia el problema sigue persistiendo en algunos productos (adjunto imágenes).

Por otro lado, en la tienda del Museo Arquelogico Nacional, no tenemos instalado el plugin Varnish Cache, sin embargo tenemos exactamente el mismo problema.

Un saludo.

agosto 2, 2019 a las 12:24 pm #4329955

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,
Muchas gracias por su respuesta.

He realizado los siguientes pasos en el producto 'Pañuelo las Velas' y el problema ha desaparecido:
- Edité el producto en el idioma original (Español) -> Hice click en el botón 'Actualizar' -> Actualicé la traducción -> Guardé los cambios y el problema desapareció.

Sospecho que cuando se crearon y tradujeron dichos productos, por alguna razón no estaba configurada la opción del header y por lo tanto cuando esta vez se vuelven a actualizar los productos y sus traducciones se guarda esta opción y se muestra correctamente el header.

Con respecto al otro sitio, le pido amablemente que realice los mismos pasos y me diga si el problema persiste.
Saludos cordiales,
Carlos

agosto 5, 2019 a las 9:57 am #4339533

Jose Manuel Gómez-Zorrilla Sanjuán

Ya está todo arreglado, he realizado el mismo proceso para todos los productos y ya no desaparece el header en inglés. Muchas gracias!

agosto 5, 2019 a las 12:04 pm #4340399

Carlos Rojas
Supporter

Languages: Inglés (English ) Español (Español )

Timezone: America/Montevideo (GMT-03:00)

Hola,

Me alegra saber que el problema está resuelto 🙂

Por favor no dude en contactarnos si necesita de nuestra ayuda en el futuro con WPML.
Saludos cordiales,
Carlos