Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

This topic contains 8 respuestas, has 2 mensajes.

Last updated by juanR-19 hace 1 año, 5 meses.

Assigned support staff: Andrés.

Autor Publicaciones
mayo 28, 2018 a las 11:21 am #2238120

juanR-19

Estoy tratando de: Hola, tengo WPML en varias páginas y no me ha dado problema, estoy intentando traducir una página nueva y no visualizo los cambios, no se ve el menú de idioma, tengo actualizado tanto el wordpress como el wpml.

URL de (mi) sitio web donde aparece el problema:
hidden link
Yo esperaba ver: Como en esta página
hidden link
En vez de eso, obtuve:

mayo 28, 2018 a las 2:51 pm #2239505

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Hola,

Bienvenido al soporte de WPML.

Creo que esta situación se debe a los ajustes de tu tema y no de WPML. Verificando el código HTML de la página en cuestión puedes ver las etiquetas hreflang para los dos idiomas por lo cual el problema no viene de allí.

Es más, ningún otro elemento de la barra negra aparece, ¿podrías revisar los ajustes de tu tema o de la ésta página en particular y verificar que todo se encuentra en orden?

Un saludo,
Andrés

mayo 29, 2018 a las 6:19 am #2242984

juanR-19

Hola, podrías decirme pasos a seguir, ya que he utilizado el mismo tema para cuatro webs con WPML y no me dio problemas, sin embargo en esta no hay manera. Gracias!

mayo 29, 2018 a las 6:32 am #2242991

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Lo siento pero no estoy familiarizado con tu tema Moose y tampoco se encuentra en nuestra lista de compatibilidad.
https://wpml.org/documentation/theme-compatibility/

1. ¿Si desactivas WPML, la página en cuestión se ve cómo deseas?

2. Si no es así, te recomiendo que revises los ajustes del tema o que contactes al autor de mismo para que te ayude a configurarlo correctamente.

Saludos

mayo 29, 2018 a las 6:58 am #2243009

juanR-19

Hola, ya he encontrado el problema, los widgets están creados pero el tema no me los muestra. Voy a personalizar tema y el widget Header Top left (es el que utilizo para ubicar el menú WPML) está creado pero no me lo muestra, como puedo cambiar esto???

mayo 29, 2018 a las 7:05 am #2243104

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Lo siento, pero esta situación parece vinculada a tu tema y no a WPML. ¿Si apagas nuestro plugin la situación cambia?

mayo 29, 2018 a las 7:10 am #2243155

juanR-19

Lo extraño es que tengo el WPML instalado en 4 wordpress con el mismo tema y los mismo plugins, no entiendo cual es el problema... Si he probado a desactivar y no se visualiza tampoco

mayo 29, 2018 a las 7:15 am #2243161

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+01:00)

Te entiendo perfectamente, pero el problema como puedes ver no viene de WPMl si no de tu tema. Nuestro selector simplemente no se visualiza por que tu tema no visualiza la barra. Una vez lo logres, nuestro selector deberá verse también.

Si una vez logres visualizar la barra de tu tema, nuestro selector aún no se ve, estaremos encantados de ayudarte.

Gracias por tu comprensión.
Saludos

mayo 30, 2018 a las 8:48 am #2249583

juanR-19

Resuelto