Este es el foro de soporte técnico de WPML, el plugin multilingüe de WordPress.

Todas las personas pueden leerlo pero solo los clientes de WPML pueden ingresar comentarios. El equipo de WPML responde en el foro 6 días a la semana, durante 22 horas por día.

Hoy no hay asistentes de soporte disponibles en el foro Spanish. Siéntase libre de enviar sus tiques y les daremos trámite tan pronto como estemos disponibles en línea. Gracias por su comprensión.

This topic contains 21 respuestas, has 2 mensajes.

Last updated by Andrés hace 3 meses, 3 semanas.

Assigned support staff: Andrés.

Autor Publicaciones
junio 20, 2019 a las 11:02 am #4059197

Iñigo

Hi,

We're having a problem when we try to duplicate some Custom Post Types.

Our context:

We have installed and configured WPML in 3 languages: Spanish (default), English and Fench.

We have created Product Custom Post Type with his Taxonomies. When we duplicate from Spanish to English we didn't hane any problems. Everything added.

Now we are adding French contents and in this case, some images didn't duplicate. First, we click "Rewrite with spanish content" button and duplicate, but now nothing.

We don't understand why before duplicate correctly and now is returning this problems.

Can you help us?

Thanks in advance,

junio 20, 2019 a las 1:32 pm #4060191

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Bienvenido al soporte de WPML.

1. ¿Me puedes confiramar si estás duplicando desde el Español hacia el Francés?

2. ¿Puedes verificar que has marcado las casillas para copias las imágenes en el artículo original antes de duplicarlo?

3. Para asegurarnos que WPML funcione correctamente, ¿podrías incrementar la Memory Limit y WP Memory Limit a 256M? Si puedes suministrar más recursos, sería ideal.
Tus valores actuales son:
- MemoryLimit 128M
- WP Memory Limit 128M
https://wpml.org/home/minimum-requirements/

Muchas veces estos ajustes son bloqueados directamente desde la administración de tu hosting. En ese caso te recomiendo que los contactes directamente y si puedes pedir valores superiores a 128M, sería recomendable.

Nota: 128M es el mínimo necesario para WPML sin otros plugins y con un tema por defecto de WordPress.

Un saludo,
Andrés

junio 20, 2019 a las 1:43 pm #4060327

Iñigo

Hola Andrés,

Te voy respondiendo a las consultas que nos has enviado:

1. ¿Me puedes confirmar si estás duplicando desde el Español hacia el Francés?

Si, estamos tratando de duplicar de Español hacia Francés. Cuando lo hemos hecho hacia Inglés como en un inicio también al Francés funcionaba correctamente.

Es desde hoy que nos han surgido los problemas.

2. ¿Puedes verificar que has marcado las casillas para copias las imágenes en el artículo original antes de duplicarlo?

Si, está. Piensa que al Inglés lo hace correctamente y al Francés también lo hizo en un inicio.

3. Para asegurarnos que WPML funcione correctamente, ¿podrías incrementar la Memory Limit y WP Memory Limit a 256M? Si puedes suministrar más recursos, sería ideal.
Tus valores actuales son:
- MemoryLimit 128M
- WP Memory Limit 128M
https://wpml.org/home/minimum-requirements/

Muchas veces estos ajustes son bloqueados directamente desde la administración de tu hosting. En ese caso te recomiendo que los contactes directamente y si puedes pedir valores superiores a 128M, sería recomendable.

Nota: 128M es el mínimo necesario para WPML sin otros plugins y con un tema por defecto de WordPress.

Nosotros actualmente lo tenemos puesto a 128MB desde el htaccess (hidden link)

Si necesitas cualquier otra cosilla nos comentas.

Un saludo,

junio 21, 2019 a las 5:29 am #4064721

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Hola,

Gracias por tus comentario.

1. ¿Podrías aumentar tu Memory Limit y WP Memory Limit a 256M? Como te decía anteriormente 128M pueden no ser suficientes.

2. ¿Me podrías decir cómo has agregado las imágenes problema de una manera detallada?

3. Ve a WPML > Configuración -> Traducción de multimedia y verifica tus ajustes:
- Definir información de idioma para los elementos multimedia existentes
x Traducir los elementos multimedia existentes a todos los idiomas
x Duplicar los elementos multimedia existentes para el contenido traducido
x Duplicar las imágenes destacadas para el contenido traducido
- Da click en el botón "Iniciar".

En el siguiente artículo podrás encontrar más información al respecto:
https://wpml.org/documentation/getting-started-guide/media-translation/

junio 21, 2019 a las 6:36 am #4064939

Iñigo

Hola Andrés

Te respondo a cada punto 😉

1. ¿Podrías aumentar tu Memory Limit y WP Memory Limit a 256M? Como te decía anteriormente 128M pueden no ser suficientes.

Aumentado a 256.

2. ¿Me podrías decir cómo has agregado las imágenes problema de una manera detallada?

Nosotros hemos creado una serie de Metaboxes asociados al Custom Post Type de Producto, mediante el plugin de Metabox. Una vez agregado el contenido, lo que hacemos es duplicar desde Español. Hasta hace muy poco funcionaba correctamente, pero no se si es que es un tema de memoria...

3. Ve a WPML > Configuración -> Traducción de multimedia y verifica tus ajustes:
- Definir información de idioma para los elementos multimedia existentes
x Traducir los elementos multimedia existentes a todos los idiomas
x Duplicar los elementos multimedia existentes para el contenido traducido
x Duplicar las imágenes destacadas para el contenido traducido
- Da click en el botón "Iniciar".

En el siguiente artículo podrás encontrar más información al respecto:
https://wpml.org/documentation/getting-started-guide/media-translation/

En realidad no es un tema de traducir la propia imagen, lo que quiero es que al duplicar y sobreescribir con el idioma Español, lo agregue automaticamente.

Cualquier cosilla al respecto nos lo comentas.

Un saludo,

junio 21, 2019 a las 8:42 am #4065545

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias por la aclaración. Revisemos entonces si no se trata debido a un cambio, ya sea por una actualización de WPML, o de tu plugin Metabox ya que no se encuentra en nuestra lista de compatibilidad. Sin embargo esto no significa necesariamente que no lo sea, simplemente nuestro equipo no lo ha probado hasta el momento.
https://wpml.org/documentation/plugins-compatibility/

He creado un sitio de pruebas para ti. Puedes acceder a este simplemente haciendo click en en siguiente enlace:
hidden link

La idea es que cargues tu plugin Metabox y nos ayudes a reproducir el problema. De esta manera, si efectivamente se trata de un problema de compatibilidad, podremos acelerar el proceso y contactar a nuestro Equipo de compatibilidad y trabajar con el autor en la resolución de tu problema.


No tienes que recrear tu sitio, simplemente instalar lo mínimo necesario para reproducir el problema.

junio 21, 2019 a las 12:01 pm #4066905

Iñigo

Hola Andrés,

Entiendo que no es compatible con WPML, pero la realidad es que ha estado funcionando. Por tanto, me parecería raro que esa fuese la causa del problema.

Replicarlo todo en vuestro entorno es muy laborioso para nosotros... Casi es mejor que accedáis vosotros a nuestro entorno y hagáis alguna prueba controlada con algún producto de prueba. ¿Podría ser?

Un saludo,

junio 21, 2019 a las 1:47 pm #4067549

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Entiendo que esto pueda tomar tiempo, pero si se trata de un problema de compatibilidad, tendremos que hacer esta prueba de todas maneras. La idea es:
- Instalar el plugin.
- Crear un campo de imagen asociado a un post como en tu sitio.
- Duplicar la página.

Otra prueba que puedes hacer en tu entorno es:
- Crear una nueva página con dichos campos.
- Duplicarla en los diferentes idiomas.
¿Se comporta igual?

Saludos

junio 24, 2019 a las 7:15 am #4075003

Iñigo

Hola Andrés,

Respecto a las 2 pruebas que nos comentas:

1) Lo entendemos, y si quieres lo hacemos. Pero la cuestión es que necesitaríamos también poder crear nuestro custom post type para que la prueba sea real. Si no tampoco estaríamos creando el mismo escenario que en nuestro entorno, por lo que no se si serviría...

Pero lo dicho, si lo ves necesario nosotros lo hacemos y os lo montamos en vuestro entorno.

2) Si, hemos realizado varias pruebas y sigue sucediendo. La cuestión es que cuando dimos de alta el contenido en inglés duplicado del Español el proceso era correcto y al duplicar traía toda la información. Es raro que ahora no lo coja directamente y tengamos que volver a dar al botón de "Sobrescribir del Español".

junio 24, 2019 a las 7:33 am #4075035

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Buenos días,

Entiendo lo que dices, sin embargo, tal vez no sea necesario crear un Custom Post Type para ello. Si el problema se reproduce con un artículo por defecto, seguramente sucederá con un Custom Post Type.

Por otra parte, hay algo que no tengo claro: ¿quieres decir que cuando duplicas un artículo las imágenes no se copian, sin embargo, cuando le das al botón "Sobrescribir del Español" si?

Gracias a los resultados que has hallado, sabemos que no se trata de una limitación ligada al idioma, si no algo relacionado con alguna nueva actualización o instalación.

En tu sitio de prueba podrías revisar que esta situación se presenta cuando:
- Sólo el paquete WPML está activado. Esto nos dirá si hay algún problema de interacción con otro plugin.
- Cambias a un tema por defecto de WordPress como el Twenty Fourteen. Esto nos dirá si hay un problema de interacción con tu tema.
- Si el problema desaparece, activa uno por uno para determinar quién genera esta situación.

Saludos

junio 24, 2019 a las 9:58 am #4076165

Iñigo

Hola Andrés,

Si finalmente vemos necesaria esaa prueba la realizamos, pero te respondo al resto de los puntos:

1) Por otra parte, hay algo que no tengo claro: ¿quieres decir que cuando duplicas un artículo las imágenes no se copian, sin embargo, cuando le das al botón "Sobrescribir del Español" si?

De hecho hay parte de las imágenes, como por ejemplo la imagen destacada, que si se copian. Pero en general sí, ese sería nuestro problema. El contenido se copia correctamente pero las imágenes no hasta que le damos a ese botón. Entonces ya las carga.

2) Gracias a los resultados que has hallado, sabemos que no se trata de una limitación ligada al idioma, si no algo relacionado con alguna nueva actualización o instalación.

En tu sitio de prueba podrías revisar que esta situación se presenta cuando:
- Sólo el paquete WPML está activado. Esto nos dirá si hay algún problema de interacción con otro plugin.
- Cambias a un tema por defecto de WordPress como el Twenty Fourteen. Esto nos dirá si hay un problema de interacción con tu tema.
- Si el problema desaparece, activa uno por uno para determinar quién genera esta situación.

Hemos quitado todos los plugins salvo los de WPML y el Metabox, ya que este último nos proveía de las imágenes esas que no duplica desde el Español. En este caso, también ha generado el problema.

Cualquier cosilla más que necesites nos comentas.

Un saludo,

junio 24, 2019 a las 1:02 pm #4077321

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Para descartar cualquier interferencia de tu servidor he creado un sitio de prueba en nuestro servidor Cloudways.

En el mensaje privado anterior encontrarás las indicaciones necesarias para la migración.

Saludos

junio 25, 2019 a las 7:36 am #4081805

Iñigo

Hola Andrés,

Migración finalizada, pero da algún tipo de error.

Revísalo y cualquier cosilla nos comentas.

Eskerrik asko!!

junio 25, 2019 a las 10:40 am #4083393

Andrés
Supporter

Languages: Inglés (English ) Español (Español ) Francés (Français )

Timezone: Europe/Paris (GMT+02:00)

Gracias, Iñigo. El problema de la instalación parece ligado al hecho de que utilizas una estructura personalizado de tu carpeta /wp-content/. Para tener las mismas credencias, ¿podrías editar el mensaje privado anterior y compartirlas allí?

Saludos

junio 25, 2019 a las 10:47 am #4083407

Iñigo

Hola Andrés,

La verdad es que no te comprendo a que te refieres,...

No se que quieres que haga para solventar el error.

Un saludo,